[Solved] GCal3 "got new token"

I’ve been using the google calendar switch successfully for quite a while until recently it stopped working, as listed in this thread:
http://forum.micasaverde.com/index.php/topic,26692.msg418778.html#msg418778
As per the directions in that post, I installed the replacement GCal3.lua file, which apparently fixed the initial issue, but now I’ve got a different problem: The “next event” section just says “CalendarID is set” and “Got new token”, but never actually shows the next event, even after several days and several full restarts. Further, trying to do anything in the plugin such as clicking “Get Log” or “Check” just gives me a “Device Not Ready” error.

I’m running on UI7 on a Vera Plus. Any ideas how I can get this working again? Thanks.

I’m in the process of creating a new release with this fix as well as a couple of small modifications.

There have been 20 or so downloads and it seems no-one else is reporting this problem so I’m guessing that something went wrong during your install. Try downloading this slightly modified version

http://forum.micasaverde.com/index.php/topic,26692.msg419766.html#msg419766

and then rebooting.

What version of GCal3 were you on before ?

Looks like you might be right. I used a different browser (Chrome) this time to do the upload, and after re-setting the calendar ID (as the post said would be needed), it came right up. Not sure what happened the first time, but at least it is working again now. Thanks!

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules