SOLVED: VeraPlus Can't Connect to Internet

I had difficulty in connecting the VeraPlus to the internet on my home network, but I was able to get it working well after spending several hours troubleshooting, and so I would like to share what I discovered in case it benefits others.

Below were the symptoms of my problem.

  1. I use Comcast Xfinity for my ISP, and a Motorola Surfboard cable modem which I own.
  2. I connected the VeraPlus to my router (Linksys EA6300) using an ethernet cable.
  3. When powering the VeraPlus, the internet and service lights blinked slowly. All other lights were on solid after it completed its power up sequence.
  4. The setup utility could not find the VeraPlus on the network. I was able to complete the process by manually entering the mios ID and MAC address, but then it took a long time to finish loading the controller software, and upon completion of loading, the dashboard reported that the VeraPlus was offline.
  5. On the router webpage, I could see that the VeraPlus MAC address was assigned an IP address by DHCP, but neither the router’s ping utility or ping run from a command prompt was able to ping the VeraPlus.
  6. The behavior described in #4 was true with the Windows 10 laptop PC I was using connected to the network via Wi-Fi and also connected to the router using an ethernet cable.
  7. As a troubleshooting step, I connected the VeraPlus on the network at my work, and the VeraPlus was able to connect to the internet (all lights solid green), and was able to complete the setup utility per the normal process.
  8. As another troubleshooting step, I bought a new router (Netgear AC1750) and tried all of the same steps on my home network, and the behavior was unchanged.
  9. I will spare you the details, but I also tried a variety of router settings, including port forwarding, turning on DMZ, and setting up a DHCP reservation for the VeraPlus, all with no effect on the behavior.

Below is what I did to correct the issue:

  1. On my work network, I went to the “Net & Wi-Fi” tab under the Settings tab and changed the “How does Vera connect to the Internet?” response to “Manually configure (advanced)”.
  2. Then, I changed the Network Connection Type to “Static IP”, and changed the static IP address to an IP address on the same subnet as my home network router, but the last number to an address that is outside of the DHCP range. For example, my router IP address is, and it assigns DHCP IP addresses in the range from to I set the VeraPlus static IP address to
  3. I then changed the subnet mask to, the gateway to, and set the DNS numbers to the values specified by my router on the router’s web page.
  4. I then disabled the firewall and turned off DHCP server (already was off).
  5. After making these changes, the VeraPlus could no longer communicate on my work network since my work network does not use 192.168.1.x IP addresses, but when connecting the VeraPlus on my home network, it worked correctly.

I spent an hour with VeraPlus tech support and another hour with Comcast tech support, and neither suggested trying the things that I did to get connected. The company that was very helpful in solving my problem was, which is who I purchased the VeraPlus from. ZWaveOutlet’s tech support recommended the actions that were able to get my Vera connected in a 10 minute conversation. If you are in the market for a Vera device, I strongly recommend buying from

So what do you figure is the root of the problem in your home network? Why is the vera not pulling the correct parameters from the router?

You are very patient, i would have returned the thing as defective, but then again, there maybe nothing wrong with the vera…

Thanks for sharing.

I don’t know what the root cause is of the issue in my home network. I don’t think it is router related since two different routers did not change the problem. My best guess is something with Comcast Xfinity internet service or with the cable modem itself. I own my cable modem instead of rented, and so maybe the modem is not handle something the way it should for most Comcast customers who get an official modem from Comcast.

I fully expect that any VeraPlus will have the same problem on my home network, not just the one I have.

The reason for my patience is that I administer a wireless sensor system at work that uses the VeraPlus and it works very well, and so I wanted to set up the same thing at my home. The wireless sensors are built from components using open source firmware and hardware, and the firmware is written for the VeraPlus. You can visit for more information. The sensors I have built for work were similar to the sensor designs on this website, except with a few additional features.

I am having the same issue. I even purchased another Veraplus controller and have the same problem with that. I went through 3 emails with Vera support and spent over an hour on the phone with them this morning for them to blame the Arris modem/router I have from Bright House Networks (my cable company)

My Veraplus was working for over 3 months and suddenly it was offline. I was considering buying an additional router and connect it to the Arris until I read your post. I was about to go and ask my cable company for another new modem/router but I cannot believe that all 4 ports would just go bad all of sudden. I am not as technical as you, is there a way to get this working when I do not have the same work option as you do?

You should be able to do what I did on my work network on any network with an ethernet jack that connects to the internet. If you can complete the VeraPlus setup using, then you can get to the Vera home page, then the “Net & Wi-Fi” tab, and then do the same thing that I did. Unfortunately, there is no way to program the VeraPlus to assign itself a static IP address without being able to connect with it.

Do you know how to get to the web page of your router? This is critical since this webpage tells you which IP addresses are assigned via DHCP, and what your gateway IP address and subnet mask are. I think is a common default IP address for a router, but I expect this is not universal.

By the way, I am an electrical engineer, but I did not anything about networking before buying the VeraPlus. The VeraPlus motivated me to learn about networking in my efforts to get it working.

Personally, I have certain devices assigned static IP’s like Vera and my computer running Blue Iris, to prevent those devices from getting a different IP and therefore “break” when it is most inconvenient - like when I am out of town ;D

I’ve spent the last week trying to solve this same issue. It was your DNS trick that finally solved it.

I’ll add my symptom which was: I could ping but not ‘’ which pointed to my DNS server.

The following was done through SSH (Putty, logged in as ‘root’ with the default PW printed on the bottom of the VeraPlus)
I ended up having to edit ‘/etc/config/network’ (under the item [tt]config interface ‘wan’[/tt]):
[ul][li]option proto ‘static’[/li]
[li]option ipaddr ‘’[/li]
[li]option netmask ‘<whatever mask you want (e.g.>’[/li]
[li]option gateway ‘<router IP address (e.g.>’[/li]
[li]option dns ‘’[/li][/ul]

In my case, with a Linksys router, the DNS server was reported under Troubleshooting > Status > Report’ > DNS 1, DNS 2

After rebooting, everything was solid and I can now ping out to any website as well as access from

I had a new VeraPlus which would not connect to the Internet. The VeraPlus was listed on the router’s device list page but I could not ping it.

Although several other devices were connected to the router using DHCP the VeraPlus didn’t like it.

To get the VeraPlus to connect to the interent I had to connect it to another router with a 192.168.0.x range of IP addresses and complete the setup process. I then changed the Internet/WAN setting from DHCP to Static IP and then reconnected the VeraPlus back to the original router which was using a different range of IP addresses.

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules