SONOS plugin

My device recently updated to the new firmware and now SONOS is not working again using TTS. I was using Mary running on my home server which worked perfectly until now, so I followed the forum messages on using responsive voice and updated my Sonos file. However this fails as well, however I can play music from the plugin but everything else fails. This is what I really hate about Vera, you can never reach consistency and stability once you get everything working.

Try uninstalling and reinstalling the plugin. I am suspecting some files got corrupted during the upgrade.

Where can i get newest update?
Mine is 1.4

Hi All,

I’m having the same issue since the firmware upgrade on my Vera Edge.

All 3 Sonos showing offline and showing discovery patch not installed. I added manual IP address but no joy, so uninstalled plugin and reinstalled but still the same.

Even tried resetting controller to default and restoring from back up but nothing still.

Currently not able to discover Sonos or install discovery patch as clicking buttons does nothing so it would appear.

-S

Shadow, uninstall the UpNP plugin and reinstall that fixed that problem for me. However it wont fix the patch issue, but it will detect your sonos.

Atleast for me this Sonos plugin is so important that I think Vera shoud buy this and add to the product. That way we can get support and propably new development to this.

1 Like

I went and bought a Sonos One mainly because of this app and I find that I can not even discover the Sonos even if I enter the I.p address in advanced field the device still shows as off line. Does anyone have a fix for this please?

I did downgrade the firmware to fix this.

I did downgrade the firmware to fix this.[/quote]
Unfortunately the recent Vera firmware update has actually resolved some of the geo fencing issues I had so that would not be desirable. Is there any other work around? Is the app developer still active?

My Sonos has suddenly become active after I entered the ip address in the advanced section and left it for some time. I can now play and pause music from Vera and I did a quick test with some lup code for tts from this URL
http://code.mios.com/trac/mios_sonos-wireless-music-systems
Very handy URL.
The tts test with google translator did work at first but then stopped working and I assume this is due to google limitations. I am downloading marytts and will report back when I get it configured

Has anyone been able to intergrate the app with responsivevoice (as suggested by Bofh in the below thread)

New TTS engine: Microsoft Translator
https://r.tapatalk.com/shareLink?share_fid=24007&share_tid=33223&share_pid=334411&url=http%3A%2F%2Fforum.micasaverde.com%2Findex.php%3Ftopic%3D33223.msg334411%23msg334411&share_type=t

[quote=“PrincessCleavage, post:11, topic:197535”]Has anyone been able to intergrate the app with responsivevoice (as suggested by Bofh in the below thread)

New TTS engine: Microsoft Translator
https://r.tapatalk.com/shareLink?share_fid=24007&share_tid=33223&share_pid=334411&url=http%3A%2F%2Fforum.micasaverde.com%2Findex.php%3Ftopic%3D33223.msg334411%23msg334411&share_type=t[/quote]

workes for me . I did have problems with sonos plugin with latest firmaware and I did downgrade the firmware though. I did notice that the national special characters does not work but with out them everything works nice.

With the latest firmware and Sonos plugin 1.4 it work but,it do not work for testing in the text box.

[quote=“markoe, post:12, topic:197535”][quote=“PrincessCleavage, post:11, topic:197535”]Has anyone been able to intergrate the app with responsivevoice (as suggested by Bofh in the below thread)

New TTS engine: Microsoft Translator
https://r.tapatalk.com/shareLink?share_fid=24007&share_tid=33223&share_pid=334411&url=http%3A%2F%2Fforum.micasaverde.com%2Findex.php%3Ftopic%3D33223.msg334411%23msg334411&share_type=t[/quote]

Works for me . I did have problems with sonos plugin with latest firmaware and I did downgrade the firmware though. I did notice that the national special characters does not work but with out them everything works nice.[/quote]

[quote=“markoe”][quote=“PrincessCleavage, post:11, topic:197535”]Has anyone been able to intergrate the app with responsivevoice (as suggested by Bofh in the below thread)

New TTS engine: Microsoft Translator
https://r.tapatalk.com/shareLink?share_fid=24007&share_tid=33223&share_pid=334411&url=http%3A%2F%2Fforum.micasaverde.com%2Findex.php%3Ftopic%3D33223.msg334411%23msg334411&share_type=t[/quote]

workes for me . I did have problems with sonos plugin with latest firmaware and I did downgrade the firmware though. I did notice that the national special characters does not work but with out them everything works nice.[/quote]
I have the latest firmware installed and I have the plugin working by using all the settings in advanced tap and lup code for tts calls. None of the setting in the tts tab do anything for me and only play/stop is the only thing that seems to function normally.
Where in the Sonos app have you configured responsivevoice.org ?

Edit:
Details can be found in the below thread post #197 has the updated files attached to enable responsive voice
New TTS engine: Microsoft Translator
https://r.tapatalk.com/shareLink?share_fid=24007&share_tid=33223&url=http%3A%2F%2Fforum.micasaverde.com%2Findex.php%3Ftopic%3D33223&share_type=t

[quote=“shadow2506, post:4, topic:197535”]Hi All,

I’m having the same issue since the firmware upgrade on my Vera Edge.

All 3 Sonos showing offline and showing discovery patch not installed. I added manual IP address but no joy, so uninstalled plugin and reinstalled but still the same.

Even tried resetting controller to default and restoring from back up but nothing still.

Currently not able to discover Sonos or install discovery patch as clicking buttons does nothing so it would appear.

-S[/quote]

Same story on my VeraPlus. !!! :-\

Did anyone find a solution?

BR H?keren

Hello guys,

Just some updates on this topic. We have initiated talks with Sonos and also got samples of the Sonos products for R&D.
However, R&D is on standby as we are waiting for the NEW API Sonos is working on. As soon as we have clearance from them, we will have this on our working bench.

Hi Sorin, what is your plan? Integrate Sonos natively or fix the existing plugin that worked great till a recent firmware upgrade of Vera did break it ?

We can’t really touch the existing plugin because of multiple reasons.

It will be official Sonos integration done together with the Sonos team. We already got the hardware, we’re waiting for their kickstart signal and API access.

Hi Sorin, that is good news…but my experience with Vera is that it can take months (if not years…) before you have this working. And if it is working it is no guarantee it will keep on working. Just one example: Hue plugin developed by Vera is not working anymore since one of the recent firmware updates and I’m waiting for 3-4 weeks already on your promised next firmware update that will fix this. Sorry I am so negative but just too many big dissapointments with Vera past months after 4 years of being a satisfied user.

@Mai Pensato

Tried to find existing tickets of your related to HUE and could not find one. Maybe you are using a different email?
Please log a ticket with our Customer Care team because as far as I remember they might have a possible solution for this. Let’s keep the sonos topic clean. I will delete these two unrelated posts tomorrow morning…

Thanks.

© 2019 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy