SSH seems to require a RSA key

Sometime in the past I was able to SSH into my Vera Plus from my MAC’s Terminal app. Now when I SSH to my Vera I get a bunch of lines (I think from my Vera about RSA keys and Host Key verification failed. Did something change in the login to require a key? I am not sure I know what I am supposed to do to get around this key or to provide the key.

My Vera Plus is running 1.7.4970.

Any help would be appreciated.

Works fine for me on Windows 10 with Putty SSH client. Just need to enter the root username and password.

In Mac terminal are you specifying the username?

Example:

ssh root@192.168.0.101

Yep ->ssh root@ip pw:pw_from_device. used to work very well.

Now I get:
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the RSA key sent by the remote host is
SHA256:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx.
Please contact your system administrator.
Add correct host key in /Users/MAC_User/.ssh/known_hosts to get rid of this message.
Offending RSA key in /Users/MAC_User/.ssh/known_hosts:1
RSA host key for IP has changed and you have requested strict checking.
Host key verification failed.

I don’t know Macs but sounds like you need to add the RSA key to your key chain of known devices to connect to.

In Windows I just click Yes when prompted to trust the device, but only have to do that once on first connection.

This sounds like the key changed. That can happen during upgrades or factory resets. Just remove the key from the file named in the message on your Mac, and try again. It will treat it as if it was the first time connecting, and after that, you should be OK.

+1

I’ve done this several times, especially after reconfiguring my LAN and having different IP addresses for the machines.

1 Like

I have tried various things:

  1. Deleting the key out of the file(known_host)
  2. Adding the key fingerprint into the file
  3. Deleting the file
    All have not had good results but at least consistent results. After the command line -> ssh root@IP pw:pwd_from_device, I now get this message:

| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -| || | | || || |
|
_____|| |
||||___||| |____|
|
| W I R E L E S S F R E E D O M


  BARRIER BREAKER (Bleeding Edge, r39638)

*** MiOS LTD. ( www.mios.com ) ***


*** WARNING : ***
*** Any changes made to the system without ***
*** guidance from MiOS support will VOID ***
*** your future Support requests ***

root@IP’s password: Keychain symbol

Nothing I enter for the password works, I have tried the real PW and the fingerprint key. I am not familiar with the format of the known_host file, so not sure what I am doing. I know if I delete the file it is regenerated and has what looks like a key in it. But the key doesn’t match anything.

I’m having trouble logging in with root too. As a workaround you could enable Remote Access and login with username “remote” and the password that is generated when you enable it, the password is after the “-“ XXXXXX-XXXXX=SerialNumber-password

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules