Strange amount of free memory on VeraPlus restored from a VeraEdge

So I have 2 VeraPlus controllers and I recently added Memory Free and Memory Available to be sent to HundredGraph. Once I started to log these variables I noticed that the VeraPlus that was restored from a VeraEdge backup has a lot less memory even if the configuration is a lot smaller on that controller.


I would expect the controller with a lot les devices to have more memory free but it seems like it now only has the memory capabilities of an VeraEdge even if it is a VeraPlus.
How can I correct this?

where do you pull these two variables from? are you able to SSH into your units and run a


or a


To see if the data is consistent?

Here is what I can see from the 2 Veraplus Devices:

Just so strange that the amount of used memory is so much more on the device with the verry smal configuration. We are talking 20 devices compared to something like 150.

Try running a… it looks like you have a huge log buffer in the memory… or is one using USB logging and not the other?

Both are extrooted

You can see from the “top” output that the LuaUPnP on one takes much more memory than the other. Do you have plugins running? Lua Startup code? The last possibility is indeed the logging which is still being done in the “nvram” like openWRT calls it which is really a virtual storage in the RAM where your logs reside before getting moved over to the logs partition.

I think I fixed it now :smiley:
I ran this from Test luup code:

os.execute("echo 3 > /proc/sys/vm/drop_caches")

Now it looks normal:

6/28/2019, 7:49:00 AM FMemAvail 207780
6/28/2019, 7:44:00 AM FMemAvail 207988
6/28/2019, 7:39:00 AM FMemAvail 102368
6/28/2019, 7:34:00 AM FMemAvail 102512

6/28/2019, 7:49:00 AM FMemFree 197248
6/28/2019, 7:44:00 AM FMemFree 198148
6/28/2019, 7:39:00 AM FMemFree 59564
6/28/2019, 7:34:00 AM FMemFree 59744

1 Like

1 Like

Ohh yeah dumping the cache memory… sometimes it is staring right at you and you can’t see it. Great job! I run this as a cron job every 10min on my vera so I never thought this could be a problem.

1 Like

I though a luup reload would do the same so that’s why I did not try it sooner…