Subject: UI7 - Vera Firmware Update - Version 7.0.31 hot fix (1.7.4969/1.7.4970/1.7.4971) - March 2nd, 2020

Exactly the same problem here

Only partially helpful, since AltHue renames and renumbers all the Hue devices. This means that 100% of the apps and Alexa commands fail. It also means hours of work to fix. More helpful would be Vera fixing the Hue app.

Pretty sure the Hue app is not Alexa’s product. Could be wrong though.

Of course, would still be nice of them to sort it, but priorities etc…

C

I understand the resistance to change but it is for the better.
The support for the native app is much poorer than that of the third party.
The Hue2 app is also a messy kludge which should not be used and its best fix is to delete it.
The Alexa commands fail because you did not redo a discovery. The devices will be new and need to be rediscovered. That being said, you can renumber and rename them to be the same as the previous ones and Alexa should work again.

Let’s not even get into how poor the Alexa app is. Have to delete scenes one at a time. Seriously why?
I know you can do a forget all via the browser but it would be nice to multi select and delete from the app.

As many other I lost Hue-devices after upgrade. I did as recommended and uninstalled Hue2 and installed ALTHUE. Had several tries with uninstall and install before it worked. It some kind of found my controller, but not my devices. And after short time said it could ALTHUE was disconnected.
After third or fourth try I was able to connect to my hue controller, and see my Hue devices. My device in kitchen was called “undefinedKitchen” and my device in my office was called “undefinedOffice”. I tried several times on each of them to rename them to “Hue Kitchen” and “Hue Office” before it finally was renamed. And light on/off just occasionally worked. And shortly after the devices names was back to “undefinedOffice” and “undefinedKitchen”

The Hue2 devices was my most stable devices before upgrade. And I liked the interface better that the AltHUE interface.

I bett the “undefined” comes from the “Prefix for names” unders “Settings” in the ALTHue plugin main device.
I have set it to “Hue”.

You are correct. I changed it to “Hue”, and “undefined” disappeared. But did set that field each time I tried to install it. It’s like values set during install not always was saved

I set it to blank as I dont need my lights renamed (only dumb part of this plugin).

There is an issue with the Hue app, the vera team say its since the last Hue Firmware update, however I had no issues until I upgraded the firmware on vera (it was fine until then). Their team say the fix is to install the althue app!. I’ve just done this for my second hue hub, and all working fine (quite a few things to reprogramme now).

You’ll need to change the name of the device in your hue hub, that worked for me. If you dont want the prefix to be “hue” then you can remove that in the althue app settings (look for prefix for names).

I was surprised to see a firmware upgrade notice to version 7.0.31 this morning. Huh? I already upgraded to that version recently. Checked the release notes link for the upgrade and it detailed the exact update that I had already installed.

Still puzzled, I then searched for 1.7.4970 and found this notice. Oh - This is a HOT FIX! Unfortunately, the 7.0.31 version number gives no clue that’s the case, nor the release notes this update points to.

Although I’m not impacted by the wattage thing this HF fixes, I went ahead with the update just so I wouldn’t be annoyed by the firmware update notice every time I login to the Vera. Otherwise, I would not have bothered with it.

Suggestions:

  1. Update the automatic firmware upgrade notice and the associated release notes to indicate this is an optional hot fix for a specific issue.
  2. Ideally, add an option to select “do not remind me again about this update”.

Hi,
Newbie here :slight_smile:
By any chance, this update deals with the random delays of commands for immediate actions, such as roller shutters or light?
I’m asking since this is my only major concern, convincing to update this device.

Yesterday, I updated my VeraEdge from Version 7.0.31 to 7.0.31 hotfix without issues.

[]'s

Hi there,

I ran the march 2nd FW update yesterday. After 2 hours my Vera was still not visible in my network. The power LED was blinking but nothing happened.

Finally I tried to reboot Vera but no change. I’ve tried resetting the unit by holding the reset button for 20 seconds and (after this did not work) clicking reset 6 times within 6 seconds (that last method does nothing btw), still no change. Only that sometimes the power led blinks normally and sometimes it blinks very fast. I’ve tried this several times now.

I cannot see the device as a connected device to my router. Sometimes a cabled device shows up in my connected devices but after a few seconds it disappears again (see image screen 1). Only to come back after a few seconds on a different IP (one IP higher, almost as if it’s scanning the IP’s to get a connection(see image screen 2))
The router log (see image screen 3)does show some activity but only with a MAC address that ends on 69 instead of 68 which is on the bottom of Vera. This is Vera’s Wi-Fi I understood from other posts.
I can even see Vera’s Wi-Fi (see image screen 4) and connect to it with my phone or pc using the default password from the back.
But I just can’t seem to get to the dashboard.

I’ve also tried adding it through the getvera website. Also no luck. At first it looked like it found it (on the old IP address) and the website said ‘updating controller’ but after this was finished it said controller offline. Also while the website said it was updating there was no device visible in my router at the specified IP address.
Finally I tried connecting it directly to my PC as suggested on the troubleshoot page.
I can then see it and ping it but I still can’t get to the dashboard using that IP or the IP mentioned in the troubleshoot.

Please help. I’m no expert but really want my vera back. It’s been a day but I miss her so… :wink:

Kindly,
Wouter

200 KB Download

200 KB Download

500 KB Download

200 KB Download

First of all, forget trying to reach it from the website. This is time wasted: If your router can’t find the device, the website which relies on the router’s upnp function to find the hostname and then the IP address, will not find it.

If you are able to find the wifi of the device and login to it, maybe you can get a PC and SSH into the unit through its wifi. Very likely you just had a corrupted firmware update and something in the kernel is not working with your ethernet port. If you are able to SSH into the unit through wifi, the useful commands to send and to post the output from are these:
dmesg and ps aux.

For future reference of other members, for the UI to show up, it requires two programs to run:

  1. The web server which is lighttpd and relies on the files in the folder (/www). If you don’t see this upon hitting the ip address of your vera, this service is likely not starting.
  2. If you hit a website frame with a rotating beach ball then lighttpd is up but is waiting for the luup engine to start (LuaUPnP). If it times out, it will give you a page telling you that the engine is down. If it is up, you will see a dashboard.

Holding the reset for 20s should not do anything. Holding the reset button while powering up puts the vera in boot loader/ TFTP client mode.

For you at this point it really looks like your ethernet interface is down and we can try to figure out why.

1 Like

Thank you for taking the time for a reply. :grinning: :+1:
Unfortunately I am no programmer or IT specialist so I have no clue how to ‘SSh into the unit’. But it sounds like you do :wink:
Any chance you can ‘translate’ this for me? I can connect to the unit through it’s Wi-fi. So maybe if you can point the way I can give it a try.

SSH is basically creating a terminal tunnel through port 21 into the vera. If you have a PC you can use putty.
https://putty.org

What IP address do you use when you get on the wifi on the vera? Is the vera serving you an IP address? Look at the wifi section of your pc/mac and look for the router IP, it is likely the IP of your vera if the vera was unable to connect to your network through wire.

ok this is a bit weird…
after the update… locally and through web everything seems fine… the issue is with android app… it jumps between connected and disconnected…fair bit…
the impact… when i leave house… since it is for extended period, it will go into away mode (as desired) but when i come back… it is not changing back to home mode… from the looks it seems to be due to showing disconnected status… not sure if anyone came across this problem… worked fine on 7.029. only thing that changed in whole network / hardware/ software is the firmware update
edit… just checked the web portal (external and its showing offline) logging internally it shows all ok (as in internet access ok) so not sure whats happening
update: been checking it out… so it appears that it is constantly connecting / disconnecting to vera servers… so if I open vera portal from remote location… it will show device disconnected… I do web page refresh… device is connected. try to get in… it times out… logging me off… i log in again… it logs in… after few sec / min (random) it disconnects me… connecting locally works fine… so doubt its the connection as locally i dont experience dropouts
any help??

Well, this is interesting. This morning I am pretty much unable to get anything done on my Dev Plus running 4955 because the firmware update notice for 4970 is refreshing the page and putting me on the notice every 5 seconds. Even then when it’s on the firmware update notice page, it refreshes it every 5 seconds.

@Sorin whatever is going on here, please accept this as yet another vote for a “don’t show me this again” or better still “turn off notices about firmware updates (forever)”.

After several minutes of hard refreshes and trying to get away from this page, I eventually got to a point where I got a blank frame in that area for several minutes, and so I was able to resume work. As of now (4h later) I get the normal firmware notice behavior.

2 Likes

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules