Temperature sensors won't stay put :)

I fixed this once before but can’t find the solution, or at least what I’m doing doesn’t work.

I re-included my Fibaro universal sensor yesterday. We have data from all four temperature sensors again (yay)

Only now when I update their room number to be correct, it keeps changing back.

So I go into the device, change the room number to the correct one, hit save. It all looks fine, all the devices are where they are supposed to be.
Then some indeterminate time later, they are all set back to the Garage as their room.

Hardly a deal breaker but not perfect.

Is this because I have ‘embedded’ ticked in the options?

TIA

C

Hi,

Yes embedded means the child devices will be in the same room as the parent. What you see (they get changed back) is the normal behavior.

Just uncheck embedded and make the room change then.

Cheers Rene

1 Like

Ta! I thought that might have been it!

C

HEADDESK
Honestly I could scream
The two sensors I moved have now been deleted, replaced with different ID’s and the original name with ‘1’ appended, and they’re back in the garage…

Any other thoughts?

Found this in the log:

09 11/27/19 9:51:03.214 Child_Devices::ProcessChildDevice deleting device 179 id e4 room 9 desc Greenhouse Temp under 175 topmost parent 1 because type o:urn:schemas-micasaverde-com:device:TemperatureSensor:1!=n: or file o:D_TemperatureSensor1.xml!=n:D_TemperatureSensor1.xml embedded o:0!=n:1 ok:1/1 <0x76c2e520>

Which I can’t parse sensibly

And just managed to force this to repeat by restarting Luup.

C

@Catman emboldened by you apparent success :wink: I thought I would try to deal with a similar situation affecting a Fibaro Double Switch two I have where the two switches control loads in different “rooms”.

As it seemed to be reverting automatically I thought I would try changing the “Automatically configure” settings in both the parent and child devices from “Use default behaviour” to “No”. This did NOT stop the child device reverting to the same rooms as the parent.

Looking though the setting for the parent device under “Advanced” and the “Variables” tab there is a variable “ChildrenSameRoom” which was set to “1”. I used “Edit” to changed this to “0” and got a brief “Change property command sent” acknowledgement.

I then went back to the child device and under the “Advanced” “Params” tab de-ticked the “embedded” tick box and again got a brief “Change property command sent” acknowledgement.

Going back to the initial device details screen showed that there was a now a room selector, which I changed to the required room.

So far it seems to the staying put - no more wandering “Outside” - although the device name now has lots of ones after it in “recognition” of the number of tries I had before I had something that appears to work. Needless to say the DeviceNo has been increments a few times as well.

So in summary

  1. In parent device under “Adanced” “Variables” variable “ChildrenSameRoom” to Zero
  2. In child device under “Advanced” “Params” de-tick “embedded” tick box followed by “Back”
  3. In child device set room using drop down that appears after 2

If this doesn’t work initially then for both the parent and child device under “Settings” change “Automatically configure” to “No” and try again.

I will be interested to hear how you get on.

1 Like

Thanks for this. I have tried with not changing ‘Automatically Configure’

The room picker has vanished, but they are (currently) in the correct room, even after a Luup reload…

Slightly delayed pickup of the temperature but fingers crossed!

C

@Catman following you comments I checked my child device and found that for me the “Assigned to room” drop down had disappeared although the child device had remained in the room I previously set it to.

Going back and checking the other settings I found that the child device “Settings” “Automatically configure” was set to “Default” so I have set it to “No” again and then under “Advanced” “Params” again deselected “embedded” and the “Assigned to room” drop down has re-appeared. Lets see if it stays this time.

Update at +15h - well the child device stayed put overnight and did not go for a wander “Outside” (where the parent device is) so that part appears to work. However, the “Assigned to room” drop down disappeared again with the child device “Settings” “Automatically configure” reverting to “Default” and “Advanced” “Params” “embedded” again reverting to being selected. I’ll put it down to being an “undocumented feature” of the software (i.e. bug) and just note that you need to deselect “embedded” if you want access the “Assigned to room” drop down. I also noted that the parent device “Settings” “Automatically configure” stayed as “No”. Also the child device name has gained a few additional "1"s and its “Device No” incremented accordingly, it seems to happen each time the child device “Settings” “Automatically configure” and the “Advanced” “Params” “embedded” are changed from their default values.

Update at +20h Well the child device has stayed where its put but the child device “Settings” “Automatically configure” and the “Advanced” “Params” “embedded” have reverted their default values (“use default behavior” and “embedded”), the “Assigned to room” drop down disappeared again, the device number incremented and yet another 1 appended to the device name. I will now leave well alone unless the child devices goes walk about again.

Interesting to see how it goes. I don’t mind have the drop down missing, I know the room numbers off by heart now :smiley:

C

The child device stayed put overnight and did not go for a wander “Outside” (where the parent device is) so that part appears to work. However the “Settings” “Automatically configure” and “Advanced” “Params” “embedded” reverted to their previous settings. Earlier post updated accordingly (Update at +15h).

Same here. I’m happy as long as they stay where I damn well put them, so I guess the important setting is the parent device one?

Cheers!

C

It is definitely necessary to change the parent device “Advanced” “variables” variable “ChildrenSameRoom” to “0” (zero). What I am not sure about is whether or not is is necessary to change the parent device “Settings” “Automatically configure” to “No”. That is what I currently have got set and the child device is staying where it was “put” despite some of the child devices settings reverting on their own, as previously noted, so I am reluctant to change the parent device settings. There may be some other setting I am missing but as the above appears to have solved the problem of the wandering child I am going to leave for the time being.

1 Like

Very much disinclined to mess with a working system but I fully expect that I will lose these again, and would like to spend less than 2 hours trying to get them back :smiley:

While restoring backups sometimes works, sometimes I don’t have a backup from before the point they stopped working that doesn’t have other changes missing.

I wonder if I can use reactor to note a lack of change…

C

© 2019 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy