Today we launch official Google Assistant compatibility for Vera!

Hello danwooller! To run scenes you should simply say 'Ok, Google! Activate scene ’ or Run scene or just Activate . If it’s not working, first make sure that you have enabled the scene to be discovered by the Google Assistant. You can do that by accessing https://nexus.getvera.com/, logging in and in the top right menu click ‘Manage Google Home’ - here is where you can select the devices and scenes you want to be available in the Assistant.

1 Like

Thank you Johnny! That also resolved the questions regarding how to hide devices.

1 Like

Yes, it is possible. You can do that by accessing https://nexus.getvera.com/, logging in and in the top right menu click ‘Manage Google Home’ - here is where you can select the devices and scenes you want to be available in the Google Home app.

For what its worth, you can select which home a device is displayed in from within Google Home. Or, at least I can. I had TWO different locations specified from withing google home prior to adding vera. Once vera was integrated I could select a device to add to a specific “home” then to a specific “room.”

Guessing you are not seeing this via your google home interface?

Seems if you rename a scene it does not dynamically update under Manage Google Home. Tried a hard browser refresh.

Working great! only issue was during the linking because I have the Ezlo atom. Once I removed the atom, it linked properly

Is there a way to select only certain devices to add to Google home? I have my Philips hue lights already added to Google home and don’t want these added again through Vera.

See johnny’s post above

2 Likes

How can I remove the Google app from my vera? I don’t want Google on my vera (!). I see It is communicating with google now and I don’t want that. How can I disable that?

I prefer to have my own control on my home automation and not having Google stuff in it

No worries, working now for me but it´s not a big deal. Looking forward to 7.30 :slight_smile: Great work !

:+1:

1 Like

Hi

Is this a bug?

I have just unchecked all the devices and scenes I don’t want to see in Google Home

However I cannot save it keeps saying

I dont think I have anything with exactly the same name, however it’s highlighted in a red box some devices that have a similar name.

Must be a bug if I unselected all those devices with the name

RGBW - {Colour} Channel

It’s now saved OK.

The solution to this was to remove the Atom from my mobile app completely. At that point the Google Home integration finished just fine.

As the Atom is offline at the moment I’ll have to try re-adding that to see the impact later.

Support hasn’t replied to me as yet - when they do I will update them accordingly as to what resolved this issue.

remove the hyphen and possibly the { }

I had a similar problem with underscore and hyphens

BTW, it seems that custom field is what Google home responds with, It is not the input word.

The only issue I am having currently is some of my scene names are not user friendly for voice and it seems like renaming the scene does not update dynamically. The only work around I have found is deleting and creating a new scene with a proper name which I would like to avoid.

Keep the feedback coming. We’ve discovered a few more bugs that will be squished shortly.

The Atom use case was already reported. GH won’t work on accounts with the Atom attached. We’re on this.

1 Like

Noted, thanks Sorin.

Am pleasantly surprised so far. The only issues I have is that in order for blinds/shutters to open you have to say ‘switch on blinds’ rather than ‘open blinds’ and ‘switch off blinds’ instead of ‘Close blinds’. This is with Fibaro Roller Shutter 3 modules. Also, when trying to stop a routine (for example the News in the morning when you say Good Morning’, it says ‘there is an error in the living room’ (even though the stop command was given in the bedroom.

1 Like

Sorin, could you please reply to my question on how to disable google? I prefer my authomation system NOT to be connected with google. I see that at least (at this moment) my Vera is setting up DNS sessions with google (8.8.8.8) (the other 2 ports 53 are my configured DNS servers via DHCP)

I also see that despite I do NOT use and want to use google on my system a device was/is created:

Same counts for the alexa app in vera. But there no device was/is created.

Finally glad to be able to test the integration…and I’m pretty happy with it working on Swedish as well :smile:
But…I’m having trouble saving my devices/scenes from the list in Vera. It doesn’t like my swedish characters. I thought it’d help if I removed the Custom Device Name…but my device name is also in swedish (which is ok by Vera otherwise) so that’s not working either.


@sorin Could I please be allowed to save swedish characters (å, ä, ö)…so I can talk to Google in my native language.

1 Like

Working as expected. Nice. Running scenes and lights which is all I really wanted. No bugs noticed but also using ONLY for scenes and lights.