UI5 Vera2 date set to wrong date

#1

How is it possible that my Vera2 sets its date to Saturday 1 Jan 2000 automatically?
A lot of my scenes don’t work anymore because of this.
Also it stops taking backups of my system !

How is this possible and how can i fix this?

#2

Reboot while your Vera has access to the network.

Chances are you had a power fail … Vera rebooted quicker than your router … So when it went to get the time it could not get it … so it defaulted to some absurd previous time.

This is a good reason to put your Vera on a UPS …
On the newer device and UI7 … they use NTP … so you do not need to reboot … but you do need to restart Vera.

#3

G’Day
Will ‘Setup’ -> ‘Net & WiFi’ -> ‘Reboot’ achieve the same thing ?

Cheers,
Josh.

#4

Hello there,

Usually, a Network reset should do the trick. The option is found under the same menu ‘Setup’ -> ‘Net & WiFi’ . But if you find this issue stubborn to resolve, don’t hesitate to log a ticket with our Customer Care team as well. See my signature for details.

#5

Hi guys, I’m having the same issue that occurred suddenly across multiple devices in different locations…
Tech support recommended to upgrade to UI7, which I find unacceptable…
I tried rebooting, resetting the controller and load a backup when was working.
The internet connection is good
The location is configuration it’s fine

Please help

#6

Same here for the last 2 days, did all the above suggestions which indeed works in the past, but none of them works now.

I have a Vera2 which doesn’t work with ui7.

Need also a solution, i think Micasaverde did change something on their site which corresponds to my Vera …
So Micasaverde please respond and give us users a solution.
All my scenes which make use of time/date doesn’t work anymore, unacceptable.

#7

We got your email on the support address also, thank you for reaching us. Please check it and get back to us with the requested info’ if possible.

Also, for everybody else having this issue, if rebooting the controller or doing a “Network Reset” does not help, please email us at support@getvera.com.

Waiting for us to check the forums might be slower than a direct email, if you are to email us, please try to include the Tech Support string, you can find it under “Account -> Tech Support”, only after you press Enable.

For any other issues/questions you should email us or send me a message if you find it easier.

cheers!

#8

I had the same problem. Apparently, UI5 devices did not ship natively with NTP. Here’s how to fix it:

Vera support kindly provided the LUUP code that adds NTP to the system.
Go to “apps -> develop apps”, click on “test luup code”, then cut - paste / execute each of the following lines separately:

os.execute("opkg update")
os.execute("opkg install ntpclient")
os.execute("for i in 0 1 2 3; do ntpclient -c 1 -p 123 -h $[i.openwrt.pool.ntp.org (http://i.openwrt.pool.ntp.org/); done")
os.execute("for i in 0 1 2 3; do ntpclient -c 1 -p 1230 -h $[i.openwrt.pool.ntp.org](http://i.openwrt.pool.ntp.org/); done")
os.execute("/etc/init.d/ntpclient restart")

After unit “reinitializes”, time should be back to normal.

1 Like