UI7: VeraAlert "Notification Configuration" Empty.

Has anybody else ran into a problem where “Notification Configuration” is empty.

Maybe I am setting up the notifications incorrectly, on UI6, the notifications could be set up on the device but that doesn’t seem to be an option anymore, and now the only way to set up a notification on UI7 is through a scene.

But when I set it up as a Scene, the Notification Configuration is empty.

I have alerts again ;D, have I missed my Vera Alert.

I was not able to get the Notification Configuration working, but adding LUUP to the Scene, and its working.

The LUUP code I am using is:

luup.call_action(“urn:richardgreen:serviceId:VeraAlert1”, “SendAlert”, {Message = “Message String {tone:1}”, Recipients = “Profile1, Profile2”}, 83)

[quote=“frankhou77, post:2, topic:182767”]I have alerts again ;D, have I missed my Vera Alert.

I was not able to get the Notification Configuration working, but adding LUUP to the Scene, and its working.

The LUUP code I am using is:

luup.call_action(“urn:richardgreen:serviceId:VeraAlert1”, “SendAlert”, {Message = “Message String {tone:1}”, Recipients = “Profile1, Profile2”}, 83)[/quote]

I take it that the “83” is the vera alerts device id? Should I use the name of the profile, or just “profile1”?

Yes 83 is the device is of the Vera Alerts plugin.
Use the name of users or profiles as the recipients arg.

I have lost my notification configuration today :frowning: Didn’t install anything, no Vera FW upgrade - but all of a sudden, all notifications are gone from that tab, and I’m getting tons of popup messages.

Any ideas? Vera Edge, UI 7, 1.7.1248

You have NOT upgraded your UI7 … but you have allowed your plugins to Auto Update.

There were releases for PLEG and Vera Alerts for the latest UI7 release. These are NOT backwards compatible with the previous release.
(API change made my MCV)

Your options …
1) move forward with UI7 release …
There are issues with the latest UI7 release
2) restore a backup from before the Auto Update occurred and disable Auto Update on the PLC and Vera Alert plugins.
People have reported problem with this process … You may need MCV support to help.

Thanks Richard. Was hoping for an option 3 (manual downgrade of the Plugin), but doesn’t sound like that’s an option :’(

Definitely not going to upgrade to the new UI7 version (I actually ask myself more and more why I should still support MCV with their crappy, untested and unreliable releases :-\ )

Restore backup isn’t an option either, too many changes. Guess I have to live with whatever Vera Alerts notifications I have configured so far until MCV sorts out their crappy upgrade process.

[quote=“RichardTSchaefer, post:6, topic:182767”]You have NOT upgraded your UI7 … but you have allowed your plugins to Auto Update.

There were releases for PLEG and Vera Alerts for the latest UI7 release. These are NOT backwards compatible with the previous release.
(API change made my MCV)

Your options …
1) move forward with UI7 release …
There are issues with the latest UI7 release
2) restore a backup from before the Auto Update occurred and disable Auto Update on the PLC and Vera Alert plugins.
People have reported problem with this process … You may need MCV support to help.[/quote]

This is good info and I have the same problem, but atleast I know why now.

I also wish there was a downgrade app option.

There is … but I down’t know how to use it … there is a way to specify a specific version.

[quote=“indianl, post:5, topic:182767”]I have lost my notification configuration today :frowning: Didn’t install anything, no Vera FW upgrade - but all of a sudden, all notifications are gone from that tab, and I’m getting tons of popup messages.

Any ideas? Vera Edge, UI 7, 1.7.1248[/quote]

I have this same issue. I have even deleted Vera Alerts and wiped it clean using SSH then reloaded it. Same issue returns. Any thoughts RTS?
Running Vera3 UI7, 1.7.599

If you have Vera Alerts Version 6.41 install you some how upgraded your Vera Alerts software.
This version is NOT compatible with your frozen UI7 version.
You need to be running a UI7 Version released in the last two months with this Version.

You can restore from backup to get an older version of your configuration before Vera Alerts was updated.

Oh OK. I understand.

Nov 24 update : Upgraded the firmware and Vera Alerts is working perfectly.

Sent from my XT1585 using Tapatalk

I’ll add in here because the topic really hits it.

I am almost new to vera and Home Control. I bought a new Vera (UI7, latest Firmware) installed PLEG and VeraAlerts and I am digging my way in it.

After installing VeraAlerts I entered info for SMTP and everything worked. Later I edited my settings in the ‘User Info’ section and unchecked all notifications from Vera. Was that a mistake? Now VeraAlerts isn’t sending anything out, messages can be found in the ‘Alerts’ section.

If I remember it correct, I never saw any messages in the ‘Notification Configuration’-Tab from VeraAlerts.

Regards,

Thomas

(This was my first post, so a warm ‘hello’ to everyone around here. You really made my decision for the vera. Greetings from Germany)

I’ll add my Vera Firmware is 1.7.1569 and VeraAlerts is 6.41. I see a few other posts regarding this problem, so I think it has to do with VeraAlerts itself.

EDIT: Updated with http://yourveraip:3480/data_request?id=update_plugin&Plugin=3008 as recommended elsewhere and now it works. Problem solved.

I just upgraded to UI7 (actually moved to a new Vera) and I have the same problem: the Notification COnfig tab is empty (rather is shows a bunch of popup messages and “Error executing function va_Configure(): set_to_delete is not defined”

VeraAlerts version 6.43, Firmware 1.7.1754

So what do I do next?

Upgrade your plugins!
The upgrade process will select the appropriate UIX files.

I already tried the upgrade process using that special URL. Isn’t 6.43 the latest?

I also Upgraded my Veralite firmware from 1.6xxx to 1.7.760
No my Vera Alerts will not work and I see that the Notification field is empty.
Running the latest 6.43 version Vera Alerts
Also cant save changes cause theres no SAVE button like there used to be. For example in the profiles area I put in my VeraAlertsID and next time I log back into the UI7 my profile is gone and also my registation ID in the Register area.
Been running great for 2 years now its broken bad.

When ever you change the UI7 you must update the pluigins.
They contain UI specific versions that get sorted out when you do the install or update.

See: http://forum.micasaverde.com/index.php/topic,15065.0.html

So I need to be on same network to do this?
This cant be done remotely?

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules