User Interface Issue with Geofence Condition

Not sure if this has been reported. I am using Reactor Version 3.4 and a Vera Plus with FW v 1.7.4453 .
Probably the best way to describe this is to share the steps:

  1. Create a reactor sensor.
  2. Create a new condition in the sensor
  3. Select “Geofence”
  4. Select “User is in Geofence” or “User is NOT in Geofence”
  5. Select one of the users. This is where the problem occurs. My wife has a short email address. This causes all the fields to stay on the same line which causes the “Choose Location” field to not expand and be visible/usable. If I select a different user such as myself with a longer email address the fields past the “geofence” field drop to a new line which allows the “Choose Location” field to expand which allows me to choose the location of one of my Veras.
    The result is that I can create geofencing conditions based on my user email but I can’t with my wife’s user email because I can’t select a location.

Hopefully this explains the problem sufficiently. I can probably attach screen shots if needed.

Tim

Pardon the short reply, traveling, but try installing the 3.4 hotfixes (see topic in this category)

Ok slightly different response but same results.
Now when I select “Geofence” as the condition, a new line starts where I can select the more specific condition ( User is in Geopfence) and user ( My wife ) but I am still not allowed to choose a location with her. The select location box is very small with no drop down menu which is the same as before.

I am still able to select a location if I choose myself as the user.

Testing for hotfixes:

  1. Under the logic summary report the version is --> Version: 3.4hotfix-19317
  2. Bottom of the test tool page the version is --> Reactor ver 3.4hotfix-19354

So not quite the same as you detailed in the hotfix page.

I also tried changing my wife’s authority level to “Account Administrator” just to see if that had any affect. No luck.

Tim

Ok. Since I’m traveling I cannot do deep troubleshooting or new hotfixes, so I suggest trying a different browser,
and failing that, installing the 3.5 beta. If that doesn’t resolve it, it will have to wait until I return.

No problem. I am going to be out of pocket most of Feb 2020 so will start working on this again in March. Once I get back I will re-evaluate the post and take direction then.
I also wonder if it could have something to do with Geofencing and not the Reactor interface. Geofencing in general for me seems to be flaky. Only about 1 in 10 times does Geofencing appear to do the right thing. Either not set the house mode to away when it should or not setting the house mode to “Home” when it should.
I wonder if this could be a symptom of another Geofencing issue.

Tim

Honestly there’s a high chance it’s the Vera geofencing that’s causing the issue. I’ve never been able to fully rely on it

Yes and it is the feature that I want the most to be reliable. When I install a home automation system, I want to tell my clients that I can automate their home based on whether they are at home or not. I simply cannot in good faith make that claim with Vera.
Vera is doing themselves a great dis-service by not having reliable geofencing.

1 Like

Unfortunately it’s an on-going issue that they can’t seem to solve. People including myself have had great success using some sort of HomeKit bridge and using HomeKit to take care of geofencing. Very reliable.

iPhone locator is pretty reliable as well.

I’ve heard some of the arguments about why geofencing is difficult but plenty of other apps seem to manage with the GPS location issues.

C

1 Like

Hi, I am ready to start working on this again. From Rigpapa’s last email, I have tried a different browser( Firefox and Safari), same result with both. I am currently using version 3.5 of the Reactor, not sure if it is Beta or not, but I still have the same problem as stated above.

Paradoxically, it pleases me to hear others have trouble using the Geofence feature with Vera, because for the past 48 hours (in conjunction with beta testing I’ve been doing on the Android version of Vera Mobile) I had given Geofence a try, but never had it trigger.

The phone knows where I am, the app seems to recognize my location, my Geofences are correctly configured, I’ve traversed the boundary numerous times, and even included a Geofence condition in Reactor just for good measure (which never once tripped TRUE).

Truth be told, it’s as if the service does not function at all. Which is (as always) how I came to find this discussion topic, and my relief at discovering that I’m not the only one.

Welp… guess that’s another much-touted Vera feature that is still years away from working as advertised, eh? :-/

Somewhere in the forums is a long diatribe by yours truly on the ways in which the mobile app fails to update geofence data in a timely way. In a nutshell, it has been the case for some time that even the most trivial edit of geofence data (e.g. change region name) causes all geofence data to be invalidated, and then it is only updated when each (one at a time) geofence boundary is traversed. The effect of this is that you can be sitting in your home region and the data will say you are not, until you exit the region (at which point it will correctly change to not home) and later re-enter. It will not update other regions, so if you have two non-overlapping regions home and work, you arriving home will not necessarily flag that you are not at work. Vera may have fixed some of these issues since they were reported–I have not tested. Some of the issues are not their fault, too. Phone limitations and increasingly tight privacy laws are reducing the efficacy of phone-based GPS for timely location tracking.

3 Likes

I’ve been trying to reproduce this under 3.5 this morning, and so far unable. Can you post a Logic Summary and screen shots if it’s still happening?

I sent an email with the Logic Summary and screen shot. I blacked out my wife’s address in the “User” field. The location field fails when she is the user. If I put my email address in the user field then I can correctly choose a location.

NOTE: If your wife is a GMail user, you could try ‘padding’ her email address as follows, to make it longer (and hopefully provide an intermediate ‘fix’ for the problem you mention in Step 5 of your OP):

wifey+anytexthere@gmail.com

Just a theory, but I use that (nearly undocumented) [+] feature of Gmail all the time to help route business email using Filters.

  • Libra

Thanks for the suggestion but her account is not gmail.

1 Like

Has not arrived…

Sent at 10:20 am MDT via the Vera Community.

OK. The problem is that your wife does not have any geofence locations configured–she’s a known user, but no geofences are associated with her account. You need to log her in on her phone using her account info, and create fences for her. Your “home” fence is not shared–each user’s fences are completely separate.

This is really weird. Her phone is set up identical to mine. The funny thing is if I change the radius of the geofence on her phone - say from 500m to 800m, about a minute later the change appears on my phone. The same behavior occurs if I make the changes on my phone. A little while later her phone will show the change. I assumed this behavior was normal and that our geofences were linked some how.
And while I typed this, she left the house and triggered a reactor that was meant for me.
Do I need to set up a completely different account for her on Vera?

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules