Vera 2 time wrong

#1

On my Vera 2, UI5, f/w 1.5.622 (which it claims is the latest), my timer scene suddenly stopped working. I can manually toggle the switch from the Dashboard but the timer isn’t working. The Power, ETH1, and ZWave LED’s are on.

I also noticed the time is way off. It thinks it’s January 2000. Clicking on the time in the Dashboard only brings up options to set the location, but not the time.

According to another thread here, stopped timer scenes can be caused by wrong dates. So I ssh’ed into the Vera and did

rdate -s time.nist.gov

and that set the date correctly and also survived a reboot. We’ll see if the timer runs tonight. But what could cause Vera to lose track of the time in the first place? And is what I did a permanent fix?

#2

I believe they only sync for time on boot so if your network is not fully up and running at boot time, you cant get time sync :frowning:
I could be wrong, however

C

#3

Thanks for the info. Turns out the timer in fact did run last night and then again this morning so the problem seems to be solved.

What’s odd is that I power-cycled the Vera several times before I tried the rdate (with my network running) and it wasn’t doing a time sync. After doing the manual rdate, it started working again. It’s also odd that a wrong date should prevent timers from running at all. Why wouldn’t they just trigger at the wrong time? For that matter, how can they know that the current date is wrong without knowing what the right date is? I guess this is just one of those mysteries of the universe.

Anyway for the benefit of anyone else with stuck timers, if your date is wrong, do a manual rdate.

#4

Your network may have been running, but was the Vera’s network stack up? Bit of a race condition I suspect.

Interesting about the timers not working. Maybe if the time sync fails it disables crontab or whatever similar process Vera uses.

C

#5

I don’t know how rdate gets called but it doesn’t use cron. The only thing in the root crontabs is a log rotator. I took a quick look at /etc/rc.d/ too but nothing there jumped out at me.

rdate is pretty old now. My guess is that whatever server Vera had been trying to connect to suddenly went away recently. Fortunately time.nist.gov still takes rdate.

Micasaverde probably no longer cares about the Vera 2 but it seems like moving to ntp might be a resonable thing at this late date.

#6

‘rdate -p time.nist.gov’ didnt do the job
it just printed the time.
‘rdate -s time.nist.gov’ did the job.
but Vera 2 resets to wrong date January 2000 after switch OFF and ON.
Is there a permanent solution to this.

#7

Oops, you are of course right. I did rdate -p first just to check what was going on. The command to set the date is indeed rdate -s. I just copied the wrong line into my post. I’ve corrected that now. Thanks for pointing it out.

It’s odd that that didn’t survive a reboot on your Vera. It does on mine. Are you on an older f/w version?