Vera 3 and UI5 time settings

I have had this Vera for many years and it’s been running my heating controls and various lights on timers very sucessfully

It has just started playing up and I have found that it is failing to set time sucessfully which is causing all my settings to happen at the wrong times.

Upon reboot it is starting at 00:00 on 1 jan 2000 and counting from there.

Any thoughts are welcome. It has internet connectivity. No changes have been made to VEra or my network/internet connection.

Many thanks


Odd. If you have outside connectivity, the Vera should reach a time server and set the time and date. Have you tried setting the date and time from the command line? That could be a short-term fix. Support might need to look at the unit to see why the NTP client isn’t working.

Thanks. I’ve not tried command line time setting as I don’t know how. It’s been workig happily since 2011 and I have no idea why it is broken. Are there options for changing the time server?

My guest is that you’ve run low on FLASH memory, and/or there has been corruption of the scripts that handle the time setting, hence the problems after many years. It is possible to redirect to a local time server, but you’ll need to have some external time source as the Vera has no on-board hardware real-time clock. I’ve got to step away for a few hours, but you should be able to search the forum to find out how to SSH into Vera and use the command line to see what’s going on. You may also want to file a support ticket and have the Vera folks take a look remotely.

Completely stumped, I reset to factory settings and it still couldn’t set the time. Restored from backup and still booted up as midnight Jan 1 1980.

I was able to SSH into it but couldn’t work out how to manually set the time.

Any thoughts welcome.

I tried to raise a tech support ticket from within VEra and it wouldn’t submit it, just hung on the submit page and did nothing.

It is a Vera 2 if that makes any difference?

Try SSH into vera

date -s YYYY-MM-DD hh:mm

So right now I’d do

date -s 2019-04-09 21:58


I am having the exact same problem, with 2 different Vera’s (1 at home, 1 at my office). Theyve both been running flawlessly for many years. Seems like something broke on the NTP server side…

Take a look here:

I believe all the default timeservers that were shipped in /etc/config/timeserver are dead now.

Per instructions I found these 4 still working:

and put them into /etc/config/timeserver. That resolved it.

P.S. I assume you have ssh access to your Vera.

Would anybody be able to elaborate on the steps needed to put the working timeservers into the timeserver file?

Not doing my best thinking around midnight when I wrote my first message. This morning, the solution seemed a little more obvious: within Putty, change to the /etc/config/ directory, access the timeserver file with VIM and substitute the above working timeservers for some of the existing non-working timeservers, save the file and exit. Reboot the Vera unit. So far, it looks like success! Thanks to all, especially haAllZwave!

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules