Vera 7.31 Core Firmware BETA 2 Release

I believe these JSON files all originate from Vera. They are not any that I’ve modified or installed from some plugin.

1 Like

This looks like just a disconnect between an old feature (the ability to click a link to get that file directly into the device sim) and the compression of files that is now (and has been for some time) standard. As you said, this is probably a long-standing bug. The parser error message suggests that the compressed file is being handed to it directly, rather than being uncompressed first. If you download the file and paste its contents into the device sim, it works fine.

Probably not even worth the effort to fix, TBH. I would just remove that link.

Mine works perfectly fine on the beta 1. There is a script in the web server which is supposed to decompress the file before reading it through the json interpreter. I have not loaded beta 2 yet but will today. What is funny is that the json interpreter always comes back with a ton of warnings and sometimes errors for the factory json files: A lot of ControlCode missing property etc…

My gut feeling is that the web server script got whacked in the move to a read only partition.

A lot of those warnings are bogus. Not every control is required to have a control code.

Sounds plausible, for sure. But there are a lot of inconsistencies in this area of the UI. Probably not worth fixing at this point, but it’s been iffy for as long as I can remember.

On the more general discussion: install went fine. I’ve done my automated tests with Reactor on it, and no issues, at least for Reactor, so far. Lots of other things to test yet.

I had the same problem after 7.30… after arguing with support back and fourth for weeks about it not being a problem with open ports on my router, they finally decided they could fix the problem by upgrading me to beta1… and so far its been stable… but it may just be coincidental. Im not going to update to beta2 until I see you got it fixed.

Upgraded my vera and indeed the json test does not work. No major issues observed on my unit besides this one. Well I don’t see much progress or changes vs beta1 either. I think it could be released with a list of known issues:

Misinterpreted Got CAN
Nonce Get Flood for secure class devices.
Tardy callbacks caused by hangups.
Broken app developer device json tested.
Broken extroot (though this was never officially supported)
Memory leak with Reload on TimeJump disabled.

It added another nasty virus like plugin called ezlo camera…

Cameras now work for the large pictures.

After some resets (6 times the reset button) the remote connection seems to be stable again.

It’s strange that the reset doesn’t always work. Often when I’m resetting with hitting 6 times the reset button, the power led blinks and it seem to do a reset, but when the controller is ready again nothing changed and all devices are still there. I also hat the state that at the end the power led was blinking fast and the controller was not reachable. Then I restartet/resettet the controller again.

I hope I don’t have solve this behavior every update with this buggy reset procedure.

Hi,

This installed fine on my Plus after updating the Egde earlier.

In the NetworkMonitor.log and log.lighthttpd_error I see a ton of request (3-4 per 120 seconds) for /port_49451/data_request?id=lu_alive&ts=… all failing. it looks like some cleanup is in order to remove this seemingly obsolete load from the boxes. Good candidate for next Beta or 7.32.

Cheers Rene

2 Likes

I’m finding beta 2 much more stable than beta 1. I was having to reboot my Vera every second day, now I’m back to weekly and so far so good.

Hi,

do we know when this will be available and installable on production units?

Thanks
Tony

There are still issues reported like Sensative strips that cannot be included anymore since 7.30. Will this also be solved ?

The beta2 just became the GA release for 7.31. I have to applaud the team for finally having changed the release methodology to only release beta tested builds. At least, we know what was fixed and what isn’t.
And no, the Sensative strip problem is not in the release notes so the problem is still there which to some extent is ok as long as it is known and communicated in the release note as a known issue…

1 Like

I updated my test Vera Plus. This went fast. First thing I notice now: Watt readings on wall plugs (both Fibaro and Greenwave) is not visible anymore in the UI. Can someone confirm this ?

Update: in Variables - Watts I still see the actual readings

Sorry… posted this in wrong topic

I was also having problems trying to include a Sensative strip the other week.

The device is detected and added as a Generic IO device and you can give it a name and assign a room, but the device isn’t then fully configured properly.

I’m having a major issue with an Aeotec Smart Switch 6.

I removed it from my Vera Plus while I was playing with some things on my laptop (connected via Z-Stick+) and when I went to add it back into my network I had real difficulties. My VP complained it couldn’t exchange security keys but after excluding and including it a few times it finally included properly.

However, now it only works when it’s within ~3m of the VP, as soon as I move it back to it’s prior location (which worked just fine) my VP says the dreaded “cant detect device” and it completely refuses to work in the mesh. It’s only 2 meters from another SS6 which is in between it and the Vera Plus and works perfectly.

I’ve tried everything I can think of and so far support have not gotten back to me despite logging a ticket (214679) 3 days ago!

Did you try sending it a neighbor node update request under the device option? Should wait a good couple of minutes after you do that. Then you can do the same with a couple of its immediate neighbors (all AC powered). This would be a partial heal of your network mesh.

This is why I really don’t recommend excluding and reincluding devices under any circumstances (except the security exchange failure which has no alternative) … It often times doesn’t fix anything. It only restart the configuration and risk wiping out all the progress made before. It is the same idiotic recipe as reload luup or power cycle because we have no idea what’s going on. Instead we should try to get down to the problem and figure out how to address it.
In your case it seems like a mesh issue indeed.

Sounds like you brought the switch to the Vera for inclusion, instead of bringing the Vera to the switch? In this case, the switch does not have a correct neighbor list, as @rafale77 is saying.

Although I try to always bring the Vera to the device, sometimes I can’t (or I’m in a hurry), and then I find this procedure quite reliable in those circumstances:

  1. Make sure the “non-working” device is installed in its final expected location;
  2. Find an existing, working Z-Wave repeater device that is closest to the non-working device and “on the path” to the Vera (i.e. between the Vera and the non-working, but as close to the non-working as possible)–I’ll call this the “relay device” for now. A repeater will pretty much be any Z-Wave switch or receptacle that is AC powered full time (permanently installed is better, but plugin is usually OK).
  3. Send an “Update Neighbors” to the relay device. This should cause the relay device to identify the non-working device as a new nearby neighbor, and send that topology information to the controller–the controller then knows that the non-working device can be reached via the relay device. I find the operation takes 45-60 seconds for a single node, so to be safe, let it be for a few minutes, and don’t make any configuration changes on the Vera while waiting.
  4. Finally, send an “Update Neighbors” to the non-working device, which may already be working at this point. This will ensure that the non-working device also gets a complete picture of its neighbors.
3 Likes

Yes to both. I’ve had it sitting there for 3 days untouched now.

I also tried something that has previously solved this for me:

go to the device screen… Advanced -> commands

  1. choose “Replace Failed” (this wipes the device configuration but does not remove the device itself)
  2. Hard Power cycle device
  3. choose “Configure node right now”

That’s usually how I do it for “portable” z-wave switches and haven’t had any issues to date.

For fixed devices, I would normally add my Laptop + z-stick into the network and include the device using my laptop - I haven’t tried this as I must confess it didn’t occur to me.

I’ll try your suggestions tonight.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy