Vera and Ezlo Google Home portal setup merging much strangeness?

BUG

Hello

@adina.porea @Ioana

Who at Ezlo is in charge of the Voice Assistants integrations ?

On the portal gateway https://nexus.getvera.com/ there is this drop down menu:

image

Now when I go in to the “Manage Google Home” option to configure my Vera hubs I am also seeing the Ezlo Atom listed in this area, before it was not:

I have four hubs.

Vera Edge (with Vera FW for testing)
Vera Plus (Production)

Ezlo Atom
Ezlo Plus

When going in to the “Manage Google Home” option, I see my Vera Edge and Vera Plus devices and scenes as expected.

However at the bottom of the page I can now also see the Ezlo Atom as shown in this screen shot.

Stranger still I have ZERO devices on my Ezlo Atom currently other than both VOI devices, yet its showing some devices suggesting they are from the Atom, when they are not.

I have many devices on my Ezlo hub however (2 real Z-Wave devices and the rest are bridged devices from the Vera Plus using the “Plugin: Bridge Vera with Ezlo: VeraBridge for Ezlo” and some TEST virtual devices from the Ezlo API.

The devices you can see listed under the Atom look to be some random devices from the Ezlo Plus, but not all the devices from the Ezlo Plus.

The Atom and these rogue devices should not be listed at all in the “Manage Google Home” option as this is for Vera hubs not Ezlo hubs.

If I instead look in the “Manage Google Home Ezlo” option I see this page, which looks totally different to the “Manage Google Home” page, the devices and scenes are not divided in to heading / sections and are all just in one long list merging together devices and scenes.

Also there is no indication as to which Ezlo hub these devices and scenes are from?
They do however appear to be all from my Ezlo Plus.

If I go to the “Manage Alexa” option on the menu for “Vera hubs”, I expect to only see my Vera Edge and Vera Plus devices and scenes listed which I do, however I am also now seeing the Ezlo Plus at the bottom of the page, this should not be here !

And it is showing just some random devices from the Ezlo Plus not all of them. And no scenes from the Ezlo Plus are showing at all.

If I then go to “Manage Alexa Ezlo” option from the menu, I then see the devices on the Ezlo Plus but no scenes from the Ezlo Plus listed at all.

This all now seems seriously messed up and screwed up.

@cw-kid
Thank you for reporting it.
I forwarded the issue to web portal team

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules