VERA Edge Z-Wave mesh network

Hello, is there anyway to know what network has built a VERA Edge for the Z-Wave mesh?
I tried to build it using the “Update Neighbour Nodes”, no way, I have a battery powered device very close to a mains powered one, it doesn’t use it to connect to the network and returns an offline error frequently.
One other thing I did was to go to the advanced-variable “Neighbour” parameter, edited it and put the mains powered devices close to it… same result. Even worse, the day after all the Neighbour parameters in different devices had been reset to their original (and not correct looking at the geometry of the house) values.
So, questions now:
1.- How can a find the Z-Wave network I have with my VERA Edge (last firmware updated, by the way)?
2.- Is there any way to build it in any automatically way (Update Neighbour seems not to work correctly).
3.- Why if I manually edit the “Neighbour” parameter it not only doesn’t work, but it is restored to their original (and not good enough) value?

additional information, I put the altid of the mains powered neighbour near devices in the neighbour parameter of the problematic battery operated device, I used the command to avoid the night heal, so no daily heal for the moment and after every change I also “reloaded engine”

Thanks for any help

regards

Javier

  1. not really. unfortunately, the only way is to add a secondary controller from another vendor and use external tools
  2. it is automatic. it can be forced in the latest fw. lool at this Zwave Network On Vera Explained - Community Playground / Getting Started & Initial Setup - Vera Community (getvera.com)
  3. this is what’s reported from the Zwave chip, so altering it will not modify the behavior

The best way to build a stable mesh is to have a lot of wired devices near battery ones. have you already tried this route?

See Neighbors variable of each node.

It always automatic.

It’s a mirror of data from z-wave chip. Only.

Some utils are exists. As i remember, graphic map exists in AltUI.
Or you can write small script, obtain Neigbors variables and make graph view in external sofrware.

And keep in mind, devices can be “offline” and “Can’t connect” by huge amount of reasons. Distance - latest reason of all.

Thanks to both of you. Commenting about your answers.

1.- Sad there is not a tool implemented in the VERA itself to look about it. Looking for the Neighbour parameter in each of the devices, if, as stated in your 3rd. answer, it is what the controller has implemented after its search, on top of being sometimes too work, demonstrates that it is wrong, because I have several mains powered devices near the battery powered one and, surprise, surprise, they don’t appear in its neighbour value, so, the controller has ignored them in building the mesh. WHY?

2.- Yes I DO know that thread from rafale77, very good one, of course, and I use his commands for having the best performance in my Z-Wave network. The problem is that even using the “Update Neighbour” command or the Heal, the network built is NOT correct, as the powered devices close to the battery one, or even connections between powered devices is not used nor built. This is the reason I asked for a way to define it manually.

And yes, I have several wired devices close to the battery ones and they are not used to build the mesh.

I already sent a mail to support asking for their help too, should they give me any solution, I will update this thread with it.

Thanks again and regards.

in zwave, this could be caused by a lot of things. is the device new? has it been moved recently?

AFAIK, latest fw have problems with reporting Neighbour Nodes (at least for me). I’m using a Zway secondary controller to check for the mesh. Support could definitely help in this regard.

First, a data point I haven’t seen mentioned that often causes confusion: the contents of the Neighbors state variable is Z-Wave node numbers, not Vera device numbers, so you need to make sure you find the node number first, and then go looking in the neighbors list. If you are using the wrong number, it’s not surprising to not find what you are looking for.

Next, what is your battery powered device? If it’s a well-known branded sensor that is explicitly supported, it’s possible the device is defective. If it’s Won-Hung-Lo P.O.S. brand or a MongoPrice closeout special, you may be whipping a dead horse.

Also, as a procedure, if you are doing “Update Neighbor Nodes” on a device, it should first be done on the powered (not battery) device that is nearest the battery device. You need to wait at least two minutes for that process to complete and update. The UI does not correctly update its display of state variables when they are modified, so after that process, you should do a refresh of your browser UI display to ensure you have up-to-date data. But in any case, after doing the neighbor update on the powered neighbor, then you can run it on the battery device.

I also advise putting the battery device in its wake-up mode, if you can, prior to requesting the neighbor updates on the two devices. Battery devices only talk when they want to. While logically it should be listening for neighbor requests and respond to them, it may be buggy and does not. In this case, you must have it in wake-up mode when doing both the neighbor update for the powered device as well as the battery device itself.

And of course, there’s the old standby: bring the Vera as close to the battery device as possible, and exclude the device. Then reinclude the device, with the battery device in its permanent home and the Vera near it. At this time, the basic neighbor assignment will be done and should be correct. Generally, I have nearly perfect success including devices in their installed position, much more than I do including them at the Vera and them moving them to an installed position, so I always do the former.

Answering to @therealdb: Yes, the device is new and I excluded and included it in the final place (and the controller too, it was ehere it is its place).

Regards

Answering to @rigpapa: I am using and looking for the altid parameter of each device, as I feel to have read this is the Z-Wave node numbers.

My battery powered device is a Neo Coolcam NAS-DS01Z, window&door sensor, officially supported standard by VERA Edge for inclusion, and its list of devices recognized.

In the last version of microcode I have, there is not an “Update Neighbour Nodes” by device, as far as I have seen, but a general one on Settings - Z-Wave network - Advanced. or… might I missing another one?

How can I put the device in “Wake-up mode”. I can “wake-up” the device clicking in a button, but, as far as I understand, this only implies that the device send a “I am here” message and that’s all, it doesn’t stay for a time (maybe a few seconds, no more) in that status.

Finally, I included the battery powered device in its final position, but maintained the Vera in its final position too. The include process ended without any problem, and I feel that this would have the most correct way to do the mesh build, having both in the final and permanent position, ins’t it?

Thanks and kind regards

Open the device’s dashboard card to get to its control panel, Device Options tab, and there’s an “Update Neighbor Nodes” button that lets you start neighbor discovery on just that device.

It’s very device-dependent. Some sensor will stay in wake-up mode for a minute (or even 10 minutes in the case of Aeotec motion sensors) so you can do more things. If yours is short, work fast! :slight_smile: Seriously, a few seconds is all that’s needed if you can make the timing.

I find that the location of the Vera is largely irrelevant, but having the Vera close the device makes all the difference with many devices. That why, as I said, I always bring the Vera to the device’s permanent location.

You might also try a fresh battery, especially if you’re still on the one that shipped with the device.

Hi, thanks so much for your indication about where the update neighbour nodes per device was… I didn’t find it previously, only the general one for all the system.

I will follow your guidance about start first with the mains powered device and later one with the battery (in wake-up node), and hopefully it will discover themselves.

**** Edit *****

No way :frowning: I tried it, and same result. Powered device after several minutes didn’t see the battery one and, when I did the same process in the battery one, having pressed the button for having it in “wakeup mode”, still the same, the only neighbour node is still the VERA Edge (altid=1).

Might be, as some one said, there is some problems in the last firmware related to the neighbour discovering and mesh build. Hope support can help on this.

Kind regards and, again, thanks.

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules