Vera has stopped picking up Netatmo temperature

scene
#1

I set up a scene for Vera to turn an Aeotec switch on and off at certain temperatures (the switch is for a heater). It worked fine for the first few hours with the switch/heater going on and off as the temperature went up and down. But overnight it stopped working. The temperature is from a Netatmo indoor module.

The temperature reading in Vera has stopped updating. The switch is meant to turn on at 18 degrees, and off at 19 degrees. Overnight it has had a temperature of 20.9. The switch turned off as it should have and Netatmo shows that the room did indeed continue to warm to 21 degrees and then started to cool again. But the temperature in Vera never changed from 20.9.

I’ve manually turned the switch on this morning and the temperature is increasing in Netatmo but there is no change to the temperature in Vera. I’ve refreshed several times (including hard refresh). I do get a message all the time saying start up lua failed (Netatmo 24) but I’ve always had this and apart from the last few hours everything has worked ok.

How can I get Vera to update with the correct Netatmo temperature?

0 Likes

#2

Checked at home. The same bunch.
Everything is working.
Last year there was a similar problem. Netatmo cloud in my country was naughty.

0 Likes

#3

Aside from the lua failed (Netatmo 24) issue, try changing out the battery on your outdoor temp module.

I had a similar problem whereby Vera would not update any temps and the cause was low battery in the outdoor module - this is little known issue that you’ll find if you dig for it.

0 Likes

#4

Believe it or not, I put new batteries in the outdoor module yesterday! All the modules have good battery life.

0 Likes

#5

But it’s ok now? How long was it a problem for?

0 Likes

#6

For a long time, about three months. I had to switch to internal sensors.
Now, it seems, everything is fine, but the distrust remains.
Noticed, going to the netatmo cloud, the information could not be updated an hour or more, at a rate of 10 minutes.

0 Likes

#7

Thanks for the info. For a while yesterday I was only able to see data for the main indoor unit (no rain/wind/outdoor/2nd indoor). So maybe it is a Netatmo-to-Vera interface problem. Certainly everything else seems ok in Vera. I’m going to try a reboot of Vera (although I rebooted everything a couple of times only a couple of days ago) and see if that helps.

Sorry I didn’t quote before - I didn’t realise it had to be selected and my replies probably looked quite confusing! Edit - and now the quote has been automatically removed…?

0 Likes