Vera & IFTTT integration - it can be done today!

I dream of the day Vera finally links natively with IFTTT, as do many others I’m sure. The joke used to be that Google kept its beta programs languishing forever… now, they are getting some competition in that department. :thinking:

ElCid I am seeing that it is possible to perform this integration with ifttt. Only now I ask you this question, if I want that when my phone’s wifi is detected by my local network, my vera will go to Home mode. How can I perform this action with this application?

No need for IFTTT, you can use the app WOLplusping as a scene trigger to set the home mode. You would need to set up a IP reservation on your router to assign a static IP to the phone.

1 Like

you could use automate on your phone to send a local http request to vera when phone connects to wifi. This request would start the the home mode addon ie. http://***.***.**.***:3480/data_request?id=action&serviceId=urn:micasaverde-com:serviceId:HomeAutomationGateway1&action=RunScene&SceneNum=24.

No need to have static ip. When i leave home my phone sends cloud message to local android running automate, then the local automate sends local request to turn on away mode. When i return home and my phone connects to local network it sends request to turn on home mode.

Continuing the discussion from Vera & IFTTT integration - it can be done today!:

Hello EICid, I try to setup this webhook between automate and ifttt but I am not succeed.
Can you please give me your flows and a more details steps how to set this up.
Thanks.

Try getting this flow working https://llamalab.com/automate/community/flows/28829.
this is the basic webhook from iftt to auto mate. you will need to add your secret key generated at https://llamalab.com/automate/cloud/. once you get webhook working then you can add the local http requests.

Show us what you tried as my flow is more complexed once you get the webhook working i will show you a http request flow.

After some struggles I succeed to send a webhook message via ifttt to automate. I have used the site example webform request in the ifttt webhook.
However I don’t understand what this “catch failure” part does in this totaal flow example. But it works.:grinning:

The next step will be to send a http request to my vera system, can you give an example how to proceed with this challenge. Thanks.

the catch failue is there tokeep the flow running if a failure happens it will stop the flow stopping.

i will upload an example to the community for you to look at
https://llamalab.com/automate/community/flows/32493
You will need to edit the variable set block with your vera’s local ip address

The payload would be “vera_on 23 1”
this will turn device 23 to on
or
“vera_dim 23 75|vera_on 24 0”
this will turn device 24 off and set dimming level of device 23 to 75%

here is link to possible http request to vera http://wiki.micasaverde.com/index.php/Luup_Requests#action

@ElCid, thanks for your example, but I don’t get it working.
I replaced the “app start” block from flow example https://llamalab.com/automate/community/flows/28829 by the example you upload and replace the tekst in variable set block by my vera configuration
http://192.168.1.48:3480/data_request?id=action&output_format=xml&DeviceNum=45&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=1
See screenshot from my automate flow. Any idea what I am doing wrong?

delete blocks 3, 8 and 6

remove ok link from block 24

block 4 change messagearray to payload

link ok block 22 back to in block 4.

block 22 edit “payload[0]” to read just “payload”

That should sort it.

edit/

http://192.168.1.48:3480/data_request?id=action&output_format=xml&DeviceNum=##1##&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=##2##

The ##1## and ##2## need to be there.

Webform

secret=fggrrght5fr4trgty6t555444tgggr4rfgt5&to=thetest%40gmail.com&device=&priority=normal&payload=vera_on%2023%201

You could add a fork to make the cloud message recieve respond to multiple requests, as without fork, cloud block will not be waiting till all http requests are made. As example image below


Once your flow is running in setting of automate check run after restart, then your flow will restart after your android device restarts.

I succeeded to get the flow working now. I also added the fork as in the example.
First it was also working with the static http message in automate. But with the last remark I understand now that the flow is dynamically, depending of the webhook payload. So the flow can stay the same.

I want to use this now to send the status of 3 sensors in ifttt to a vera virtual sensor. So I have to create 6 webhooks, one for switch on and one for switch off, in ifttt to transfer this status. Or is there an easier way to do this? Thanks for your support.

Yes you would probably have to create 6. Unless the ifttt sensors can trigger on toggle and report state, then you may get away with 3. In developer section of ifttt, there is the ability to make more complicated applets https://platform.ifttt.com .

edit/

the payload can be multiple commands to.

vera_on 23 1|vera_on 24 1|vera_on 25 0

each command seperated with a |

Okay, I’ll try this

I have been wondering the same. Anyone?

@delbz @Nailer00

Just a guess, but it may be the time out of the request

I know this is an old topic, and from what I can tell Vera IFTTT is still in Beta, or completely dead. Either way, I was following the steps above and created a trigger within my Vera and IFTTT and then finally got to the part about creating a Webhook. I ultimately created my Webhook as an IF and then my THAT to be what I want to control outside of my Vera hub. This works perfectly and I didn’t need steps 1-4. I can use the LUA wget to run the webhook trigger. However I got to thinking if this was a security issue or not. Or am I over thinking this and I really only needed steps 5-10 to get everything running right?

1 Like

Thanks for the great tip, its just what I need to run not zwave/vera devices.
I have run run the - local status, result = luup.inet.wget(‘https://maker.ifttt.com/trigger/Front_Garden_Lights_On/with/key/1234uniquecode5678’, 5) as the action in PLEG and it won’t turn on my device. Ive tested the code in LuaTest and it executes with no errors. Still wont turn on the device though. If I run https://maker.ifttt.com/trigger/Front_Garden_Lights_On/with/key/1234uniquecode5678 from the web browser the device turns on. What could be going wrong? could the vera be blocking an external connection?

vera setting possibly.
Try
user and info - security - allow unsafe Lua

Yes you have to have the allow unsafe to do wget calls.
They have also made the IFTTT Vera Beta available to all here: Vera Official IFTTT Integration ( BETA )

Note:
The IFTTT Vera Beta Service Allows you to use Vera as the “That”
Webhooks allows you to use Vera as the “This”

Using them together you get both directions

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules