Vera Secure or Vera Plus failsafe mode, recovery mode.

Hi!
Any known method of how to recover a bricked Vera Secure that only powerled lights constantly on, and no other leds. ?
Holding reset button when putting in power cable it boots in some state that all leds lights but power led blinks. Still no network contact.

Tftp method ?
Boot in recovery mode/failsafe mode ?
Usb flash ?
Jtag flashing ?
Special recover firmware ?

Have a hard time to figure this out. Anyone knows ? or can maybe @Sorin @melih share your knowledge of the recovery procedures.

Hello f0u,

Usually we are using TFTP to establishes the connection with the controller, then based on the type of the issue we use PuTTY and WinSCP. There is no specific method of putting VeraSecure or VeraPlus in recovery mode as it is on VeraLite or Vera3. These controllers can only be recovered if they receive and respond to an IP address

Also, as far as I can see, your VeraSecure unit is up and running on our servers.
If you have any issues with a Vera controller, I highly recommend you to contact Customer Care Department via email at "support@getvera.com"

Thank you!

Hi Ionut A
Thank you for a quick and informative reply. You are right, i have a Vera Secure up and running, my third unit. Two unit’s failed and i got replacement for them. Wonderful and great support you have in these situations!

But it raises a number of follow-up questions. It almost seems like it’s an active decision not to have a recovery mode. Couldn’t it be enabled by future updates?. Are you considering not using a recovery/failsafe mode even for future hardware too?
I think I have read many posts here about bricked devices that could certainly have been recreated here through a functioning recovery mode. It would certainly have been a very appreciated feature when the unforeseen happens. Especially when the software is so incredibly unstable and fragile.

Being forced to use third party solutions and plugins to get what many would consider to be basic functionality just make the need even more important to have a good security solution to lean back on at experimenting.

I’ve got a Vera Secure, that I can’t connect to, I’ve tried the hard reset option (hold reset in for 30 secs etc.) , but nothing seems to work. It just does not appear on the network.

To try and explain what I’m seeing, when I plug it in, the power LED comes on first, and then later the Internet and Service light with then follow and both will flash / blink, but still no IP is obtained or a connection occurs.

As I could see the LED on the network port flashes, I’ve also tried to connect it to a PC running Wireshark to see if an ARP is being made, so I can try and see if has a static IP, but no joy there either.

As it seems it’s essential that you can get your Vera on to the network before Vera support will look at it. Does anyone have any other ideas on what to do?

1 Like

Linking to this thread, if it’s of use…

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules