VeraBridge not auto connected after reboot Pi4

I am using openluup on a raspberry pi 4. After restarting the Pi4, openluup and altui start automatically according to the settings in Appendix: Start OpenLuup during system startup (openLuup user manual). Everything works perfectly only I still have to manually run a reloading luup engine to reconnect the VeraBridge. Is this normal or is something going wrong?

It’s not something I’ve found I needed to do, however, it depends on which startup method you’ve used in the reboot process. Is it possible that openLuup starts up (and it does so very quickly) before the network is fully up, so that it can’t reach Vera? Anything shown in the openLuup log?

Hi,

What probably causes this is that openLuup gets started before the local network is fully up and running. The faster the board the higher the chance this happens.

Check the method you use to start openLuup as it must be possible to have it wait for the network to be active before it gets started.

Cheers Rene

Thanks for your response. I am using this option “openLuup Start at boot with Systemctl on Raspberry Pi by groundglass”. I have no idea what to do and if it is possible to make the system wait for the network and become active before start openLuup. Maybe you can help.

I can share the log file with you if that helps

If you’re using Raspian (sorry not looked) then I think you can do it trivially using the raspi-config from the CLI

C

You can run the sleep command before your ExecStart to delay the start of OpenLuup before your network is up with ExecStartPre:

[Service]
ExecStartPre=/bin/sleep 30

2 Likes

I had the same issue and this solved it for me too. Thanks

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules