VeraPlus and sudden multiple Can't Detect Device errors

Over the last so many days, suddenly 15-20% of the devices have fallen offline with “Can’t Detect Device” and won’t respond to Vera. This includes 2 (both) thermostats, a door lock, the garage door (MyQ), flood sensor, and 3 smart plugs.

Everything else seems to work just fine. I can’t get these devices to jump back on though. So far, I have rebooted Vera from the interface and by pulling the plug, as well as the WiFi on the router (just in case). I cleared some cache and data from the Vera using some os.execute("rm… commands in case it was getting inflated (even though most of the fluff should be saved to the attached USB drive).

I’m out of ideas…

1 Like

Recover from a backup when it was working?

C

1 Like

I was trying not to do that. Although I haven’t made any changes since this started or near when it started even, I have made enough changes since my last backup and i couldn’t tell you what they were…shrug lol

Backups are made daily to Vera servers, you can grab the file when you log into your Vera and head over to settings-> backup and all the server backups are listed there. I am unsure if the z wave network is backed up there though, so worst case you may lose a few z wave devices you’ve added since this problem started if any.

Ah!! You are right! I just noticed that I was reading the date format of the list wrong. Thought it was day/month/year. I tried that but it didn’t work. Energy screen is also all messed up now like the theme won’t properly load within that frame.

So the restore didn’t help? Are the devices that stopped responding all in the same area of the home? Have you tried powercycling the z wave devices?

The devices are not in the same area. One is within 15 feet from the hub, one is across the house, with a mix in between of others. Some aren’t so easy to just unplug and plug back in (ie, thermostats, wall outlet).

For the devices you can power off try cycling them, I’ve had this issue happen before and usually power cycling does the trick sometimes one problematic device can interrupt the whole z wave network

1 Like

I had a similar experience a few years ago. My whole z-wave network all were “can’t detect devices”. It would start with a few devices. I eventually narrowed it down to a bad thermostat. Replaced it and all was fine.

By chance, do you remember the brand that went bad on you?

So far, I have rebooted even the thermostats pulling them off the walls and if there was batteries inside, stripping those and then putting it all back together. I’ve rebooted everything in every which way possible. I even deleted some stuff off of the Vera I don’t absolutely need any more. Still, half the devices show as non-responsive. WiFi signal is great all throughout the house, even from next door.

It was a Radio Thermostat CT-30. I even bought a replacement z-wave card on eBay. Here is a link to my report: Radio thermostat CT50 wifi with zwave added. I guess it was 3 years ago.

Ok. Looks like I have a different case then. I have one Honeywell and one GoControl. Looks like the Honeywell one is working again suddenly, but 9 other devices are offline still. Possibly more as some of them, if I click on an option, it times out and then that device shows as offline lol.

I had the same problem after the last firmware update. I had to restore the network from a backup and it was fine after that.

I’ve rolled mine back to all of the way to March 5th and it doesn’t even fix it. Everything else smart in the house that isn’t Z-Wave on Vera is working flawlessly. Quite annoying. Even the cheapo Chinese smarthome stuff running on Smart Life app (that’s probably spying on everything) hasn’t displayed a single issue lol.

I have had the same problem twice in the last 3 months, but with mainly tkb dimmer and on\off plugs, tried lots of things but quickest way for me was to restore earlier back up then all good

This is probably unrelated, but after switching from PLEG to Reactor, and fine tuning my logic, my LUUP restarts are perhaps every 2 or 3 days (from 2 or 3 a day at best, and 6 or 7 times a day at worse). Perhaps there is some logic in your setup causing some z-wave clashes? Oh how we miss @Rafael77.

Same happened to me yesterday, around 20% out of ± 100 devices can’t be detected , I tried rebooting Vera then some failed devices individually with no success, finally I cut energy at home for 1 minute to reboot All devices, I have not battery operated devices most of them are in wall switches, curtains and some thermostats. When Vera finished booting up all devices where detected, no errors shown. Doesn’t know what was happening but this solved the problem.

phillid2, I do have Reactor installed, but have never used it. There is some custom Lua code here or there, but nothing intense and nothing (custom Lua-wise) that has been added in over a year.

erengifo, I just tried this for the rooms with wall outlets. Everything else has been manually pulled and replugged in already. Don’t want to cut whole-house power as too many other things depend on it (ie, roommate works from home, a few servers running, too lazy to want to reset clocks of appliances…etc). :slight_smile:

So far, nothing has changed.

Have you checked how much free memory you have?

SweetGenius, Yeah.
Mem Available: 169584 kilo bytes
CPU Load (1 minute): 0.33
CPU Load (5 minute): 0.16
CPU Load (15 minute): 0.15
Last CMH Reboot: 08:52:21 Wed 31 Jul 2019
Last Vera Restart: 11:20:14 Sun 10 May 2020
Last Luup Restart: 13:16:49 Sun 10 May 2020

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules