VeraPlus Zigbee Pairing Broken - Invalid Device ID (Bluetooth is Device 2, Should be 3)

I’m having a issue with my VeraPlus and adding ZIgbee devices. I’m on the latest official firmware. When trying to add Zigbee devices I just get a spinning wheel. Logging in the logs, it’s clear there is an issue with the Zigbee Device ID - It’s look for the wrong device (Should be device 3, not 2 - bluetooth is assigned to 2). I’ve confirmed a factory reset will resolve this issue, but I really don’t want to do that because that requires a complete rebuild. Can anyone give me any other ideas on how to fix this? Logs–

08|05/12/20 10:22:48.250|JobHandler_LuaUPnP::HandleActionRequest device: 2 service: urn:micasaverde-com:serviceId:ZigbeeNetwork1 action: OpenJoin <0x72d0c520>|
08|05/12/20 10:22:48.251|JobHandler_LuaUPnP::HandleActionRequest argument action=OpenJoin <0x72d0c520>|
08|05/12/20 10:22:48.251|JobHandler_LuaUPnP::HandleActionRequest argument Duration=60 <0x72d0c520>|
08|05/12/20 10:22:48.251|JobHandler_LuaUPnP::HandleActionRequest argument serviceId=urn:micasaverde-com:serviceId:ZigbeeNetwork1 <0x72d0c520>|
08|05/12/20 10:22:48.251|JobHandler_LuaUPnP::HandleActionRequest argument DeviceNum=2 <0x72d0c520>|
08|05/12/20 10:22:48.251|JobHandler_LuaUPnP::HandleActionRequest argument rand=0.8158524091833924 <0x72d0c520>|
02|05/12/20 10:22:48.252|Device_LuaUPnP::HandleActionRequest 2 none of the 0 implementations handled it <0x72d0c520>|
02|05/12/20 10:22:48.252|JobHandler_LuaUPnP::RunAction device 2 action urn:micasaverde-com:serviceId:ZigbeeNetwork1/OpenJoin failed with 501/No implementation 

Device ID List –

<device id="2" PendingJobs="0" status="2">
<states>
<state id="42" service="urn:micasaverde-com:serviceId:BluetoothNetwork1" variable="NetStatusID" value="3"/>
<state id="43" service="urn:micasaverde-com:serviceId:BluetoothNetwork1" variable="NetStatusText" value="GET_LANG(resetting_bluetooth_network,Resetting Bluetooth Network)"/>
<state id="44" service="urn:micasaverde-com:serviceId:BluetoothNetwork1" variable="BLEAddress" value="3C:98:72:F9:41:0B"/>
<state id="45" service="urn:micasaverde-com:serviceId:BluetoothNetwork1" variable="BLEScanTimeout" value="10"/>
<state id="46" service="urn:micasaverde-com:serviceId:BluetoothNetwork1" variable="PollingEnabled" value="1"/>
<state id="47" service="urn:micasaverde-com:serviceId:BluetoothNetwork1" variable="PollDelayInitial" value="20"/>
<state id="48" service="urn:micasaverde-com:serviceId:BluetoothNetwork1" variable="PollMinDelay" value="60"/>
<state id="49" service="urn:micasaverde-com:serviceId:BluetoothNetwork1" variable="PollFrequency" value="60"/>
<state id="50" service="urn:micasaverde-com:serviceId:HaDevice1" variable="CommFailure" value="1"/>
<state id="51" service="urn:micasaverde-com:serviceId:HaDevice1" variable="CommFailureTime" value="1536885893"/>
<state id="52" service="urn:micasaverde-com:serviceId:HaDevice1" variable="Configured" value="0"/>
</states>
<Jobs/>
<tooltip display="1" tag2="Can't Detect Device"/>
</device>
<device id="3" PendingJobs="0" status="-1">
<states>
<state id="74" service="urn:micasaverde-com:serviceId:ZigbeeNetwork1" variable="LockComPort" value="1"/>
<state id="75" service="urn:micasaverde-com:serviceId:ZigbeeNetwork1" variable="ComPort" value="/dev/ttyS2"/>
<state id="76" service="urn:micasaverde-com:serviceId:ZigbeeNetwork1" variable="NetStatusID" value="0"/>
<state id="77" service="urn:micasaverde-com:serviceId:ZigbeeNetwork1" variable="NetStatusText" value="OK"/>
<state id="78" service="urn:micasaverde-com:serviceId:ZigbeeNetwork1" variable="RediscoverEnabled" value="1"/>
<state id="79" service="urn:micasaverde-com:serviceId:ZigbeeNetwork1" variable="RediscoverInitialDelay" value="60"/>
<state id="80" service="urn:micasaverde-com:serviceId:ZigbeeNetwork1" variable="RediscoverMinDelay" value="120"/>
<state id="81" service="urn:micasaverde-com:serviceId:ZigbeeNetwork1" variable="RediscoverFreq" value="120"/>
<state id="82" service="urn:micasaverde-com:serviceId:ZigbeeNetwork1" variable="PollingEnabled" value="1"/>
<state id="83" service="urn:micasaverde-com:serviceId:ZigbeeNetwork1" variable="PollDelayInitial" value="20"/>
<state id="84" service="urn:micasaverde-com:serviceId:ZigbeeNetwork1" variable="PollMinDelay" value="60"/>
<state id="85" service="urn:micasaverde-com:serviceId:ZigbeeNetwork1" variable="PollFrequency" value="60"/>
<state id="86" service="urn:micasaverde-com:serviceId:ZigbeeDevice1" variable="StackVersion" value="5.6.0 GA build 231"/>
<state id="87" service="urn:micasaverde-com:serviceId:ZigbeeDevice1" variable="PendingRemoveDevices" value="000d6f00054108fa-c247"/>
<state id="88" service="urn:micasaverde-com:serviceId:ZigbeeDevice1" variable="UnknownDevices" value=""/>
<state id="89" service="urn:micasaverde-com:serviceId:ZigbeeDevice1" variable="ZigbeePanID" value="f2cd"/>
<state id="90" service="urn:micasaverde-com:serviceId:ZigbeeDevice1" variable="ZigbeeEPanID" value="eec06eaafa6661bd"/>
<state id="91" service="urn:micasaverde-com:serviceId:ZigbeeDevice1" variable="ZigbeeChannel" value="24"/>
<state id="92" service="urn:micasaverde-com:serviceId:HaDevice1" variable="Configured" value="0"/>
</states>
<Jobs/>
<tooltip display="0"/>
</device>
<device id="4" PendingJobs="

Thanks - I’ve already reached out to support as well.

You can swap Id via code or the UI. Then reload luup engine.

1 Like

Will that break anything though? I have not swapped device ID’s before - Can you point me in the direction of documentation on how to do that?

I managed to fix this by swapping the device ID’s using AltUI and then doing a reload of LUUP fyi.

2 Likes

I’m also experiencing the same problem. I’m running firmware version 1.7.4832. (Haven’t done the latest upgrade, the last one was a horror show).
I have 1 Zigbee device which I was running on a Wink. Now that they’re going to a subscription model, I’m moving everything else off of the Wink and running on a Vera Plus.
I’m a little less skilled at hacking around in Vera. Can someone explain the device ID swap needed to fix the Zigbee pairing? Perhaps a simple step-by-step? I haven’t tried AltUI yet, not sure where to begin.

Thanks if anyone can help…
Randy

1 Like

Download the ALTUI for UI7 - From the vera app store. You can find information here –

http://forum.micasaverde.com/index.php?topic=33309.0

After you have that installed, find the device list under “More - Table Devices”. Confirm the device ID’s of the zigbee, and bluetooth radio. The Zigbee radio should be id “2” not “3”. If it’s 3 - Navigate to the bluetooth radio device under the same page by clicking the edit button, and modify the ID under “Attributes”. Change the bluetooth to a unused ID - and change the Zigbee radio to 2.

1 Like

This can be done easily on the sock UI, same steps.

Since the Zigbee and Bluetooth are hidden devices it is really not just “the same step”, without AltUI.
I assume we are talking about the “Zigbee Network”. Device? When we say Zigbee Radio?

If that is the case here is how you would change the ID:

First you need to find the device number.
I have found the easiest way to find hidden devices is by creating/editing a scene, when you use the advanced editor, and add an action the drop down list of devices you can select includes hidden devices and their ID numbers. Remarkably my Zigbee Network is device #244. Make sure the is no device #3 in you list of devices while you are there.

Then you need yo un hide the device.
To do this go to Apps->Develope App->Test Luup Code
Type in
luup.attr_set(“invisible”,“0”,244)
When 244 is the ID of your Zigbee Network

The Zigbee Network device should now show up in “No Room” when you Goto Devices. Click on the Zigbee Network select Advanced and edit the ID field to 3 (if 3 was taken like by the Bluetooth network you need to Unhide that one first and change its ID).

You can then re-hide the device by setting the invisible parameter to 1 on the Advanced tab of the device. Or call the LUA code again:
luup.attr_set(“invisible”,“1”,3)
Where 3 is now the device ID of you Zigbee Network.

Hope that is helpful (and the right device, I too tried to add my Zigbee light I had in Wink and no devices were ever detected so am wondering if this was my problem). My try out this fix myself.

Also note that device 2 I believe is usually the z-wave “ _scene controller” device I definitely would not mess with that! Or try to change the number if you are working ok.

It seems that the device had been added, but only halfway. I could see it in the AltUI, but not the standard UI7. I told it to use the D_BinaryLight1.xml device file. After reloading, it shows up, but doesn’t work. I’m getting “No Implementation” errors, it probably needs a custom I_ file.

I’ll dig around, see if I can find a Zigbee implementation file and hack that up.

Thanks for the help.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules