Virtual HTTP Light Devices, supporting RGB(WW), Dimmers, Switch and much more (Tasmota, ESP*, Shelly)

Already tried…
I deleted the device …
I created one again and went back to programming, but nothing … remains the same … :frowning:

Well i don’t understand why it wouldn’t work, maybe @therealdb will have more help for you.

Have you tried using the link in a browser to see if it works from there.

I’m not home…
Right when I get home from work I try …
But thanks for the help! :slight_smile:

Yep, try it in a browser. It should work.

Hello everyone

I just tested it on the browser http: //192.168.xxxx/relay/1? Turn = on and it works, if it goes to Vera to turn it off he says he turned it off, but the light doesn’t turn off …
What can it be?
Thanks

This is the “Params” page on Vera! Any bad config?

You have to post the variables, not the params.

Here goesimagem

AFAIK you have to use the correct case for the querystring part and this doesn’t seem correct. Turn=On vs turn=on

The urls looks correct to me.
some questions
all works when set to channel 1 “0”?
Have you set the out_on_url and off in the shelly settings for both channels?
What is the error showing on your screenshots?

I too suspect it’s something (else) weird going on, since the device will just call the URL. These virtual device are really simple.

Good morning guys!
In channel 1 everything works normal! I leave the switch one settings here!

if I run the link in the browser “http://192.168.1.101/relay/1?turn=on” the lights turn on and Vera changes the state everything is normal … but if you follow Vera off, the lights do not turn off and Vera appears as off …

What doe a call to http://yourdeviceip/settings return?

https://shelly-api-docs.shelly.cloud/#settings

Now I’m at work and only at the end of the day can I see this information! I can barely say!
Thanks again for your help! :slight_smile:

you should be able to see all this in the shelly cloud app.

this is http://192.168.xxx:3480/data_request?id=variableset&output_format=json&DeviceNum=297&serviceId=urn:upnp-org:serviceId:SwitchPower1&Variable=Status&Value=1

Are the DeviceNum different for each channel?

Yep, device 293 and 297. I think Debug should be enabled and some logs shared in order to have a proper triage here.

Sorry for the question, how do I do this?

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy