VistaCam 1200 flashing red light

My new VistaCam 1200 went to flashing red light.
Which means device exception.
Anyone know how to fix it??

Interesting. I just got mine, had it working (more or less). Then after a few hours, I have solid red light. Reset not doing anything, power cycle not doing anything. Seemed to work pretty good in the mobile app for those 3 hours, but couldn’t get live stream out of my computer browser. Browser would give a message saying it was in “Emulation” mode when you tried to view the video. Also, the video though clear, is very disappointing as it looks like it is placed behind a fish bowl. Everything is severely curved and skewed to the point where it would be hard to actually recognize anybody who approaches the door. The video in the advertisement didnt say anything about that. Hopefully that is just another symptom of whatever is going on with this less than 10 hour old device. Somehow I doubt it though.

What type of doorbell transformer are you both using? Needs to be 12 to 24 Vac with at least 12 Vac I think.

I believe its meant to also work with an 8 Vac transformer but people have reported issues with this doorbell hardware and had to swap out their transformer for a higher powered one.

"Red Light Flashing Fast Device Exception
Steady on Doorbell is powering on."

This is how one guy here got past the solid red light issue:

"I just tried to upgrade my Ezviz db1 camera directly from the version out of the box to the latest Hikvision firmware 5.2.4_200321 and it resulted in a SOLID RED button led state. I have managed to fix it and here is how…
Pull the power and wait ages for the LED to go out and remove the front cover whilst waiting, it may take an hour.

1. With no power applied and the LED no light up as it has lost power hold in the reset button and keep it held in.
2. Apply power with the reset still held in.
3. The button light will flash and when this happens push the big button whilst you still have the reset held in.
4. Wait and the camera will speak to you and go back to flashing blue LED state.

I am not 100% sure what order was important and I may have pressed the doorbell button more than once but sorry I dont feel like bricking it again to test this out so if it does not work, just experiment and then post for others on what worked for you. The key was draining all the power and turning it back on with the reset held in."

There is also a lot of useful information about this doorbell camera hardware in this 101 here. See the troubleshooting tips section.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules