Zwave Network On Vera Explained

I would most likely run the linux version if I did switch.

FYI, at least on HS3, the linux version is actually an emulated windows .NET build. That’s why some plugins don’t work as some instructions don’t get fully supported through Mono emulation… so it is still windows framework based.

https://www.mono-project.com

Yuck! that sounds horrid! :man_facepalming:

In that case I might give it a miss as I dont own the Windows version.

^^^
I wouldn’t jump to any conclusions until it becomes a RC.

They still have a long way to go, but their progress appears faster ( and in the right direction).

1 Like

That’s why I said for HS3 for what I know.

That is true… ahh building software from the foundation up… It’s magic! :dizzy_face: :crazy_face:

They’re probably migrating to .NET Core, that’s cross platform and runs good on windows and Linux. My companion code is all written in C# and runs a similar platform. Performance are super and I like C# way more than lua. With that said, they come from VB, so porting is complicated. When done, you should be able to do what you want in any supported operating system. .NET Core supports arm23/64 too and is easily dockerized with Alpine. If I have to change platform, it’s probably where I’ll head. But as I said, I will first try to protect my investment and avoid to build a complex system from scratch.

The big plus here is they haven’t changed vision with new owners.
The knowledgeable user base IE guy’s like you…is much larger and they accept input.
I like the flexibility but proof will be in the delivery - I’m still waiting on the Zee2 HS4 release before I pass judgement.

When I first started my journey into Home Automation, I wanted an appliance that could be easily hackable. From my research, Vera seemed the best answer.

I didn’t wanted to hack things too much, since my wife could probably kill me if I left her in dark or things like that (since I travel 50%+ of my time and I live between two cities each at 800 km from the other - but that’s another story and I’m not sure I will continue this way after this COVID situation). But, with Vera, I ended up writing a lot of code to normalize its weirdness and quirks.

So, if I have to write code and have a system that’s not an appliance, maybe choosing my own components is a better choice. If complete compatibility and an easy transition path are on the plate, I’m more than happy to follow this route. My only blocker is that I invested too much into Nests thermostats, my wife likes it, the interior designer that’s in me can’t like other solutions - and I have probably to run a Vera just to have the plug-in running and bridged to openluup - at least until Nest sort things out and it’s out with a new API for integrations.

I’m also exploring a couple of ideas where I can add a C# module/application to openluup and have them integrated beyond HTTP. We’ll see.

I’ll take a look at the new Linux firmware because why not, but I’m not impressed at the moment. With all that said, I think this situation with Z-wave outstanding problems not fixed in the current firmware will force a lot of people go to different platform and never look back. If I was in the dev team, I’d have put more support into this, to keep the current user base loyal. To be honest, they tried this summer, but they’re now vanished, feedback is ignored and transparency has ceased, so we’re basically left behind - like before eZlo took over. Who could assure me that this will not happen again, let’s say, in 3 years with the new firmware?

3 Likes

[quote=“therealdb, post:268, topic:210661”]
zway+openluup
[/quote]what is “ zway+openluup”? A new platform? Or are you referring to homeseer?

Z-Way is predominantly used by EU Z-Wave users, I used a version of it a few years back but the SD card that the program resided on became corrupted rendering the software unusable.
The developers didn’t want to assist with a replacement so I stopped trialling it.
https://z-wave.me/z-way/

Out of all the software I’ve looked at Homeseer has the best prospects, HASS best potential, Vera best value for money.

I have a slightly different view.
What you bought was probably the razberry but z-way is a cross platform controller which can run on windows, arm32, arm64, and linux. It is not as polished as homeseer on the automation and integration layer but is much, and by that I mean much much better than HS3 on zwave network control and command class level control and I was using it as a secondary controller/tool to configure and read devices on the network in ways the vera or homeseer couldn’t. So having openluup as the virtual device/integration and automation layer on top of it makes it perfect…
Not so sure why you would get hung up by something as trivial as an SD card which by design is failure prone. You had a raspberry pi problem. Not a z-way problem. Not sure why you would expect them to replace it. I run mine in a ubuntu VM.

1 Like

^^^
The SD Card contained the licence. They refused to help me recover the licence. nuf said.

Must be a long long time ago. Ever since I used it, the license is contained in the uzb or the razberry board. I’ve never seen it in the software…

^^^
It was. I believe it was the 1st gen Raz board, looks nothing like the ones used today.

edit: I just checked on the website and found this:

UZB comes by default without support of Z-Way. You can buy and activate the license to enable Z-Way support and benifit form our best in class Z-Wave controller.

To try a demo go in Expert user interface (Settings → Devices → Z-Wave → Expert UI) → Netowork → Controller Info → License and press Demo button. To enable full support enter the license key and press Activate.

So I’m guessing that if you buy the new Gen hat then you don’t need a key, BYO your own UZB then you do.

Correct. Once you have the key and insert it, it gets stored in the uzb and you can move the uzb to any machine, the key will remain valid.

Just to provide some clarity here to others, you must use z-way devices for this to occur.
If you use another manufacturer’s USB, then the key is not saved.

If you go down this route make sure you don’t lose the key.

BTW, does the Z-Way UZB Back Up & Restore correctly in your configuration?

Yes it does. I even used the vera to do this. I cloned the vera’s network by taking a copy of its network and saved it on the uzb. I wrote a tutorial on how to do it. Another member did the same, saved it using zway and then restored it on a razberry cap. All things you cannot do with Homeseer I heard.

Does Smart Things not come into contention here? Doesn’t the hub now do local processing ?

As far as I know, they tried hard but failed. It is not easy to move from a cloud based logic and cram it into a cheap dumb thing like the smart things which were designed to just be device bridges. The initial design concept is essential which is one of the reasons why I am so skeptical of the current eZLO firmware build up. The localized logic on ST is only partial and unreliable.

The localized version of it is made by another company called hubitat… which was started by a group of unhappy ST users.

Not quite right.
HS is unable to Backup & Restore using AEON & Z-Way UZB, it’s OK with the top hat (RaZ).
Our ZWBCUZB-AUS performs the Backup & Restore flawlessly.
AEON & Z-Way UZB has a different architecture which doesn’t allow Restore in HS. (It originally did, but then the manufacturer’s altered something in newer versions that HS is unable to map)
Weird really as you can make a Backup but then you can’t Restore it !

I’d post to the link to the discussion but Sorin would remove it so it’s a moot point.

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy