Deleting devices, deleting devices

What’s is Vera and the inability to delete devices? I have two and both have this issue. One was just restored to factory settings and has only one device. I can’t flipping delete it.

#drumbeats Have you tried a hard refresh of your browser?

What do you call a hard reset? I have tried different browsers, loading and reloading, rebooting. I have a device that I have been trying to delete for months.

I linked it in the post, but if you’ve tried other browsers, you’re good. What kind of device are you trying to delete?

Sorry I missed that. I have a garage opener that I can’t get rid of for many moons (Vera 3). Also, a sensor that showed up as a dimmer on a freshly hard reset Vera light. They just won’t go away.

What firmware versions?

Latest on both.

I’d contact support@getvera.com. Save yourself an email cycle and turn on remote access, and send the remote codes in your initial email (see Settings > Customer Care)

Thanks. I may do that. What bothers me is that the issue is resent on two different devices, different generations. It has to be the firmware.

You’ve tried using the HTTP request described in the Wiki…?

http://wiki.micasaverde.com/index.php/Luup_Requests#device

http://ip_address/port_3480/data_request?id=device&action=delete&device=NNN

Also, would be good to check if the device is a Z-wave device or not, if it’s Z-wave it may still respond to the controller to some extend and it won’t get removed from the Web UI.

You can check it by opening the device menu and going into “Advanced”, there look for “Parent id” and if it’s 1 it’s Z-wave, if it’s 0 it’s Virtual; 2. 3 ,4 belong to Zigbee ,BLE and VeraLink.

Now, if the device belongs to the Z-wave network, you will have to exclude it, if it’s real. Also, if it’s the only device on the controller, just do a Z-wave Reset and that will wipe it out.

Virtual devices or any other than Z-wave should be easy to get removed through “Delete”.

If you just cannot get rid of it, you might want to email support or send me a private message with Tech Support Enabled.

#fingerscrossed

Thanks, guys. Those are all z-wave devices. The http delete doesn’t work. Did it many times. I reset the chip on one of the Vera. That took care of it. The other one is my main device though and I cant afford doing that. The devices have been excluded.

This is odd and not the first report of this happening on this forum. It looks like the vera thinks it excluded the device but failed to reset the homeid of the device… technically failed to exclude it. I have never seen this on my units but it is concerning. If such is the case the workaround is to factory reset your device (not the vera) and then delete it without exclusion from the vera.

Isn’t a factory reset of the device the same as excluding it?

No it’s not. The outcome is the same but not the process. A factory reset doesn’t require a controller.

At least one of the phantom devices is already part of another network.

Sorry for this llate post, but, resetting the device it’s not the same as an Exclude, if you Exclude a device it’s supposed to disappear from the Web UI and “Vera’s Z-wave Chip”.

When you Factory Reset the Device, it does not get removed from the Web UI nor the Chip and it cannot be controller nor excluded anymore, so you have to Delete it, even if the “Exclude” process is successful, once you reset it it won’t disappear, so, if you ever do a factory reset on a device, do not exclude it anymore, just delete it from the Web UI directly, if it does not get removed upon delete, it means that the device is still responding to Vera, to some extend at least, so, Power-Off the device, wait 1-2 mins and then Delete it.

I hope I didn’t raise ahella lot more questions xD

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

© 2019 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy