Installing a setting up grafana openLuup Rpi3 Headless install

This was a bit of a fiddle so in an effeort to help anybody else trying this - I’m not sure I remember every stage but it might give someone a start.

I already have datayours installed and 9 whisper metrics recording to files in the LOCAL_DATA_DIR - actually its a mountpoint for my Synology NAS but it shouldn’t matter

I have the root diectory of the RPI3 mapped to a drive on my windows machine which helps copying files to the rpi

So SSH into the pi running openLuup and type the following

sudo apt-get update sudo apt-get install adduser libfontconfig

now this next bit failed for me but it might have been a temporary problem and it didnt download the deb file - so you get an error with the second command

curl -L https://github.com/fg2it/grafana-on-raspberry/releases/download/v4.0.1/grafana_4.0.1-1480722482_armhf.deb -o /tmp/grafana_4.0.1-1480722482_armhf.deb sudo dpkg -i /tmp/grafana_4.0.1-1480722482_armhf.deb

So as an alternative I used my windows machine to download from here

https://bintray.com/fg2it/deb/grafana-on-raspberry/v4.0.2

this file

grafana_4.0.2-1481228559_armhf.deb
and place it in the /tmp directory on the rpi - this is version 4.0.2 rather than 4.0.1 so I used this to install [code]sudo dpdg -i /tmp/grafana_4.0.2-1481228559_armhf.deb[/code]

this results in

Preparing to unpack ../grafana etc Unpacking garfana (4.0.2...... Setting up grafana Adding system user 'grafana' (UID ###) Not creating home directory '/usr/share/grafana'
---- not sure about the last bit but I didnt do anything about it

At this point i just started the server using

sudo /bin/systemctl start grafana-server

(After I got it all up and running I went back and did

sudo /bin/systemctl daemon-reload sudo /bin/systemctl start grafana-server
so that it restarted on reboot)

Now not sure whether the next is needed but I assume it started the grafana web server

./usr/sbin/grafana-server web

Then from my windows machine I used

http://OpenLuppIP:3000

Yay - Grafana dashboard I created a user/password and logged in.
Initially I couldn’t set up a data source so I created another organisation so I was an admin user and I could then use graphite to specify a datasource (http://localhost:3480)

I then used this video to give me a start create a dashboard

https://www.youtube.com/watch?v=sKNZMtoSHN4&index=7&list=PLDGkOdUX1Ujo3wHw9-z5Vo12YLqXRjzg2

hope this helps somebody

Hi @Nikv,
I have on a RP3 a working ALTUI on openLuup, write data to a whisper directory and installalled Grafana according your instructions.
I also added a dashboard following the youtube screencast
I do not see data appearing, can you describe how you succeeded in creating the link.
I created http://localhost:3480 and the path to the whisper directory but no success
Thanks in advance
Jacob

right this is a bit Hazy - it was a while ago… IIRC I created a new organisation so I could create a data source. I called mine openluup and set it as the default (not sure how but that shouldnt matter. EDit - tick the default box on the datasource screen)

When I create a new dashboard I then click on graph I get this view under the blank graph - first attachment below

clicking on the panel datasource should give you a list --> default, “openLuup”, Mixed and Grafana ( mixed an grafana just have test data) - I assume you need to select “openLuup” here (my default is already openluup so default works fine for me --> see second attachment

Then moving to the query above this box --> click on metric - see 3rd attachment - I think that the “airing cupboard”," “cold tank” etc are data sources set up on the variables in ALTUI, I use the vera-88800000 entry, this should give you device numbers (see 4th attachment) in the next metric box which have variables being watched in datayours. So you work across to the right drilling down until you get to the watched variable. On mine the datapoint appear after drilling down to the variable level.

Im assuming that you have data appearing in datayours. IIRC there was a short delay after setting up the datasource in this screen until the valid metrics appared in the query line.

At some point I had downloaded a file from AKBooer that he posted in another thread - I think it was L_DataGraph7.lua but I dont know if its needed or not for graphite to query the whisper databases or not. (this was before the latest version of datayours so it may now be correct in latest version)

nik

limited to 4 attachments so needed a new post

does your data source test out ok - see attached datasource screen

@NikV
Thanks for your reply and explanation
I practically did all you suggested the only change was the Basic Auth checked (i tried today)
However it appears in the tab Metric and selecting the data source there appears no list of channels like in your example
I think in the OpenLuup/Datayours there is a problem
I will install from scratch the comping day’s
Jacob

@NikV
Found the problem
Installing datayours into openLuup did not create directory /www/
Did it manually and performed an update via More->Plugins
After this the file DataWatcher.conf populated the directory /www/
Now I could select the information in the grafana dashboard
Thanks again
Jacob

Glad you got it sorted

I had to create the /www/ directory just to get datayours to keep watching the variables past an openLuup reload and save the datayours graphs as well

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules