iPhone Credentials Not Being Saved ver 2.44

I’m giving this another go and it won’t save my credentials. I enter the icloud pw, choose a device and if I change the screen or tab the device disappears.

Same issue here. I accidentally changed my iCloud email address and even though I’ve changed it back, my iPhone is no longer being tracked like it used to be… :frowning:

Have you tried forcing the credentials in the advanced settings:

Don, everything actually looks correct in my advanced settings…

Weird thing is that the dysfunctional instance of my iPhone just randomly started tracking again but now I cannot control any aspect of my wife’s nor mine (can’t manually mute the phones, set them as present.away…) I don’t understand what’s going on…

Each of the two iPhone devices I created from the plugin are saying “command failed” when I try to change their state now.

[quote=“agoodman82, post:4, topic:198672”]Don, everything actually looks correct in my advanced settings…

Weird thing is that the dysfunctional instance of my iPhone just randomly started tracking again but now I cannot control any aspect of my wife’s nor mine (can’t manually mute the phones, set them as present.away…) I don’t understand what’s going on…

Each of the two iPhone devices I created from the plugin are saying “command failed” when I try to change their state now.[/quote]

I have no idea whats going on, never seen or heard something like that before
first is your environment : brower version, UI version, vera type

I would recommend you :

  1. desinstall the app from the UI7/Apps/My Apps
  2. reload luup
  3. reinstall from the app store
  4. wait and reload luup
    5 ) go to IPhone locator and enable debug mode
  5. Open javascript console ( ctrl J on chrome )
  6. go to settings tab and enter your email / pwd,
    leave the pwd field and confirm the button changes from refresh to refreshing then to refresh again
  7. confirm that it works and that you see your devices assocaited to that account in the list
  8. select one and move it to the list on the right list

if that fails please share : console javascript log , lua debug log ( cf micasaverde wiki or top level posts of that forum on how to get the logs ) and screen shots to show at which step exactly it fails

thx

@amg0:

I’m not even sure what happened to the other day, but randomly, my iPhonelocator plugin issue just disappeared and both instances of my plugin started working again without me having done… anything. Both function as they now should with tracking, and being able to manually manipulate actions like mute/unmute and home/away.

Thanks for the advice though! Now if I could just drag @VeraMate back to these forums so he could update his app so those of us using it could still get push notifications for our scenes using the iPhonelocator plugin, I’d be back to operating at 100% ::slight_smile:

I moved over to Pushover last week - I could not live without notifications. Otherwise VeraMate still working fine otherwise.

I moved over to Pushover last week - I could not live without notifications. Otherwise VeraMate still working fine otherwise.[/quote]

ALTUI ( other plugin ) offers lot of features for notification. it includes IFTTT trigger support or a https://www.pushingbox.com/ support with a ALTUI.notify( pushingbox_DID, str ) function callable from scene or workflows for instance

Thanks for that information. I have a Vera 3 so I am staying away from too many plug-ins. I do have a RP3 boxed in the garage I may set up with Openluup and AltUI. But time prevents me from looking into that anytime soon.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules