Lost icons

Somewhere along the way several of my device icons have been lost. I was hoping to correct the problem. I can find them by searching with WinSCP. Perhaps the icons are in the wrong location. For example:
The Multistring plugin icon is missing when showing Devices. The icon name is “MString.png”. Where should it be located? I tried copying it to mios/www/cmh/skin/default/img/devices but an error message sain that the folder was read only. Any suggestions would be appreciated.

Thank you, Mark

Use another browser and see…

Thank you for the reply,
Just tried Opera and it looked exactly the same.

Try Chrome or Firefox lastly :slight_smile:

Edit: you are also accessing cera locally or remote? Remote is known to miss some icons …

1 Like

You could try:

mios/www/cmh/skin/default/img/devices/device_states/
1 Like

@MarkAgain , if you’re still having these issues don’t hesitate to ask our support team as well.
Hit the “I need Help” button up top.

Since you mention Multistring, which is a plugin, I’m going with this: I’m guessing that you’ve recently updated your firmware to 7.30 or 7.31. They introduced new restrictions on the location for icons. As of 7.30, the designated official on-board location for icons is now /www/cmh/skins/default/icons.

You can place/move your icons there, but that alone won’t fix the broken plugins that still try to use the old location in their UI URLs, like Multistring. All plugins that have used any other subdirectory in www/cmh/skins/default other than that icons directory will need to be updated. Many used to use /www/cmh/skins/default/img/devices or its child .../device_states… these are all read-only now and cannot be used.

The correct relative path to use in static JSON (the D_xxx.json files) to refer to the new official directory is now ../../../icons/<iconfile>, where <iconfile> is the name of an image file in /www/cmh/skins/default/icons.

Note: In my plugins that use on-board icons (really only Sonos for historical reasons), I don’t copy files there, I create a symbolic link to the file in /etc/cmh-ludl. The icons directory is on the root partition in this firmware, which is smaller than the partition /etc/cmh-ludl is on, so using a symlink saves a little space on the root.

Several of us objected to this when it was happening, for many reasons, but didn’t prevail. On the plus side, though, it will help highlight which plugins no longer have maintainers that need someone to pick them up.

1 Like

Thank you to all for the suggestions.
@rigpapa
I just don’t understand WHY the decision was made to break older plugins! I sure can’t replace some of them with something newer as it doesn’t exist!

With that said, I edited the D_MString_UI7.json and D_KiraRT_UI7.json files and saved their icons to the location as suggested. This got both of the icons to reappear. Thank you! I have several more to work on.

Thank you, Mark

1 Like

I want to add/replace the DSC alarm plugin icon. The existing D_DSCAlarmPanel1.json shows the icon file as:
“flashicon”: “icons/generic_sensor.swf”,
How would the .json file be edited?
Can I add an icon that I create to the new icon location?
Thanks again, Mark

Keep in mind this is just a visual change; it doesn’t affect the operation of those plugins at all.

Thank you for all of the information!

Mark

1 Like

Good evening,
I’m making a little progress. The DSC Alarm plugin has lost it’s icon as well. I edited the json file and it displays an icon that I created. I’m trying to understand where the original code was pointing to:

**"flashicon": "icons\/generic_sensor.swf",**
"imgIconBody": "",
"imgIconDimmable": "",
"imgIconTurnable": "",
"imgIconMin": "",
"imgIconMax": "",
**"halloIconsDir": "pics\/hallo"**,

Please let me know where this icon was/is located and how I might correct it.

Thank you, Mark

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules