PLEG - Been years; how do i even see existing scene?

Hi - It’s been probably 6 or 7 years, so I have completely forgotten how to do this.

Basically years ago I had a motion sensor outside that I wanted to trigger a scene (which would in turn activate a switch) for 30 minutes each time it detected motion. So basically it would reset the ‘30 minute’ activated timer for 30 min each time, meaning as long as it detected motion once every 30 min, it would remain on all the time.

In the end i used PLEG with a basic few lines of code, but now I can’t for the life of me remember how to get to it.
looks like i’m using CMH_UI6 (this is ‘advanced mode’). the ‘simple ui’ is a lot simpler.

In the ‘devices’ tab, i see ‘Pleg’ (and it’s “Armed”), but when I hop over to scenes, I see all the scenes I have created for various things, but not sure where the PLEG code i used goes?

When i open the “pleg” plugin, and click ‘edit’, it just freezes on “Opening plegInit…”. Would that be where the code is?
Same ‘freeze’ issue when i try to go to ‘scenes’ tab in pleg. “Opening devices_scenes…” stays indefinitely

I understand you’re asking for help with PLEG… but have you looked into the reactor plugin? It’s much more stable, and dead easy to use. You could replicate your PLEG recipe in a minute!

Thanks, but with a setup this old, running this outdated firmware, i don’t want to try something new :slight_smile:
Thanks though - i’ll definitely look into it.

1 Like


This is the ‘pleg’ i see in devices. I could have sworn there was another box here at one point that had a ‘conditions’ tab, etc. where everything was set.

Ah still on UI5… nostalgia !!
Those were the good times :grinning:

1 Like

Yeah i’m not going to upgrade unless it becomes necessary - this thing just WORKS. I haven’t had to make a change to the config in probably 5-6 years.
Please let me know if you think i SHOULD upgrade (major security flaw, etc)

I was forced to upgrade to UI7 3-4 years ago because I bought some new zwave plus devices that did not work on UI5. Faced many troubles… A month ago I started from scratch again (for third time…) with latest firmware 7.31. Stopped using some old plugins and started with Reactor. This can plugin can replace several others and also I don’t need any scenes any more. Till now it runs stable.

I have a very basic setup (although extensive). Two door sensors that turn a light on when the sensor is tripped, and off when it’s not. Then i have the outside 30 min timer PLEG. And outside of that i have a ‘day/night’ plugin that turns outside lights on at ‘night’, and off in ‘day’.

About ~60 z-wave devices total. Most of those are light switches and power outlets, but a few motion sensors, door sensors, etc.

Don’t upgrade.
I’m running a Lite on UI5 with PLEG and it’s always been rock solid.
In my case all that PLEG ran was sensors and lights which don’t require fiddling.
Any new devices went to a Edge which has generally been a PIA after UI5, not sure what the future will bring but the Lite will be there until it croaks it.

1 Like

In regard to PLEG, hover your mouse over the right hand side of the top bar and a settings symbol will appear, click on it and the rest of PLEG will open up.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules