Reactor Activities not firing under 7.30

Hi @rigpapa , I’m having an issue with some reactor logic not firing despite conditions being met under 7.30 - oddly it’s only happened to some of my HVAC logic so far. The only way I can get the logic to fire is by disabling the reactor sensor and then re-enabling it.

As you can see below, all conditions were met and the sensor was tripped but the Activity (turn on Lounge Fan) never fired - when I disabled the reactor sensor then re-enabled it worked instantly. This has been randomly happening since the 7.30 Charlie Foxtrot.

i had the same issue but it would reload luup, for me its down to space. somtime it would run reactor and just realod in the middle

OK. I’ll need to see a Logic Summary (Tools tab), preferably made right after the logic conditions are met and fail to fire.

It’s really bizarre, I cant recreate* the fail conditions at all today - if it happens by itself I’ll grab the info.

*I tried changing thresholds to recreate the condition’s but it fired every time.

I have had a few luup restarts under 7.30. It seems to have happened when two reactors where tripped at the same time. Discovered by disabling associated reactors and using the process of elimination. I tried to pull a summary but got back something like no data and at that point I had to leave for the day. I worked on the logic remotely and resolved by delaying the triggering of a reactor until the other was doing what it needed to do. I will also note that the luup restart was in the middle of an activity since the first action in the group fired but not the susequent actions. I am hesitent to reboot the Vera since it is a plus running the problem FW. Can try to restore reactor from backup and try logic summary again providing that my Vera does not self destruct in the mean time. Just will be quite busy over the next few days.

It would be interesting to know just what type of action that was. My guess is that activities are triggering just fine… there is nothing specific to 7.30 vs 7.29 that would cause Reactor to behave any differently in that respect. But, more likely is that the operations being performed are triggering a bug in the Z-Wave stack, which has been through some wool-pulling between 7.29 and 7.30 and may have some new, exciting things for us to discover. Until we get it nailed down more, though, we can’t know, so collecting good data and being careful and diligent in the approach is key here. It is very likely that Logic Summaries and navel-gazing alone are not going to show us much, and I’ll actually need log snippets to get to the bottom of it. We need to see the sequence of events and what messages are logged at the time of the reload.

Yeah, I actually meant log snippet. I had set to debug mode, restarted sensor, waited a few minutes and when trying to pull snippet I got a message that there was no data. Something like that anyway. I was in quite a rush as I was running late. The action that fired was turning on my AV receiver and the actions after that failed were setting 2 switchboard virtual switches off. I discovered it was in a loop restart after trying to switch from the status tab to activities. I should have some time on Saturday to try the log snippet again.

OK. Are you currently on 3.4, or the 3.5 pre-release?

When I was attempting to pull the snippet. There was a notification that there was an update so I just updated the general release. I have not install the beta you posted the other day. The issue still persisted after the upgrade, it was not intermittent, happen every time I tested.

P.S. checked, its 3.4

Yup, there’s a bug in the snippet generator for 3.4. I’ll pull together an update on the hotfix branch (only the JS file needs a fix) and let you know when it’s up. Give me a few moments…

OK. It’s up in the hotfix branch.

Thanks, will, get you something later tomorrow or Saturday.

1 Like

Patrick, I tried to step back to the configuration that was causing the issue and of course today I cannot replicate. I installed the hotfix L_Reactor lua as well as the js for the snippet fix that you recommended. Is it possible that the L_Reactor lua hotfix remedied the issue? Anyway, I will continue to monitor but all seem ok for now.

I did notice that uploading a reactor-config-backup.json in the Vera interface did not update the current backup and I needed to overwrite the file via winSCP. It seems that using the vera interface lzo compresses the file with a lzo extension but Reactor is looking for backup without the lzo extension,

The changes to the Lua file were very limited and only cover the issues described. I’m very careful to keep the hotfixes to the absolute minimum, to avoid injections. And neither of those two fixes was significant or would have affected how activities are run. Keep an eye out. Grab a Logic Summary and your LuaUPnP.log file in its entirety if/as soon as you see it pop up again.

Yes, this is an issue, and I need to spend some time on that area in general to make it more user-friendly. At the moment, I’m kind of slow-playing the deck and seeing how the 7.30 landscape evolves.

1 Like

I can’t replicate the issues despite not changing a thing, very bizarre!

© 2019 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy