Reactor ERROR:Module not found:cgi-bin

Hi All,

Not sure what to do here, but I have the following error when I try to look at the log file in reactor.
ERROR:Module not found:cgi-bin

I have uninstalled reactor, rebooted, reinstalled and have tried to reload luup as well and nothing works. I also tried to clear data and it returns: %REACTOR-REQUEST-F-NOTIMPL, requested action is not implemented

Each time is try to create a sensor, I get the following error message
Reactor has detected that the Vera UI may be badly out of sync with the Vera itself. To remedy this, please (1) reload Luup or reboot your Vera, and then (2) do a “hard-refresh” of your browser (refresh with cache flush). Do not edit any devices or do anything else until this issue has been remedied.

Status of the new sensor states cannot detect device and states failed (see log), but I cannot access logs.

Question is this, is there a simple fix for this or can I just remove files from SSH terminal and start fresh to correct this? TIA!

*************************************************** REACTOR LOGIC SUMMARY REPORT ***************************************************
Version: 3.7-20190 config 20190 cdata 20045 ui 20190 pluginDevice 29 LuaXP not loaded
System: Vera version 1.7.5186 (7.31) on Sercomm G450 ID 36 (Vera Plus); loadtime 1600180173/1600180184; systemReady 1600180189
Env: Lua 5.1; JSON dkjson 1.2; UnsafeLua=nil/true
Local time: 2020-09-15T09:37:03-0500; DST=1; Haslet, Texas United States; formats false false
House mode: plugin 2; system 2; tracking off
Sun data:
Geofence: not running
RS: 1600180184
NS: 0:X,1600180200:U

Plugin files
{“serviceVersion”:20185,“files”:{“J_ReactorSensor_UI7.js”:{“compressed”:true,“check”:“d41d8cd98f00b204e9800998ecf8427e”},“L_Reactor.lua”:{“compressed”:true,“check”:“d41d8cd98f00b204e9800998ecf8427e”},“D_ReactorDeviceInfo.json”:{“compressed”:true,“check”:“d41d8cd98f00b204e9800998ecf8427e”},“S_Reactor.xml”:{“compressed”:true,“check”:“d41d8cd98f00b204e9800998ecf8427e”},“J_Reactor_UI7.js”:{“compressed”:true,“check”:“d41d8cd98f00b204e9800998ecf8427e”},“D_Reactor.xml”:{“compressed”:true,“check”:“d41d8cd98f00b204e9800998ecf8427e”},“J_Reactor_ALTUI.js”:{“compressed”:true,“check”:“d41d8cd98f00b204e9800998ecf8427e”},“D_ReactorSensor_UI7.json”:{“compressed”:true,“check”:“d41d8cd98f00b204e9800998ecf8427e”},“D_Reactor_UI7.json”:{“compressed”:true,“check”:“d41d8cd98f00b204e9800998ecf8427e”},“J_ReactorSensor_ALTUI.js”:{“compressed”:true,“check”:“d41d8cd98f00b204e9800998ecf8427e”},“I_Reactor.xml”:{“compressed”:true,“check”:“d41d8cd98f00b204e9800998ecf8427e”},“L_LuaXP_Reactor.lua”:{“compressed”:true,“check”:“d41d8cd98f00b204e9800998ecf8427e”},“S_ReactorSensor.xml”:{“compressed”:true,“check”:“d41d8cd98f00b204e9800998ecf8427e”},“D_ReactorSensor.xml”:{“compressed”:true,“check”:“d41d8cd98f00b204e9800998ecf8427e”}},“timestamp”:1600180715,“installpath”:"/etc/cmh-ludl/",“pluginVersion”:“3.7-20190”}

Activites Tab Error
Error executing function ReactorSensor.doTools(): Cannot read property ‘root’ of undefined

When I get the “badly out of sync” message. I reboot and “hard-refresh” and then I have to give the unit some time before the message disappears.

Thanks, I have done this already. I seem to have a corrupted configuration.

Looks like you are mixing a whole bunch of things in this post, flailing a bit. You need to slow your roll so we can understand what you are doing.

First of all, none of those links works via remote access. Are you using local access to your Vera?

Also from what you posted, it does not appear that you have reloaded Luup more than once. I should be seeing multiple reloads if you have followed the instructions in the error message. You also need to hard-refresh your browser, as the message says. My guess is that has not happened. Instructions here: https://www.getfilecloud.com/blog/2015/03/tech-tip-how-to-do-hard-refresh-in-browsers/#.X2D_2WhKhdg

And, logging in via SSH and removing files is not the way you uninstall plugins. That’s done from Apps > My apps if you originally installed from the App Marketplace (which I assume you did). And don’t do that (uninstall) either. Let’s work this until we get it.

Thanks @rigpapa. Sorry for all the data. Let me do this all with local access and update the post. All I am trying to do is get the reactor to run initially. I completely think this is something left over in the config that did not get removed cleanly. My fault and nothing but great things to say about this plugin.

If you have not used it, it is a must as it is really awesome!!!

No problem, it’s just that so many things happened, it’s hard to know where you currently are and to go one direction. At this point, don’t uninstall anything. Let’s focus on the system as it is. If you have a Reactor master device (blue icon) with no red messages on it, that’s a good start. There has not been a case yet where, after creating a new RS, a reload of Luup and (real) hard-refresh of the browser has not solved the problem. I’m pretty sure once you have local access and can do those steps, you’ll be OK. Let me know how it igoes.

Alight, I am finally home with local access. Many of the errors went away as you stated such as not being able to view log etc.

Here is my issue. When I create a new sensor, it cannot detect the device.
I have attached an image and the log file from the error. Please let me know if you have any ideas on what I can try to fix this. Thanks!

luaupnp log.zip (26.8 KB)

The log is just showing that you need to reload Luup again.

Go to Apps > Develop apps > Test luup code and run: luup.reload()

Thanks @rigpapa. Looks like the issues are resolved.

For anyone else that has this issue. Give it time to set in. I did the refresh of luup as recommended and it is all good now. Hard refresh of the browser was not reloading luup for me and causing the error.

Again, awesome app for Vera and a must have!!

To clarify, reloading Luup and hard refreshing the browser are two separate things. Very often both need to be done, but one does not automatically do the other. If that was your expectation, that may be why you weren’t seeing the result you wanted sooner.

1 Like

Thanks. Root cause was 1. doing this remote and 2. not reloading Lua. By far one of my favorite plugins for Vera

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules