RFXtrx with Lighting4

Hi,
I have a RFXtrx433E working on my Vera Plus Platform. It works perfectly with some Somfy produts (awnings and shutters but I can’t pair the lights of my swimming pool that work with Lighting4 protocol.
When I see the configuration of my Vera Plus Ligthing4 appears as enable but I can’t select this protocol when trying to include the new device.

I guess you have a remote that came with the lights? If so, try this:

  1. In the RFXtrx page in the Vera web page select Managed Device and enable Auto creation.
  2. Using the remote for the lights and while close to the RFXtrx transceiver, turn the lights on and off several times.
  3. Hopefully, a new Door Sensor will show up as a new device
  4. On the web page for that device go to Advanced -> Params and note the value for the altid - probably DS/D/xxxxx
  5. Note the xxxxx portion (the device ID) and using the Windows calculater -> Programmer convert this to decimal
  6. Go back the the RFXtrx device page and select new device
  7. Select Sonoff Smart switch from the drop down
  8. Give the device a name and enter the decimal value of the device ID, then click Create
  9. If all goes well you should be able to control your lights with the device you just created
  10. You can then delete the door sensor device.

Hi,
I did the steps 1 to 6 without any problem but, in step 7, when trying to select a new device, the option Sonoff Smart is not available.

Thanks

What version of the plugin are you using? (Go to the the RFXtrx device page and select Help).

Here you are:

Plugin version: 1.611

RFXtrx firmware: 1024

Any version at or later than 1.60 should have the Sonoff switch. I don’t think I’ve created a version 1.611 but the current version is 1.87. You can find all the files for the latest version in a ZIP file attached to this posting: Plugin Update V1.87
Upload all the files and try again to create a Sonoff switch device.

Thank you Tinman,
I have, succesfully, updated the Plugin Version to 1.87.
Firmware version for RFXtrx is 1024 and firmware type is Ext2.
Now, it is possible to choose SONOFF switch, when including new device, I followed your instructions but the lights can’t be controlled yet.
I had to re-include the Somfy Shutters and the ASA Awning but they work fine currently.
If there is any new idea about how to proceed, I will try with it

The only thing I can suggest is to use the RFXmngr program that you can run on your Windows PC or laptop. Connect the RFXtrx transceiver to the PC and run RFXmngr (available for download at RFXCOM.com). Once the program is connected to the transceiver, make sure the Lighting4 protocol is enabled. Operate the pool lights with the remote and note what appears in the log screen of RFXmngr. Let me know what you see there.

Hi Tinman,
Sorry for my late reply. I tried what you suggested and I got the Lighting4 code of the remote but even by putting the RFXtrx beside the controller, it has been impossible to pair the RFXtrx. I think the controller from BS Light didn’t work properly. I solved the problem by using a Fibaro RGBW and it works perfect.
Thanks a lot.
Now, I am trying to incorporate a Remote Control for the garage that works with KeeLoq protocol but my Vera doesn’t present any option for KeeLoq devices vene by having select the KeeLoq protocol as enabled.
Is there any possible way to incorporate this kind of device?
Thank you.

Sorry vfbueno, the plugin does not yet support the all the Keeloq devices. I will plan on adding more support in the next version.

Keeloq devices normally use the encrypted part of the keeloq message and this cannot be created by the VERA application as the keys and algoritme are not know!

Hi tinmam,
I’ve faced similar issue by trying to control a miboxer LED control remote. By connecting RFXtrx to a pc Lighting4 commands seems working (tested only one command). But the id seems depending on the button pressed on the remote. When I go back to vera in auto add devices mode in the RFXtrx plugin, the led control unit provides around 8-10 devices (door sensors and one motion sensor). The IDs of these are similar to the identified IDs in the RFXmngr. Like: DC0E0, 2C0E0, etc…

To receive the LED remote as Lighting4 you have to disable X10.
With X10 and Lighting4 enabled the Lighting4 commands are translated to X10 security and is used for Kerui sensors.

Thanks, Unfortunately only Lighting4 is enabled and unable to control through Sonoff smart switch device. I’ve checked all 5 buttons and the dimmer bar what codes they send. In case of buttons the code is 2C0E00, D…, B…, 4…, 9… So the fixed part is C0E00 hex. That is 790016 in dec. By creating a sonoff switch with that ID it doesn’t work. In the meantime RFXtrx creates automatically 12 new devices. (Some of the are doubled)

There was some progress in the past hour… Two toggle switches are finally operating. With one on command is sent with the other off command. The solution was that the entire code should have been provided. Is there any way to create toggle devices/switches or dimmer devices as well for the same device configuration?

I don’t know how Lighting4 is implemented in the VERA plugin.
Check with RFXmngr what is received, this displays the ID and pulse timing and makes the packet clear I hope.

Alright, keep on investigating. Thanks for the help so far!

I need to expand the handling of Lighting4 devices in the plugin. I’ll do this for the next version of the plugin.

Progress so far for those who are also interested in an easy solution to use Lighting4 together with VERA. After gathering all status codes by RFXtrx a virtual dimmer should be created. I’m using SwitchboardPlugin. In either a reactor module or Pleg. (I’m actually using reactor) On/off state shall be defined by rules. Inputs are coming from the state of the virtual dimmer. The output is the trick. I’ve created separated devices (Sonoff as advice) for each code written down in the first phase. Entire code after “Code=” in may case because these unique codes representing one unique command. Each output in the reactor logic is a toggle trigger of one of these devices. For example in case of VirtualDimmer on state and VirtualDimmer LoadLevelTarget < 33% ToggleState of the device which is representing my “low” button on the remote. The next step will be to record all brightness codes of my remote and make the dimming more smooth then only using 3 levels and on/off.
The RFXtrx device is really useful and flexible to configure together with vera in case of unknown low cost dimmer remotes too. Thanks again for the developers! :slight_smile:

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules