Soft start lights

I’m wondering if somebody could point me in the right direction…
I have Fibaro dimmer 2 modules and I’d like them to ‘soft start’ my lights when they’re turned on and off.
So rather than my light turning on full at brightness it’ll dim up gradually to full brightness,and when turned off it’ll dim down gradually to off.
I’m guessing there may be a plug in I can use?
Or possibly it’s in the parameters in advance settings?
I have very basic knowledge of the programming side of Vera and controllers (I’m a electrician so wiring it’s fine-where as programming not so much) so excuse my ignorance.

Thanks for your help.

My Fibaro Dimmer 2 modules ramp the bulb down when turning off the light. Not sure I did anything to achieve that.

However they do not ramp up when they are turned on, they just go to full brightness.

I never looked into it before, but it would be nice if they also ramped up.

If you download the Dimmer 2 manual you’ll find many options for ramp timing.

The manual references setting for the Fibaro home center not the Vera plus that I have :-1:t2:

The manual describes parameters and values that can be set to control the functionality. In Vera, use the Device Options tab to add and set new parameters.

1 Like

Yea this is what mine do. It’s the default for dimmer 2. But it would be nice if it ramped up when turned on

I will have a look at the parameter settings and test at the weekend. I have no time till then.

Let me know if you find anything thanks. I’ve tried this evening but nothing :confounded:

The only parameter settings that appear to be possibly related to this are these ones.

I am not 100% sure about the difference between “Automatic Control” and “Manual Control” presumably automatic control is when the dimmer is controlled by another device via a Z-wave association group.

image

There are different user manuals for different firmware versions of the Dimmer 2 modules. The latest is v3.5. The Dimmer in my lounge is v3.3.

Within the Dimmer device in Vera, under Device Options, I added Parameters 5,6,7,8 as monitor only initially expecting it to show me the current values of these parameters however it did not which was unexpected.

I then attempted to set parameter 8 to 20 with 2 bytes Dec. The default value is 5 = 50ms. So 20 = 200ms.

However after saving, reloading and refreshing the browser the parameter value is not set.

The correct user manual for a Dimmer 2 module with v3.3 firmware does have these four parameter settings, so I am not sure why its not being set ?

EDIT: I’m an idiot LOL. Automatically Configure was set to NO. I have changed this back to Default Behaviour and now the values are showing correctly.

I think my ceiling light now turns only more slowly but kinda hard to tell. I will try increasing Parameter 8.

EDIT 2: I have changed Parameter 8 to 255 with 2 byte Dec. Its maximum value.

This parameter makes no difference to the ramping when turning on or off the light.

All it appears to do is slow down the dimming or brightening.

Changing Parameter 7 from a value of 1 to 10 with 1 Byte Dec. this changes the dimming step. It now Dims / Brightens in 10% steps rather than 1% steps.

I don’t think any of these parameters are for altering the “Ramping” so the light turns on from off gradually and doesn’t just jump to fully on right away.

I can’t see any other parameters in the user manual that are related.

It might be possible some other way, I seem to recall there was an old plugin for ramping or it might be possible with some LUA code ? It needs more research.

I’ve just noticed these options for the Fibaro Dimmer 2 in a Vera scene advanced editor:

image

I created a new Vera scene called “Main Light Ramp Up”

I selected the load level 100 and the time as 10.

When I run the scene nothing happens the light is not turned on at all.

I then tried “StartRampUp” instead

However nothing happens when running the scene.

So maybe the Fibaro Dimmer 2 does not support these commands.

This was that old plugin not sure it still works ?

WakeUpRamp plugin

I have a different model dimmer and have changed the “Dim Rate Adjustments” as shown below.

The difference between Auto and Manual is Auto=Z wave controlled and Manual=pressing the dimmer’s button.
The MFR doc explains:
Both the number of steps (or levels) that the dimmer will change and the timing of the steps can be modified to suit personal preferences. The timing of the steps can be adjusted in 10 millisecond intervals. As an example, the default setting for parameter 8 is “3”. This means that the lighting level will change every 30 milliseconds when the Dim Command is received. A value of 255 would mean that the level would change every 2.55 seconds. Combined, the two parameters allow dim rate adjustments from 10 milliseconds to 4.2 minutes to go from maximum-to-minimum or minimum-to-maximum brightness levels.

edit - I also learned that you can have text after the Variable number separated by “-”.

1 Like

Thanks.

I set parameter 6 to a value of 30 with 2 Byte Dec and that does really slow down the “Ramping” when switching the light on or off via Z-Wave.

It also slows down the dimming / brightening time.

30 is a bit too slow however so I tried a value of 10 instead and that is more to my liking.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules