[Solved]Configuring Google Calendar

Need help to setup the calendar.
I have followed the manual and finished the “Setting up a Google V3 API Service Account” (service account created).
The user rights for the new user is set in the online google calendar.
I have installed the app and am trying to configure the calendar.
I am using the standard name of the json file and have uploaded it to Vera.
I paste the ID:
Then Press “Set”

First it say: see attached file.
Later it say “** ** No more events today”

However, I have several meetings in the calendar for the current day?!

[quote=“paros, post:1, topic:198171”]Need help to setup the calendar.
I have followed the manual and finished the “Setting up a Google V3 API Service Account” (service account created).
The user rights for the new user is set in the online google calendar.
I have installed the app and am trying to configure the calendar.
I am using the standard name of the json file and have uploaded it to Vera.
I paste the ID:
Then Press “Set”

First it say: see attached file.
Later it say “** ** No more events today”

However, I have several meetings in the calendar for the current day?![/quote]

Tried with the testfiles from “Documentation” and getting error: see attached file 2

I am also having troubles setting this up on openluup.
For me it is working with the test credentials, but not with my own.
After a while I realized that the client_mail I added under “share with specific people” in the calendar settings just disappears.
When arming the device I always get “Http error code: 403” which hints that there are permission issues.
How do I make the client_mail “stick” under my calendar settings?

[quote=“pls90, post:3, topic:198171”]I am also having troubles setting this up on openluup.
For me it is working with the test credentials, but not with my own.
After a while I realized that the client_mail I added under “share with specific people” in the calendar settings just disappears.
When arming the device I always get “Http error code: 403” which hints that there are permission issues.
How do I make the client_mail “stick” under my calendar settings?[/quote]

I understand what you mean.
Change back to “Classic mode”- here you only have “Share with specific people” - here the shared address is still saved.
In the “new” UI there is both “Access permissions” and “Share with specific people” - here the shared address is disappearing?

However, the calendar is empty for me?!
I created a new device from AltUI and it showing the same…

I tried again with the test file provided in the documentation and now I getting this error.
The file (GCal3Test.json) is already uploaded and I can see it under luup files.

Thank you for pointing out the different settings pages for new/old calendar layout.
Switching back to old design actually brought up the client_email address I had entered which was not showing in new design (still some kind of bug in new design?).
Regarding my error message (Http error code: 403) it didn’t make any difference though.
What looks fishy is the fact that I have set gc_debug to 3 but the log file (31-GCal3.log) has 0 bytes.
Is anyone running the plugin on openLuup successfully and willing to share their permissions that are set for the GCal files / directories? Thank you.

I run it successfully on openLuup. GCal3 directory has:

GCal3: total 12 -rw-r--r-- 1 openluup openluup 487 Jan 3 09:01 11GCalVariables -rw-r--r-- 1 openluup openluup 1704 Dec 31 09:34 GCal3.pem -rw-r--r-- 1 openluup openluup 2314 Nov 5 2016 GCal3.json

GCal3 under /etc/cmh-ludl:

drwxr-xr-x 2 openluup openluup  4096 Dec 31 09:34 GCal3

What’s in your openLuup log when you restart openLuup?

@jswim788, great, thank you! I did fumble with permissions a bit and got it working.
Alas, I quite don’t know which one it was that made the difference in the end.
Now I will have do a bit of reading how to put this to use :slight_smile:

Ran in to the same issue and even more frustrated that there wasn’t an answer in this thread!

So for those of you who can’t figure out why you’re getting Error 403 after following the instructions…

Visit https://console.developers.google.com/apis/ and add the Google Calendar API to your project!

[quote=“kalavo, post:9, topic:198171”]Ran in to the same issue and even more frustrated that there wasn’t an answer in this thread!

So for those of you who can’t figure out why you’re getting Error 403 after following the instructions…

Visit https://console.developers.google.com/apis/ and add the Google Calendar API to your project![/quote]

Along the way -(likely when google changed the UI last) – the service account instructions omitted the need to enable the Google Calendar API.
I have added it back in (as the first step). Thanks for pointing it out.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules