Subcategory_num of devices

Hello all,
Is there really no way to change the device category so that it sticks. I have a relay (Linear FS20Z-1) that I use to turn my porch light on or off automatically at night; it obviously shows as a ‘relay’ in the UI7. On the other hand, I have a light-switch that controls a receptacle-outlet into which is plugged a camera; it shows as a light-bulb in the UI7. Now in the dashboard, when I click “turn all lights off” it turns off my camera (which I don’t want to happen) and of course it does not turn off my porch light via the relay (which I wish it did).
I tried manually changing the device category and subcategory_num (in Advance-parms) so that the relay would be seen as a light-switch and vice-versa but they eventually revert back to their original values (at the next engine reload?). I also tried changing the device_type, device_file and device_json but they eventually revert back to their original values. I also read somewhere that I should change the device settings “automatically configure” to NO, but that did not help. Those values that I change in Advance-parms always eventually revert back. I found several other posts on this subject but they are old posts and did not help. I vaguely remember reading an old post mentioning some kind of table of values that was stored in the controller somewhere but I cannot find this post anymore. Anybody else has this problem?
Thx
Claude

Some of the device files (D_<device_type>.xml) will define the device category and subcategory but unfortunately there doesn’t seem to be any consistency about this. Of course if this was the only place they were defined than changing that definition there would impact all devices of that type. Like so many things in the Vera environment there’s no clean way to come up with a solution. Perhaps you could create your own device file, setting the categories to what you need and assign that device file to your device in the params tab.

Thanks. I’m pretty sure I already tested to change the device_type from “urn:schemas-micasaverde-com:device:Relay:1” to “urn:schemas-upnp-org:device:BinaryLight:1” one my device but it reverted back to the original value, But I will try again just to make sure. Thank you

I tried again just to be certain but it did revert back to its original value … Plus, when I do this, it seems to change my device number to a new number as it reverts back to the device_type, so all my scene (with this old device number) no longer work and I have to fix them.
So to go back to problem at hand, is there no solution to this?

Nothing? Really nothing??

A quick search answers this question, almost any device category change is reverted after a Luup reload. So in short the answer is no you cannot permanently change a device category.

Thank you for your prompt reply… If you read my original post, you would see that I did several “quick search” [I found several other posts on this subject but they are old posts and did not help] .Also, can anyone at vera acknowledge that this is a real problem with the dashboard? I am not being petty and complaining about the looks of the application icons, it is a real functional issue with the dashboard “shortcut”… Because when I click “turn all Lights off” in the dashboard, it turns off “non lights” switches. I can’t believe that I’m the only one with this problem.
Thx.
Claude

While you can’t probably fix the relay, you can set the subcategory to 4, 5, 6 or 7 and remove the binary light from the turn all on/off.

Look at the wiki for the exact values.

It worked for some of them, but others reverted back. But thank you, I will accept this flaw in the UI7 and I will teach my wife to “unlearn” to use this dangerous dashboard button

If I remember correctly, you could alter the json file and stop forcing it. What’s the json file reported? I could take a look and suggest the edit.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules