Upgrading Two Vera3 to Two VeraPlus

So I’m getting close to making the leap. I’ve read through the “official” Vera document on moving from Vera3 UI5 to VeraPlus UI7 and Richard Shaefer’s tome on making the move. I’m inclined to the “official” version as it SEEMS to make life as easy as it will be. I’ve read through most of the posts on the forum, both the success and the horror stories. I’ve copied out any Startup LUA in the APP section and in the PLEGs so I guess I’m about ready.

Just a few niggling little areas of concern.

  • Richard mentioned he had Leviton devices where all of my wall switched and outlets are GE/Jasco. Are they going to come over without a lot of hassle?

  • I have a number of Aeon relay switches and MonoPrice single and dual relay switches installed in hard to reach outside boxes for security lights and camera power. Anyone have any experience with these and the transition?

  • I have a number of PLEGs running on the two Veras.
    ** What happens to the licenses on these … as I recall they are tied to the unit serial number which means the minute they move they stop working?
    ** Do the PLEGS come over clean with all the correct device names, ids, references and logic in tact? Or am I faced with a massive editing job?

  • The two Veras talk to each other using HTTP to do things such as set MultiSwitches in the other unit to pass control and status information to each other. I’m confident the HTTP command system will continue to work but will the device numbers and references remain the same or am I going to have to edit every one of them? Similarly status is passed from my Blue Iris system to one of the Vera using HTTP commands so if the device numbers and references do not remain they will have to be edited in Blue Iris as well?

Both Vera 3 units have the external antenna mod. I have one ZWave sensor installed in the curbside mailbox about 75 feet from the Vera 3 which currently works fine but without an external antenna will the VeraPlus see this guy?

I set up one Vera Plus with temporary installations of the various plugins so I could play with the configuration controls and make sure they all initialized. So far that appears to have worked properly and everything at least installed and started up without complaints.

Thanks for any info on these questions, I really appreciate your input.

John

I’m in a similar situation. 2 Vera 3’s but going to a Plus and an Edge.

The http call setup works just fine between the Plus and the Edge (actually between the Plus/Edge and the Vera 3’s as well) however, unless you to a backup on the 3 and restore to the Plus, your device numbers will change forcing update on all http calls. If you want to go the ‘clean’ way by unpairing a device from the Vera 3 and then pair it to the Plus chances are very large it will receive a different device ID.

I’m noticing the z-wave antenna on the Plus being stronger than the default one on my Vera 3. It’s able to pick up a MonoPrice PIR sensor in the master bedroom without any relays in between and does so reliably and consistently. From what RTS posted a while back, the antenna mod is a no go on the Plus as it uses a different internal antenna than the Vera 3.

I can’t comment on PLEG as I don’t use it but posts do indicate you’ll have to get a new license.

I’ll be following this thread closely.

Thanks.

The backup/restore is part of the Vera document so that sounds good. I’m a bit surprised that the backup/restore will work from UI5 => UI7, I thought there were a number of internal changes that required the source to be on UI7 as well. But the Vera document is specific to UI5 =UI7 so maybe my concerns are overblown.

Thanks again for your input…

UPDATE
In reading through the docs again its clear the source controller must be on UI7 so I guess I misread it. Sorry

There is a Vera 3 UI5 -> Vera Edge UI7 direct upgrade procedure on the Vera site.
http://support.getvera.com/customer/en/portal/articles/1840699-to-veraedge-from-ui5-on-veralite-vera-2-or-vera-3

Is the Vera Plus sufficiently different than Vera Edge that this procedure will not work for Vera 3 UI5 -> Vera Plus UI7?

In reading further it appears the device names do not get transferred over for non-Leviton devices where the names are stored in the device. So everything comes over as _Dimmer, _Switch, etc. rather than “Hallway Light Switch” and so on. Is this actually correct?

I would NOT transfer the Z-Wave network from a Vera 3 to a Vera Plus.

I have had weird things continuously happen.
It seems that people that are happy with there Vera PLUS start from scratch!

Like you I have a large number of devices in difficult to access locations. So besides getting out the ladder and screwdriver is there another solution?

I tried an experiment, I took a backup of one of the Vera 3 UI5 units and restored it as is to a Vera Plus UI7. I did not transfer the ZWave network, I just wanted to see if the backup/restore process brought over everything, device names, rooms, etc., despite the fact that the units are on different UI versions.

The transfer appears to have been completely successful. As expected the PLEGs failed as the licenses are tagged to the old serial number and all the logic contained in them failed because there were no actual ZWave devices present. Things such as iPhone Locator that are not physical device dependent worked immediately. The DSC alarm interface failed as expected because I did not enter the IP address of the DSC panel

Just wanted to thank you for taking the time to ask these questions, and report on experimentation, as I’ll soon be joining you in making this transition, and am eager to hear what you find.

Well I’m probably going to do one Monday so we shall see :slight_smile:

Sending positive vibes down the State for a succesfull conclusion. :slight_smile:

So much for “positive vibes” :slight_smile:

I tried making the transfer by first converting one of the existing Vera 3 from UI5 -> UI7. I entered the firmware url:

http://download.mios.com/rt3662_betafirmware/rt3662_Luup_ui7-1.7.2044-en-mios.squashfs

for the current release, running on my Vera Plus. But the simply download fails consistently.

Stuck again, contacting support :slight_smile:

My Vera 3 is on the latest Ui7 and it is version 1.7.830. Are you trying to install a Vera Plus/Edge firmware by any chance as my VeraPlus is on 1.7.2044. As teh Plus and Edge have the ZWavePlus chipset, the firmware is not compatible with the Vera 3 and Lite. (and vice versa)

Check the firmware download thread below. Then upgrade to the most current Ui7 its has for the Vera3 / veralite.
You can then let the unit upgrade itself the the current Ui7 firmware.

http://forum.micasaverde.com/index.php/topic,32278.0.html

Ah, that’s possible. I copied the link from the Vera support site but I may have copied the wrong one. its 5PM now so I think I’ll wait until Tuesday morning now so I have all day to suffer through the consequences of the “upgrade” :slight_smile:

This document

http://support.getvera.com/customer/en/portal/articles/1840699-to-veraedge-from-ui5-on-veralite-vera-2-or-vera-3

describes the upgrade directly from Vera 3 UI5 to Vera EDGE UI7.

I thought that Vera EDGE and Vera PLUS both supported ZWave+ so what’s different that this procedure won’t work for Vera 3 UI5 to Vera PLUS UI7?

[quote=“RichardTSchaefer, post:6, topic:193107”]I would NOT transfer the Z-Wave network from a Vera 3 to a Vera Plus.

I have had weird things continuously happen.
It seems that people that are happy with there Vera PLUS start from scratch![/quote]

Where did you find those two people? ;D

Joking aside when I went from Lite to Edge (ui5 to ui7, z-wave to z-wave plus) I also ended up starting over. I would recommend the same.

It was also like a house cleaning for me with plugins and everything. Didn’t want any back-end files that were unused to get in the way.

I first did Vera3 Z-Wave config with a controller shift to Vera Plus and renamed/recreated all of my automation.
This only saved me the actual exclude/include task for each Z-Wave device.

Instant status never worked properly.
After I tried to add/remove some devices to the Z-Wave configuration I kept getting the Z-Wave network hosed …
Last week it rebooted every 15 minutes with errors about the Z-Wave not starting up …

So I started from a Factor Reset and a new Z-Wave network. Re-included all of my devices and re-entered all of my automation. I have all of my day to day stuff done … No unexplained reboots and NO problems found …
I still have about 25 Z-Wave devices for lights in my Shop to do … I moved those Z-Wave devices over to my Vera 3 for now. But it’s pretty simple automation for those lights. (A grid of 6x4 lights)

I had a couple of Z-Wave plugs in a metal electrical box … It worked with Vera 3 and Antennae but the signal is two week for the Vera Plus … There just hanging outside the box until I replace it with a plastic box … it’s in an equipment room so there is no immediate need to fix this.

I have not heard of a single person that started with Z-Wave configuration on another device that is happy with it moved over to a Vera Plus (Via Z-Wave controller shift as MCV recommends)

Those that have re-included them directly on the Vera Plus are more likely to be happy.

Disappointing to say the least. It’s unfortunate that Vera doesn’t care enough to make sure that the process is seamless.
The Vera 3 I’m planning to convert first doesn’t have too many devices and all of them are readily accessible so manually reinstalling won’t be a major problem. But the big problem I’m still having Is stability and response time on the primary Vera with almost all the devices on it, some of which are Aeon and Monoprice relays installed in outdoor boxes for security lights and Wi-Fi camera power control, and other difficult to access devices.

Good news, I guess

The direct transfer Vera 3 UI5 to Vera Edge UI7 procedure works on the Vera Plus as one might expect. The previous attempt failed apparently because the two controllers were not close enough to each other. The doc specifies 2 feet so apparently the transfer occurs through mind control or something :slight_smile:

I transferred my Vera 3 UI5 to the Vera Plus UI7 and everything appears in tact with the exception of the PLEGs AND VERA ALERTS.

VERA ALERTS - apparently installed but does not show up anywhere on the DEVICE panel except in LIST mode, its assigned to a “ROOM” called “2Z Applications” but it does not show up and nothing I’ve done so far has revealed it. The USERS and PROFILES are present but none of the USERS are assigned in SETTINGS and NONE of the NOTIFICATION CONFIGURATIONS came over. The “ADVANCED” and “REGISTER” tabs are missing so I can’t even purchase a new license for it.

PLEGS:

  • I purchased a new license but I can’t get it to accept the license data.
  • NONE of the DEVICE TRIGGERS are present
  • NONE of the CONDITIONAL LOGIC is present
  • ACTION and NOTIFICATIONS are present but not none of the NOTIFICATIONS are assigned to any users because they apparently didn’t get transferred either.

ZWAVE:

  • The few actual ZWave devices came over intact and are fully controllable and reporting .

If I could get the PLEGS to activate perhaps I could find out it the TRIGGERS and CONDITIONS are actually still there or if I’m going to have to rebuild everything.

Interestingly the things that were supposed to transfer fine didn’t and the things that were supposed to be a problem, the ZWave, wasn’t. The GetVera.com stuff I expected to e a problem turned out fine whereas Richard’s stuff that I expected to come over fine didn’t.

The upside is that checking the Memory and CPU usage the Vera Plus has reduced it drastically.

                 MEM      CPU
Vera 3           95%     2-14%
Plus             54%     1-2%

If the problems thus far are a harbinger of the main Vera transfer I may need a few weeks and an other case or two of wine to get everything running again. I have 80 ZWave DEVICES, six PLEGs and LOTS AND LOTS of logic in them, VeraAlerts, and if I have to rebuild it it will take days.

[UPDATE 2]
VeraAlerts suddenly decided to show up when I accessed the VeraPlus via direct IP rather than through the GetVera gateway. However it still does not have ADVANCED or REGISTER tabs, the NOTIFICATIONS are gone and I am unable to assign USERS to PROFILES, tye selections don’t stick.

[UPDATE 3]
I had forgotten to update to the current UI7 version of Richards PLEG and AverAlerts Plugins. Once I did that I got the VeraAlerts running and managed to purchase new licenses and get them licensed. Everything looks to be in place, USERS, PROFILES, USER<->PROFILE relatationships and even all the NOTIFICATION CONFIGURATIONS

After updating the PLEG Plugins I tried Register it clears the screen but does not give any registration options. Reported to Richard and waiting to hear back.

[UPDATE 4]
After much gnashing of teeth and a few restarts and refreshes the system finally allowed me to access the PLEg Registration and I successfully registered the 2 PLEGS. I was able to set all the NOTIFICATIONS (they come over with no users selected)

MultiSwitch
Now I find that I can’t manually turn OFF a switch in a MultiSwitch. I can turn it on but it refuses to turn off. At this point I haven’t determined if they are also disabled for setting by program logic or HTTP commands but at this point its a no-go because I use a few for system control functions from ImperiHome tablets. Also I can’t change the button labels, they don’t take after a restart. I’ll investigate that later.

[UPDATE 5 14:29]
I’ve swapped IP addresses around to make the new Vera Plus the active second Vera and surprisingly everything I’ve tested seems to work.

DSC Alarm Interface
I had to move the DSC interface setting on the Vera 3 to a phony address as it doesn’t allow more than one device to access it. Tested and the Vera can arm and disarm the DSC. Tested from an unmodified ImperiHome panel and that also worked.

Arduino Interface
The Arduino subsystem interface even works so I’m doubly surprised.

iPhone Locator
Works

ImperiHome Interface
Works, I can control pages and send TTS to the panel

HTTP Command Communications
The Vera <-> Vera and Blue Iris <-> Vera HTTP interface appears to be working fine. My Vera <-> Vera Heartbeat appears to be working.

GCal
Surprise, even the GCal settings came over and it detects a temporary travel item I set.

UI7 Interface
I like it even less than the first time I saw it. Its wasteful of screen real estate, just generally “messy”

[UPDATE 6 20160727]
I put this in here to keep it all in one place. It looks like some of problems I had may have been related to accidentally using the Windows Edge browser. It looks like it really has problems with the Vera UI … and a lot of other things too :slight_smile: I made sure to use FireFox and everything has been going well since.

Its been almost 24 hours now and the new Vera Plus has performed without a problem SO FAR :slight_smile:

Tomorrow, Thursday I will probably tackle the other Vera 3, the one with beaucoup ZWave devices on it, lots of PLEG logic, etc.