Vera Plus- dropping devices after hours or days

I have had a Vera Lite for years and have been very happy with it. I recently bought a Vera Plus to upgrade and because the Dome water shutoff I bought is supported only with UI7. I have some Aeon labs switches and cameras. I as well as a Radio Thermostat CT30/CT50. The thermostat and especially the switches drop after hours or days. I get a “Can’t Detect Device”. I am really frustrated since I need something that is reliable as I need these devices to not drop off if I am away. These have always worked well with my Vera Lite (except the water shutoff since UI5 is not supported). So I know these work. I cannot have these drop off especially if I am away. I have these hooked up to a backup heater to keep pipes from freezing and also to shutoff water to the house.

Any ideas?


By drop off, do you mean that they are not controllable anymore or that they just are flagged by the vera UI? If you cannot be controlled any more, you may have a mesh issue and a zwave heal is probably the cause of the problem. This should not have been new though. Did you migrate or start your network from scratch when you moved to the Vera Plus?

Hi… Yes by drop off I cannot control anymore. They were controlable and working and then after hours or days, when I try to turn something on or off, it retries a few times and then gives an error “Can’t detect device”. I was able to solve it last time by unplugging the devices and then back in and rebooting the Vera. This does not do my any good when I am not here though.

I started from scratch given the issues I have heard people having. I paired the devices with the new VeraPlus and have a couple simple scenes. My setup is not complicated so was not hard to redo what I needed to. Is that all I need to do to start from Scratch? Like I said my setup is not complicated, but do need to able to control these devices when not here.

Thank you…

This is strange and I am wondering if you lose your devices overnight. If this is the case, you may be losing them because of a nightly heal where the zwave network is trying to reconfigure itself. You may need to strengthen your network mesh by adding a couple of AC powered devices like zwave power plugs close to the vera as its antenna tends to be a bit on the weak side.

Hi… Actually all of the devices are running off AC Power. Most are some old Aeon labs plugs off a house outlet model number DSC06106. These have worked reliably for years.

One is used to control a Rinnai heater in the basement which runs off a wall outlet in case it gets really cold or the furnace fails. I have a couple around the house and one even across the room from the Vera. I never had an issue with the Vera Lite.

The CT30 Tstat is right across the room and that does not run off batteries either. I have it hooked to an AC transforner. The Tstat I did have an issue with the Vera lite and never got it to work right so cant blame the Vera Plus on that one. Along with the water valve it was a reason I upgraded to the Plus.

With the water shutoff, I have another Aeon Labs outlet hooked to the water heater. That is in the basement so isnt really close but it loses connection after a while.

I wonder if I should start from scratch again and try again.

What I meant was to have more AC powered devices closer to the vera. It is possible that the zwave+ routing on your zwave (non plus) devices is a little different and that you need to strengthen the mesh. If you want to start from scratch, many people here have shared their experience of locating the devices in their final position and add them from the closest to the furthest from the vera and when adding, try to also start with locating the vera in its final position and bring the vera close to the device only if needed for inclusion. I have had bad experience with the vera’s antenna range to the point of losing devices by moving the vera by 2cm and getting it back by moving it back.

OK, thank you for the help… I think I am going to delete these and start from scratch. Many of these I did not necessarily have in the final location when I paired them including the vera itself.

Just overnight two outlets went offline and then by morning came back online again.

Thanks again for the help


try this to heal the network

Anecdotally. I’ve had exactly the same thing happen.
Ran on Lite / UI5 for 5 years - no issues ever.

‘upgraded’ to Vera Plus / UI7 - i get dropouts on half a dozen switches that previously used to be rock solid. I had support look at them, but they were frankly useless… I still have half a dozen switches which are red. And eventually just gave up…

Worst upgrade evar…

Steve… I take it you never got it working fully? I was pushed into this since the water shutoff I bought needs UI7 and didnt want to chance the upgrade on the Lite since people have had issues. can you repost the link. It is not working for me. Unless I am doing something wrong.


First: The Link -

In the link provided you need to change VeraIP with the IP address of your own vera. I tried the link too, and mine is like:… etc etc etc

It kicks off a ‘heal job’ - Which I believe is something that happens every night anyway. And didn’t solve my issues.

I take it you never got it working fully?
Nope - I never got mine working. My upgrade was actually performed by support. I was happy with the LIte / UI5. I had read the nightmare on the boards about the UI7 upgrade on the Lite and never did it - but the wife wanted Alexa control - and that required me to upgrade the Lite to UI7, took a backup of my Vera Lite - it failed to import into my Plus. Support faffed around with it for a while, and eventually got something up and running ( with some beta firmware which I understand got pushed out a couple of months after).

The disconnects came later… I had support look at them… Over some more days I’d get emails asking questions and they reset my device. I have additional issues which aren’t mesh related - things like I have some Evolve switches. One is a ‘main switch’ and two are ‘slave switches’ which don’t have a traveller wire and simply send a signal back to the Vera to tell it to ‘dim the main light’ - worked flawlessly under Lite / UI5 - utterly fails in Plus / UI7. Worse. one slave switch says ‘disconnected’ and the other ‘works… but it takes like a minute and a half to perform the dim’…

Support’s final resolution? Sorry - not supported. Change your switch or put in a request to have us look at getting them supported…
How that comes around when they worked under Lite / UI5 I have no idea.

Some sockets show disconnected. I have some sockets in my garage. One is inward facing, and right next to it is an external ( outside facing) socket. The internal shows as connected, the outside is disconnected - they are 2 inches apart.

A socket in my front room ( Vera is in the back room) now shows as disconnected. I can reset it… it comes back and then a few days later it’s disconnected again. Same with another socket in the dining room.

I gave up asking for help. I’m ditching Vera as soon as I decide on either a new hub or a new technology. I have a few of those wifi socket things now and might just make the leap to what I believe is a lesser - but ironically better supported - protocol.

Evolve/Linear/GoControl switches are all the same manufacture and … ABSOLUTE TRASH. I have posted about this a few times over the years. I originally installed more than 40 Evolve/Linear devices starting about six years ago.
In the last 3 years, I have now lost through various device failures over 25 switches of that manufacture. In fact, I have 3 failed devices in my wall right now in that have failed in the last two months waiting for replacements to be installed. Switches, Dimmers, Relays, Remotes, have all died and the rest will likely soon. If all your switches are Evolve/Linear, I would seriously look at those.

Examples of recent failures:

  1. Switch internal relays start ‘chattering’ every time a poll or configure occurs. Actually triggers the relay about 3-4 times a second. Luckily I have not had critical loads on these 4 devices that failed this way. (one is still in my wall)
  2. Devices (dimmers and switches) dropping offline. Forcing a reset or cycling power restores them temporarily, then drop back off. FInally, they just die. (about 10 devices)
  3. Devices that decide to just up and fail . Goes completely dead. Dimmer cut-off tab sometimes restores for a few minutes or just never comes back (about 5 devices)
  4. Devices completely wedging up the zwave network so that even other devices that normally are OK are dropping intermittently or delayed. A common pre-failure condition. Took those suspect devices out, and amazingly the mesh becomes stable and faster. (This may be your issue here)

I contacted Evolve and after they said they would contact their OEM, their VP went dark on me. No answer as to why chattering relays is a safe failure mode.

As these failied, I have replaced with GE/Jasco, the system has been rock solid. Only one device failure in over 2 years.

1 Like

I have the same issue with my Vera plus, one device will start giving me issues and if I dont catch it right away and delete the device and re add it then eventually over a few days all my devices stop responding and I get device can not be detected. I have around 13 Stelpro Zigbee thermostats and it usually starts with one of them and then the rest of my devices start failing. Support captured the logs and said they see the problem but it needs to be fixed in a future firmware update but they cant tell me when that will be. I asked them if I upgraded to the Vera secure would that fix my issues and they said no that it would happen with that controller as well. im looking at other controllers now as they have no idea when this will be fixed. I have many zwave switches and smart plugs and they all fail after a few days.

install Altui and check the quality of your connections

Beyond frustrating. I dont think this is operator error on my part, but I am trying to install ALTUI. I go to install apps and it pinwheels for a long time and the list is blank.


I might do a factory reset.

u have a veraplus?

Yes… Bought it back in February. I needed UI7 for the water shutoff I bought and did not want to brick the Vera Lite I had.

I think the page you sent for ALTUI said for UI7 install it using install app, but would have to go back and check

yeah its for ui7

I’m seeing this too. I think there’s a problem with the Install Apps function at the moment. It’s locked up my Vera twice now… Something’s up!

From what I have seen, if you log into the Mios servers, then the app list is displayed.