WaterCop valve with inverted status ON=closed OFF=open

Hi everybody !

I bought a WaterCop speric valve to be controlled via ZWave with my Vera Controller.

I add it as a general device, the controller detected it and add it ok. I actually can open and close the vale, but I have 2 problems:

  1. the status is inverted, so when the valve it is closed the switch in my vera panel is ON, and when the valve is open the switch in my vera panel is OFF
  2. when operating the valve via my vera controller, it operates it ok, but reports: “Sorry, the node reports it’s busy. Please try again” The message never desapear.

I read in the f?rum and tried to change the configuration as relay, and it happeneds the same.

Can you Help me?

Thanks in advance !

Marcelo.

Hi,

Wow, I just posted the exact same thing. I have the same issues as you.

However, the off/on thing doesn’t bother me as I am using the “old” amazon echo Java utility on my synology NAS, which allows me to invert the off and on easily. So, when someone says “Alexa, turn on Misters” (I am using it to control my misting system) it actually sends the command to turn if off which opens the valve.

I love the old java app, I am even using it to control some other things around the house that accept HTTP commands and aren’t interfaced with Vera.

Hello,

If you’re using a WaterCop valve with Vera and the On/Off status indicator in the UI is reversed, inverted or backwards, You might find the solution below. I’ll also tell you how I changed the status icon to say Open/Closed as opposed to a light bulb that says On/Off. An important tip here is that if you want to do both, you must change the icon first. Otherwise, you’ll be un-pairing and re-pairing your device.

To change the light bulb icon and change the On/Off to Open/Closed:

Click on your device and go to “Advanced”.
Under “device_type” it will probably say, “urn:schemas-upnp-org:device:BinaryLight:1” - Change this to say “urn:schemas-micasaverde-com:device:Relay:1” (Thank you Don Diego)
Scroll down to “device_file”. It will probably say “D_BinaryLight1.xml” - Change this to say “D_Relay1.xml”
Scroll down to “device_json”. It will probably say “D_BinaryLight1.json” - Change this to say “D_Relay1.json”

To change/reverse the On/Off status:

Click on your device and go to “Advanced”.
Click on the “Variables” tab towards the top.
Scroll down to “Status”. (This number will probably be a 0 or a 1)
Click “Edit” to the right.
Reverse the numbers - if its 1 change to 0, if its a 0, change to 1 and click “save”. (This will reverse the on/off status)
Click the “Back” button in the UI. (Not the the web browser)
Click on “Settings”
Under “Automatically Configure” use the drop down menu and select “No” and click “Save”. (This will prevent it from changing back)

Hope this helps someone!

[quote=“Livebrain, post:3, topic:199030”]Hello,

If you’re using a WaterCop valve with Vera and the On/Off status indicator in the UI is reversed, inverted or backwards, You might find the solution below. I’ll also tell you how I changed the status icon to say Open/Closed as opposed to a light bulb that says On/Off. An important tip here is that if you want to do both, you must change the icon first. Otherwise, you’ll be un-pairing and re-pairing your device.

To change the light bulb icon and change the On/Off to Open/Closed:

Click on your device and go to “Advanced”.
Under “device_type” it will probably say, “urn:schemas-upnp-org:device:BinaryLight:1” - Change this to say “urn:schemas-micasaverde-com:device:Relay:1” (Thank you Don Diego)
Scroll down to “device_file”. It will probably say “D_BinaryLight1.xml” - Change this to say “D_Relay1.xml”
Scroll down to “device_json”. It will probably say “D_BinaryLight1.json” - Change this to say “D_Relay1.json”

To change/reverse the On/Off status:

Click on your device and go to “Advanced”.
Click on the “Variables” tab towards the top.
Scroll down to “Status”. (This number will probably be a 0 or a 1)
Click “Edit” to the right.
Reverse the numbers - if its 1 change to 0, if its a 0, change to 1 and click “save”. (This will reverse the on/off status)
Click the “Back” button in the UI. (Not the the web browser)
Click on “Settings”
Under “Automatically Configure” use the drop down menu and select “No” and click “Save”. (This will prevent it from changing back)

Hope this helps someone![/quote]

Thank you for this.
I was able to get the icon and words to change but the status is still inverted.
After selecting NO in the Automatically Configure drop down, there is no “SAVE” button to click. Am I missing something here?
When I reboot the controller and check, it still says NO so I am sure it is saving my selection, unfortunately the device is still inverted to the status of the Watercop valve.

Hi

Reversing it didn?t work for me. It looked like it would work until I issued the commannd from echo to toggle it, then it went back to off is actually on. I did save the changes.

Hi, I am new to the board and new to Vera. I was an avid ST user but decided to go to Vera for the integration to my DSC alarm panel. Works great ! but getting the Watercop to work properly seems to be a major problem shared by others.

I get the error 'Sorry the node reports its busy. Please try again later’. I see the controller for the Watercop and the Fortrezz WV-01 seem to be the same and the WV-01 manual is better. On page 7 the statement is made

Note: If the valve position is not known by the WV-01 (for example because the Valve is changing position, or because of a fault condition), the Basic Get will be ignored. The Water Valve will instead respond with a ZWave ?Application Busy. Try Again Later? transmission. I believe these are the same errors and it is being generated because Vera is setting up the valve as a light (which I see some including me change to a relay) however unlike in ST, the Vera does not seem to be reading (or properly reading) the actual #pwd4#out? of the valve.

The other nag is the reversal of the commands. Per the poster just before me, I tried the recommended steps to get it to change and it does until I command it and then it reverts.

MAN I like the DSC integration because it breaks out all of the zones into actionable sensors but this Watercop thing makes me not like Vera !!! Getting the Sonos to work is a pain as well but THAT is a different thread.

Any progress or comments on suppressing that error AND reversing the commands would be greatly appreciated !!

Oh, I see it now, thats the whole valve. Anyone have a link to the valve cores for both sides?

Sorry for the thread jack

Here is the information from Vera support on how to fix this issue:

To reverse the ON/OFF status of the valve you have to go to Devices > click on the ?>? button for the valve > click on Advanced > New Service and fill out the input fields as follows:

New service: urn:micasaverde-com:serviceId:HaDevice1
New variable: ReverseOnOff
New value: 1

click on Add > then click on Reload Engine.

Once the engine reloads the status should be displayed correctly. However you might also have to activate the valve in order for the status to update.

That worked! Thank you for letting us know. You get an applaud for that!

Now if we could only get rid of that pesky “Sorry, the node reports it’s busy. Please try again later.” notification.

I learned recently that this may be deep inside the Zwave protocol. A device really can respond and say “I’m busy, try again later” within the Z-wave protocol. See https://community.openhab.org/t/oh2-z-wave-refactoring-and-testing-and-security/21653/3789 for an example of it. Vera should do something intelligent in these cases, but it is interesting that the underlying message may be coming directly from the Z-wave device and isn’t something Vera is creating.

Sorry, can’t help you on that one as mine is not doing that. However, this may or may not help. I was having all sorts of issues with my Z-wave. 2nd tier support the one who helped me out with the reversal found that when I transferred my old vera to the new vera plus it changed my node from 1 to 17. He told me if the node is not 1 it can cause a lot of problems. However, it may also work. In my case it didn’t. I was told to reset the z-wave network and repair all of my devices again. It sucked, but it worked. If you have transferred from one vera to another, you might look at this as well.

Just played around a little more with this. Try using D_WaterValve1.xml and D_WaterValve1.json. This will change the icon to a water valve as well.

[quote=“wrk24wheel, post:8, topic:199030”]Here is the information from Vera support on how to fix this issue:

To reverse the ON/OFF status of the valve you have to go to Devices > click on the ?>? button for the valve > click on Advanced > New Service and fill out the input fields as follows:

New service: urn:micasaverde-com:serviceId:HaDevice1
New variable: ReverseOnOff
New value: 1

click on Add > then click on Reload Engine.

Once the engine reloads the status should be displayed correctly. However you might also have to activate the valve in order for the status to update.[/quote]

Thanks for this. I hate to admit it, but I just wasted the better part of a day, having used basically the same Variable entries from a different thread, that used the font that Vera does internally, displaying a capital “I” (eye) and a lower-case “l” (Ell) identically, as just a vertical line. I had deduced that the entry “serviceId” was actually “serviceld”, which resulted in a garbage entry that didn’t do anything. Once I entered it properly, using the capital “I”, the valve status is now properly displayed. Your choice of a better font helped me to discover the problem.

I post here only to possibly avoid any future frustration for anyone else trying to fix this problem.

Ok - so I performed these steps last fall and it worked pefectly to correct my reversed status. However, I’ve noticed recently that Imperihome shows it opposite, as in status 1 = open. I’m don’t see the service listed on variables and wondering if one of the updates corrected it on the vera end, but my 3rd party app is now showing incorrectly based on the service/reverse I added. Any ideas? TIA

Me too - I encountered the same problem a few days ago. It seems that Vera has “fixed” the reverse output of WaterCop/Fortrezz valves, so that the the Vera app properly shows the true valve status, but now Imperihome sees the output as reversed from reality.

I was hoping that I could edit the icon in Imperihome to select it to Invert the icon display, but unfortunately, the icon doesn’t respond to a long press, and can’t be edited, nor can a different icon be selected.

The valve reported status can still be reversed with the use of the ReverseOnOff Variable in Vera, which corrects the display in Imperihome, but then causes Vera to display the opposite status. Lacking a solution, I’ve gone back and forth between those options to see which would be the least annoying. Currently, I have mine set to properly report the status in Vera, and I’ve removed the icon in Imperihome.

Maybe our only good solution would be if Imperihome could make a “fix” as Vera did to report the correct valve status.