Whisper error

Hi,
I moved my datayours folder between NAS recently, and whilst they seem to update, I get the following error when trying to use the Whisper tab on the datayours dashboard.

[string “module (“L_DataWhisper7”, package.seeall)…”]:574: Unable to read archive 2 metadata from ‘/nas/Vera-45103575.200.urn^micasaverde-com^serviceId^EnergyMetering1.EnergyUsage.wsp’

Can I fix this?

Thanks

You have modified the LOCAL_DATA_DIR to reflect any change and changed the mount command for the NAS appropriately?

I have the same folder name/structure on the new NAS, I copied the whole directory structure over. Then changed the startup mount command on the Vera to point to the new NAS. I can see it writing to the new folder so it’s seeing that the mount ok. I didn’t change anything in data yours

Is it possible that that particular file has been corrupted? Does everything else work? You could PM me the content of that file to check.

Hi,
The spare time I have had for Vera I have been playing with Alexa and getting that working, plus my actual automation. Now I am back to wanting to get the logging working properly. Am I missing something, how to I PM a file through the forum, or do I need to send via email?
thanks
Simon

From the file excerpt you sent, it looks very much as though the archive header has been corrupted.

I would theorise that this has occurred because you copied the old files to the new NAS with DataYours already running and writing to that… but I might be wrong?

Suggest you stop DataYours, or take the NAS offline, restore the data from the old NAS, and then restart. You will, of course, lose what you have written since. Because of that you might back up what you currently have, but I couldn’t guarantee we can reconstruct it because I suspect that the archive configuration currently being written doesn’t match that of the original files.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules