Wifi not reconnecting after router reboot

The VeraPlus’s wifi connection can’t seem to survive a router reboot. It will not resync to the wifi, even with a power cycle. I have to connect an ethernet cable and let it give my PC a address, then re-select the same Wifi network.

My old Vera3 did not have this issue,

Is this a known problem?

Yessssssss, the vera connects to your wifi on a specific channel…if the channel changes it does not connect…known issue…they (whoever is in charge here) don’t seem to care.

1 Like

For real? A wifi system that can’t deal with a changed channel, on their latest model? That has to be a joke…

1 Like

Hey there,
If the problem goes away after connecting through ethernet, there’s a good chance something is interfering with your wireless.

1. How to solve

  • Avoid wireless networks when you can’t afford disruptions (i.e. keep your computer plugged into ethernet).
  • Reconnect to wireless and turn off devices that might be causing interference. Track whether anything changes after a device is powered down.
  • Change the router’s WiFi Channel and see how performance is effected.

2. Bad Hardware

It’s possible for cords, modems, routers, and other network ingredients to fail and negatively affect network performance.

Hope I could help,
casita24

Nothing wrong with my wireless. I use auto channel selection, which is common. The problem is the Vera, it’s unbelievable that this thing cannot deals with a changed Wi-Fi channel but that’s the case. I can induce the problem as follows:

  1. Connect the Vera to my router via Wi-Fi 2.4ghz channel xxx
  2. Power off the Vera
  3. On the router change the Wi-Fi 2.4ghz channel to some other number.
  4. Reboot Vera. It won’t connect.

The problem is 100 percent repeatable. If I lock down the Wi-Fi channel on the router, the problem doesn’t come back. None of the other wireless clients in my home have this issue,they all are able to resync to the router when it’s channel number changes.
It’s a big defect in Vera if you ask me.

That maybe true, however it’s probably best to use a WiFi channel scanning app and pick a 2.4ghz and a 5ghz channels that your neighbours aren’t using or has fewer nearby routers using those channels at least and set your router to use those channels.

I always disable auto channels on my routers as a matter of course.

Also if you havent already split the 2.4ghz and 5ghz radios, I’d recommend doing that also.

And it would be even better to hardwire the Vera hub with an ethernet cable rather than having it connected via WiFi anyway.

1 Like

I have over 50 wifi clients on the 2.4ghz band used mostly for IoT things and I generally reserve the 5ghz band for high performance devices like laptops/tablets/streaming devices unless they are far from the source (as 5ghz doesn’t have as much range). I use 802.11ax, not that it really matters here, just saying. The vera is the ONLY device I’ve ever seen or had that has this issue. It should work like any other wifi client… in the world… reconnect based on the SSID and password, not be bound to a specific channel#. Let the user decide if he/she wants to let the router decide on the channel or not. The purpose of auto-channel selection on any decent router is to automatically avoid the crowding problem and pick the channel with the best SNR, as there could be multiple channels to pick from and this could even change once in a while… that’s why we have routers with this feature.

yes, a hardline would “fix” the issue too, but the Vera is located in the central room of the house, one of two rooms with no hard line (and it would be difficult to add).

I have the same issue and thought it might be addressed in the latest firmware update or the previous one. I have not updated due to so many issues with the update.

I use ORBI for a mesh network within my house and the Vera Plus connects to one of the Orbi sattelites. However every time I lose power which can be a few times a month, the Vera Plus will not reconnect to the Orbis. I have to hardwire it to my network, reset the IP address and then reconnect it to the Orbi wifis. As stated above you would think this would work. I have the Vera Plus located in a location that does not have a nearby hardwired connection. I don’t want to move it to impact my zwave device visibility.

Try this if you haven’t already. Turn off your Veras own WiFi access points.

In the Vera Web GUI go to Settings - Net & WiFi

Scroll down the page under Wireless section and change 2.4ghz and 5ghz bands to NO.

Also whilst your in there make sure LAN DHCP server is turned off.

Does your Vera then auto re-connect to your own WiFi router / access points then OK? After the router has been rebooted or after your AP has been power cycled etc.

I’ve never connected a Vera hub to WIFI always used an Ethernet wired connection.

However this issue with auto channels has been raised before on the forums if you search, so it has been a known issue.

If my suggestion / guess above doesn’t work and remedy the problem. I recommend you both contact Vera support help desk and open a ticket about the problem.

In the meantime your only option if you don’t want to or can’t use Ethernet is to not use auto channels on your router and set a static channel number.

It does not work no matter what I do, if the wifi channel changes, then the vera is hosed. This is really not acceptable from a wifi compatible device, in my opinion. As I mentioned, I’ve got over 50 IoT things on the 2.4ghz band I have zero problems with them when the channel changes, except for the vera.

It’s of course true that a wired connection is sometimes better, but my optimal zwave room is pretty much the only room in the house that doesn’t have wired internet, plus, when you’re adding zwave clients it’s much easier to use wifi.

So you have turned off the access points on Vera itself?

When I didn’t have wired to my Vera, I used this: https://www.amazon.com/gp/product/B00TQEX8BO/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1 instead of the onboard wifi (wifi wasn’t supported until relatively recently). It is super easy to use, knows how follow channel changes, and my Vera seemed much more reliable when it thought it was on an wired connection (plus if you get into trouble, or if Vera forgets is wifii settings etc… it is just easier all the way around).
Note: set it up in client mode when using with Vera

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules