Failed to save system configuration

Hi,

I just bought a VeraPlus, but im struggeling a bit with setting it up.
Almost every setting I’m trying to change gives me the error message “Failed to save system configuration”. The change I made is displayed anyways, but is back to default the next time I log in.

Same thing happens if I try to create a scene.

Any clever things I could try to fix this?
Thanks!

Hi,

To get you sorted out please send us an email to support@getvera.com

Thank you!

How did this work out for you? Having the same problem on 1.7.2043… :’(

MCV has made some progress on the Saving state bug in the 7.15 release … but I guess they still have some more work to do.

Many PLEG users that had saving problems … were fixed in 7.15 … but not all … I was able to provide a patch to one person that was still having a problem.
But this only fixes the PLEG saving problem … and I had to work around another MCV bug in providing that patch.
The problem I noticed was a memory corruption … and I forwarded to MCV … because I do not know the scope of effected code.

I consider these types of bugs EXTREMELY SERIOUS … because the integrity of the Vera is in question.

You really need to call/email MCV.

I’m seeing “Failed to save system configuration” when I try and create or modify a scene since yesterday. I’m also seeing randomly when unchecking and checking the logging options. It was able to update scenes until then though I’ve been seeing other random errors since I upgraded my Vera Plus to 1.7.2044. I’ve already had support look it over once this week for previous errors. Note I still had to use the remote backdoor to ssh to see the logs and reset my root password after support cleaned it up.
In the logs I’m seeing repeated messages like
RAServerSync::SyncDevice alt 0 response 401 url https://vera-us-oem-device11.mios.com/device/device/device/50001335/localdevices with 35241 bytes
RAServerSync::SyncDevice failed
FileUtils::ReadURL 0/resp:401 user: pass: size 50 https://vera-us-oem-device11.mios.com/device/device/device/50001335/localdevices response: WWW-Authenticate: MMSAuth error=“invalid session”
that would make me think the problem is on the cloud end but my other 3 non upgraded controllers seem to be working OK though they have a lot less than 89 devices and 50 scenes on them. And these errors seem to happen even when I’m not trying to make changes.
Memory and storage look fine but I tried uninstalling some apps to try and reduce the load. No help.
Seems like the only option left is a reset and rebuild but frankly I’m to the point if I’m going to do that again I’ll get a HomeSeer eval and see how that goes. If I’m going to have to do this much DIY I might as well have it on a standard Linux distro on a box with real horsepower. Plus get the Alexa and IFTTT integration Vera still lacks so I can retire my SmartThings hub.

I just started getting the Failed to Save System Configuration error when updating the startup file. Never happened before. It’s followed by about 8 restarts.

Man, am I losing interest in swimming up stream with this company. I have a boat load of custom logic written. More and more I’m getting the sense that one day I’ll wake up and find out that all of my time spent learning Lua, writing code, and participating in this forum will be for nothing because the company will simply go out of business. They need to fire their lead software engineer, and if they don’t have one (yes, I’m suspecting), they need to hire one immediately.

Contacted Vera and they stated that everything looks fine on their end. They suggested I try using my local network, rather than remotely. I’ll test later today to see what I come up with.

To add to my rant, the guy from support I spoke with a minute ago must have learned English yesterday. I could only understand every 3rd word and he had to repeat everything nearly 3 times for me to understand. I’m used to talking to other countries for support, but this was the worse. On a positive note, at least they answered the phone.

Tried by bypassing their servers and updating the startup file on my local machine. No luck, still get the multiple reboots and the failed to save config error.

Tried to add an additional device action to an existing scene today and got the error. Never happened before. This sucks… Ticket is opened, but seriously… ::slight_smile:

Same thing happening to mine after the update.

Have you tried the latest beta ?

I tried the latest beta version.
I’ve got always the same problem : message “Failed to save system configuration” when I want to modify a scene where there’s a operator character as “&”.
So the problem isn’t resolved for me.

same here. anytime my Luup for a scene contains an &, it fails to save and dumps my changes

Maybe try replacing the ‘&’ with ‘%26’ or possibly surrounding it with single or double quotes, but frankly the issue is obviously the way that special characters are handled by the o/s. I know it’s a bit of a cop-out, but for now I’d avoid it by just using “and” instead… :wink:

I have the same problem with some LUUP code that I’ve had running for a year (its a vacation ghost scene). It doesn’t contain an “&”. Tried to make a simple change (after the latest firmware update) to the code and got the “failed to save system configuration” message. So I put the older version of the code back (I save all my custom code to a file and keep prior versions). Same message.

I take the code and run it under Apps/Develop Apps/Test LUUP code and it works fine.

Opening a case with customer care.

Attaching the code in case anyone is interested.

Hi,

At this moment I do all my code changes to scenes and start-up via ALTUI. That does not corrupt the code.

Talk about a guy they should be hiring. Amg0 is the one :wink:

Cheers Rene

Your only real option is to move back or move to the new beta.

The current release has hosed the LUA scripts by inappropriately URL decoding data it should not have.

New release 1.7.2139 fixed this problem on my VeraEdge.

;D ;D

It’s only a partial fix … your lucky your code is working now.
I sent them an example that shows they are still screwing up the LUA code.

I decided to stop using the Vera3 as a slave and am just running VeraPlus. I’m running the latest version 1.7.2349 of firmware on VeraPlus and I saw the same thing. I revised a scene and my LUA code became garbage scrambled characters.

Now VeraAlerts stopped working even though I have the Plus registered on its own…

Man, this is really, really frustrating. How do these guys stay in business? Should I just sell off my Vera gear?

Has anyone come up with solutions to the UI7 VeraPlus issues?

© 2019 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy