OpenSprinkler Plugin Update for firmware 2.1.3+

v1?

[quote=“therealdb, post:119, topic:185261”]You have to set the variables as per the original plugin.
I’m busy finishing a new book, but I’ll take a look and write a guide in the next weeks.[/quote]

Thanks again. Anything I can do to help, let me know.

In the mean time. I have managed to get Vera to operate the OS controller (Disable/Enable) and it’s outputs (Valves) (On/Off) but unfortunately there is still no feedback on status of the OS controller or any of the outputs.
To do this I had to completely delete the OS add on and follow the first post on this thread.
http://forum.micasaverde.com/index.php/topic,29977.0.html

I ended up with the following and I can now enable and disable the OS controller and turn on and off any of the valves connected to that controller.
Remember the valves will turn on and then automatically off for the predetermined time set in the Variables tab called “ManualMaxMinutes” or you can turn them off before that time set via a scene or manually.

Great. I forgot to commit a new version with local icons. I’ll do next day since I’m travelling again.

If you are able to write a small manual, feel free to make a pull request or send it to me directly and I’ll publish it.

[quote=“therealdb, post:122, topic:185261”]Great. I forgot to commit a new version with local icons. I’ll do next day since I’m travelling again.

If you are able to write a small manual, feel free to make a pull request or send it to me directly and I’ll publish it.[/quote]

Everything is already documented on the first post to this thread, or the link I provided.
If there is anything I can further do, please let me know.
Thank you for your effort here.

Yep, I’ve been struggling trying to get this working and using the instructions from the first post and well… no bueno.

I tried installing the original app, overwriting the files mentioned in the first, and then uploading the two files from this most recent modification. Nothing works however.

As a final resort, I uploaded all the files in the most recent update and that just about killed Vera :slight_smile: Luckily I was able to uninstall the app and reinstall it. still no luck getting this working.

yeah it killed my vera as well === it loads abou 35 valves / zones that kills the vera

I found you’re supposed to put the password (not sure if it’s the hashed or clear text) into the I_OpenSprinkler1.xml file. Problem is I did that and it wouldn’t work. I did get it working once after I disabled the password on the controller but then I had to deny internet access to the controller.

When I went to start modifying the sprinkler names that killed it and now I can’t get it to communicate again. Been struggling with it since without making any file changes.

Edit: Got it working in UI7 on my Veraplus, with md5 hashed password and 6 zones

  1. Install the opensprinkler app and let it install the controller
  2. Add your IP to the device. Under Advanced - Variables, add your zones (2 are added by default)
  3. If yours works, abort. Proceed no further! For most though, it won’t work.
  4. Upload the 3 files from the first post in this thread.
  5. Note, the I_OpenSprinkler1.xml file will be uploaded again later but with the password modification
  6. Ensure your OS controller has “Ignore Password” enabled. At this point,
  7. Open the 2 files from therealdb’s github (D_OpenSprinkler1_UI7.xml and D_OpenSprinkler1_UI7.json)
  8. In Vera, go to the controller’s property and click Advanced. Change the device_file to D_OpenSprinkler1_UI7.xml
  9. Reload
  10. You should be ready to rock at this point.

To restore security

  1. Uncheck “Ignore Password” on your controller
  2. Open up “I_OpenSprinkler1.xml” in notepad or a true xml editor (this tripped me up till i just used a plain text editor)
  3. Look for the line “HASHEDPW = md5(PW)” and change md5(PW) to your hashed password in quotes
  4. for example: HASHEDPW = “bj289hgkadjfjashggjio2”
  5. To generate a hash I’d recommend doing it offline using an app but there are online generators too
  6. Save and upload the file

Done.

Now I just wish I could use these as a light switch so I could integrate them into Alexa, Google, or Homekit. I’ve got the older OS2.2 which doesn’t support IFTT. Although, now that it’s in Vera…

I didn’t tried with my Alexa, but it should work if you change category_num (3) and subcategory_num (3) to your device and do a rediscovery again.
Remember to not use all lights on/off, becuase you will change your spinklers status as well.

Will this be updated in the app section or do we have to manually install it?

Thank You

I don’t understand this one…
“Open the 2 files from therealdb’s github (D_OpenSprinkler1_UI7.xml and D_OpenSprinkler1_UI7.json)”

As I don’t own the code and no license was attached, I simply fixed it and uploaded on my GitHub with no guarantee I’ll work, etc. Unfortunately the original author seems to not reply to questions about this plugin, so I cannot “officially” take ownership of it.

[quote=“Viruta57, post:129, topic:185261”]I don’t understand this one…
“Open the 2 files from therealdb’s github (D_OpenSprinkler1_UI7.xml and D_OpenSprinkler1_UI7.json)”[/quote]

this is not necessary, if you set the proper variable via UI/LUA.

doesnt work on my veraplus crashed and had to do a reboot

for some reason my vera plus wnot accept it and it just crashes

I didn’t tested it with the latest firmware, but it should work OK. I moved away from using it, since I have invested in my own automation middleware, taking care of notifications and automations related to Open Sprinkler, but this should work OK out of the box. the setup is a bit convoluted, since you have to patch the official plugin. I’m not sure if @Sorin has any opinion about dead plugins in the store and an external dev taking over to fix things when no license is attached to the original code, but I’m eventuallu available to submit the fixes to the original plugin if that’s allowed.

is not that it doest work its just that its not reading the astatus codes propery

so when i use it produces the task handler message " OpenSprinkler : Error manually controlling valve Connection Issue" this only happen when resp in the code reads nill

if (resp == nil) then
return “ERROR”, nil, “Connection Issue”
end

local lul_base_cmd = http://192.168.15.130/cm?pw=a6d82bced638de3def1e9bbb4983225c&sid=0&en=1&t=1800

    if  lul_settings.NewModeTarget == "Disable" then
      lul_cmd = lul_base_cmd .. 'en=0'
    elseif lul_settings.NewModeTarget == "Enable" then
      lul_cmd = lul_base_cmd .. 'en=1'
    end

    local isOk, resp, err = os_http_call(lul_cmd)

    local taskHandle = TASK_HANDLE or -1

    if (isOk ~= "OK") then
      taskHandle = luup.task("Error enabling/disabling controller: " .. err, luupTaskReturns["Error"], MSG_CLASS, taskHandle)
    else
      taskHandle = luup.task("", luupTaskReturns["Success"], "", taskHandle)
      luup.variable_set("urn:fowler-cc:serviceId:OpenSprinkler1", "ModeStatus", lul_settings.NewModeTarget, lul_device)
    end

    if (TASK_HANDLE == nil) then
      TASK_HANDLE = taskHandle
    end

    debug("OpenSprinkler : SetModeTarget : Exit")
    return 4

the http response it

  1. Request Method:GET

  2. Status Code:200 OK

the text on the page displays

{“result”:1}

by looking at this code, you seems to use the old plugin files. you should upload them as per the previous posts, then try again. you can grab them here: https://github.com/dbochicchio/vera then go to Apps, Develop Apps, Upload Files and upload them all. if you them correctly installed, you should see a water valve icon, instaed of the original one. make sure to also save your MD5 password in the device variables.

did that a few time did not work … it crashed my vera even up to tonight

im gonna try again … is there any other help for this plugin

after about 2 years i was able to fix it using some of therealdb’s code
I_OpenSprinkler1.zip

all u have to do is upload the I_OpenSprinkler1.xml implementation file