Heiman HS1SA-Z Smoke Sensor

There isn’t a thread for this device, so this is now it.

I have just purchased on of these Heiman HS1SA-Z Smoke Sensor devices cheap off Aliexpress. The device is mini much smaller than I was expecting but its loud when pressing the test button.

http://www.heimantech.com/product/96.html

User manual

http://www.heimantech.com/uploads/2018/01/030813172350.pdf

Paired it to my Vera Plus as a Generic Z-Wave device and it was added as such to the UI7 as a Generic IO device with On / Off buttons.

The include / exclude button is within a small hole on the side of it so you need a pin to press it 3 times, I couldn’t see it initially and had to consult the user manual to find it.

You can easily change the device in to a Smoke Sensor in Vera.

image

In the device go to Advanced then the Params tab

Change the following fields

device_type: urn:schemas-micasaverde-com:device:SmokeSensor:1
device_file: D_SmokeSensor1.xml
device_json: D_SmokeSensor1.json

You should also change category_num to 4 (Security Sensor) and subcategory_num to 4 (Smoke Sensor) for the sensor to appear in the Vera Dashboard - My Modes section.

That’s all I have done with the device so far, I plan to create a Fire Alarm scene and test the sensor somehow and see if it triggers my scene ?

1 Like

Is this US spec only do you think?

Hmm just seen I can get them over here. Tempting.

C

It’s an EU one. They might sell US ones as well on Aliexpress?

Yes, I see I can get EU ones.
That led me down a path of finding other Zigbee devices…

Hmmmmm.

Cheers

C

I tested this smoke sensor today.

I have so far just created a basic Vera scene, to send my phone a Vera Alert “Smoke Detector Triggered” message.

The trigger in the scene I used was “Whenever Smoke Detector detects smoke whether is armed or disarmed”

I set fire to a post it note and blew out the flame and held the sensor over it.

It did take a little longer than I expected to trigger, but it went off OK and the Vera Alert was received on my phone.

I was also watching the sensor in my Imperihome app on the phone, the default icon for it is a greyed out fire. When it tripped the sensor, its status went from OK to Alarm! and the icon changed to a coloured fire icon.

So it works anyway.

I might pick up a Heiman CO2 sensor as well and put that one near my gas central heating boiler.

I also have couple of them (non branded) and they indeed work well. Beware of the included battery, mine died within a couple of weeks. The unit then beeps and flashes in a certain pattern. Took a while to figure out what was wrong. A fresh battery solved this :slight_smile:

Do you think it could be possible to trigger the alarm manually (without the button)? In that case i could pair them in a scene and make them all go off in case 1 detects smoke.

@Catman
There are zigbee versions available as well

1 Like

Good question but Im not sure if it’s possible to manually trigger other smoke sensors as well.

I have a few of these smoke sensors as well. Any idea why i do not have the battery status?
image

Not sure you should have a Battery Level variable under the devices Advanced settings in the variables tab.

Have you tried excluding and pairing the device to Vera again?

I didn’t do anything to have the battery status showing it just worked first time.

image

A bit confused, my sensor is not listed on the “Preset Modes” settings page after configuration, shouldn’t it?

My Smoke Sensor isn’t listed on the Dashboard Modes page either.

Just changed category_num to 4 (Security Sensor) and subcategory_num to 4 (Smoke Sensor), got it to show up on the Modes Page. But it is now shown as “tripped” = 1.

Go in to the Smoke Sensors Advanced settings and Variables tab and change the Tripped field from 1 to 0.

Just looking at mine the category_num is 11 and the subcategory_num is 0 currently.

I just changed them both to 4 and now my Smoke Sensor is appearing under My Modes in the Dashboard !

Changed device_json: D_SmokeSensorWithTamper1.json to D_SmokeSensor1.json, There seems to be no tamper sensor in the device? I also reset the tripped fields to 0. Will test the device to see if it will both trip and untrip when activated when the house is empty next time.

No I don’t believe there is any tamper function on this device.

My device_json is also currently set as:

D_SmokeSensorWithTamper1.json

Seems logical to use D_SmokeSensor1.json, hopefully this may solve the problem with untrip not beeing registred. I noted this as changing house modes after fixing the categories to smoke sensor resulted in an alarm state…

Can’t say I’ve noticed any issues with my Smoke Sensor not untripping.

It’s gone off a few times since I installed it, mainly due to my bad cooking and burning stuff.

Hi. Hopefully someone can help here. I had 2 of these smoke sensors and one died last week. So within warranty I got a new one today. But, after adding a new generic device I only got 1 device in Veraedge.

Old
old

new
new

So not very usable. Any idea? I already tried an exclude/include twice.

What is the problem? The new replacement smoke sensor is not appearing in Vera at all?

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy